LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-14-2005, 06:23 PM   #1
D4ve G
Member
 
Registered: Jun 2005
Location: Canada
Distribution: XP / Ubuntu
Posts: 55

Rep: Reputation: 15
Second Harddrive FAT32


Solved.

I had to chown the directory.

www.gentoo.org

Last edited by D4ve G; 07-20-2005 at 11:43 PM.
 
Old 07-14-2005, 07:24 PM   #2
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
The hard drive won't just "appear" in fstab. You need to add it there. The line to add depends on the filesystem used and the way the drive is connected. Please post more details.

Last edited by stefan_nicolau; 07-14-2005 at 07:26 PM.
 
Old 07-14-2005, 07:29 PM   #3
D4ve G
Member
 
Registered: Jun 2005
Location: Canada
Distribution: XP / Ubuntu
Posts: 55

Original Poster
Rep: Reputation: 15
Ok I added it but I can only write to it under root. How can I change this?
 
Old 07-14-2005, 07:36 PM   #4
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
Use the uid, gid, and/or mode mount options (see man mount) to restrict access to non-unix filesystems like fat32.
 
Old 07-14-2005, 08:13 PM   #5
D4ve G
Member
 
Registered: Jun 2005
Location: Canada
Distribution: XP / Ubuntu
Posts: 55

Original Poster
Rep: Reputation: 15
I tried using the chown command unmounting and then mounting it again and I'm having no luck.
 
Old 07-14-2005, 08:16 PM   #6
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
Quote:
Originally posted by D4ve G
I tried using the chown command unmounting and then mounting it again and I'm having no luck.
Did you read my post? I said to "use the uid, gid, and/or mode mount options (see man mount) to restrict access to non-unix filesystems like fat32."
The only thing to do with chown/chmod would be to change the mount point's permissions , if it is what you want. Using chown on files on a fat32 partition is useless.
 
Old 07-14-2005, 08:43 PM   #7
D4ve G
Member
 
Registered: Jun 2005
Location: Canada
Distribution: XP / Ubuntu
Posts: 55

Original Poster
Rep: Reputation: 15
Ok Chown worked. Thanks for the help. Bye.
 
Old 07-15-2005, 01:56 AM   #8
Andreas Huppert
LQ Newbie
 
Registered: Nov 2004
Location: Freising, Germany
Distribution: Fedora 3
Posts: 6

Rep: Reputation: 0
You must add a line like
/dev/hda3 /dos-drive vfat defaults 1 1
to fstab and the mount-point must be present as well.
 
Old 07-15-2005, 02:04 AM   #9
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
http://ubuntuguide.org/#automountfat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fat32 Harddrive errors, causing system instability redness Linux - Hardware 2 02-01-2005 03:49 AM
Installing linux on 2nd harddrive(dual boot) windows on seperate harddrive lysol Linux - Software 25 08-03-2004 09:33 AM
External harddrive FAT32- VFAT options (uppercase to lowercase file name translation) pauquetb Linux - General 1 03-20-2004 12:52 PM
Need to replace full harddrive with new, larger harddrive pearlr Linux - Newbie 1 01-02-2004 12:59 PM
recovering a fat32 harddrive kingswood76 Linux - Hardware 1 07-24-2002 11:47 PM


All times are GMT -5. The time now is 03:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration