LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-08-2006, 07:46 AM   #1
jaymoney
Member
 
Registered: Mar 2006
Location: Cincinnati, OH
Distribution: Ubuntu 8.10, Xubuntu 8.04, Fedora 10
Posts: 87

Rep: Reputation: 16
Question screen resolution issue


I am having problems with my screen after installing *ubuntu. The max resolution i can choose is 800x600, but this leaves a large black boarder around the desktop which significantly shrinks the useable desktop space. I was wondering how i can configure the screen resolution so that it is 1024x768, which was a resolution option when i was running a Vector Linux live CD. Would changing the resolution fix the black boarder problem? This is an old P2 Compaq laptop. I do not have these screen issues with my Dell D610 with the same version (Ubuntu6.06) installed. I wouldnt mind keeping Vector Linux but *ubuntu supports the PCI ethernet card i have installed.
 
Old 07-08-2006, 09:18 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Try editing /etc/X11/xorg.conf with a text editor (you'll need root privileges, so start the editor from console using sudo editorname where editorname is the editor of your choice. Once the file is open, scroll down until you find this line:

Section "Screen"

there are first some lines (identifier, device) but scroll down to the

SubSection "Display"

and to the line

Modes "1024x768" "800x600" "640x480"

where there are resolutions configured (you might have other resolutions) just add your favourite to the beginning of the list (as you see, resolutions are typed in quotes, "WIDTHxHEIGHT", separated by a space). Those are the available resolutions and are configured for every color depth; I suggest you add your favourite resolution to every depth (to every Subsection "Display"). The first resolution in the list is used if it's possible and the others can be switched using CTRL-+ and CTRL-- (usually using the numpad + and - signs; this works in most cases). When you're ready, save the file and exit editor, then restart your X (in some cases it works if you press CTRL+ALT+BACKSPACE, in some cases you need to use console and do init 3 && init 2 (ubuntu uses runlevel 3 as the graphical one; if runlevel 2 is also graphical, then you might try 4 or 5 instead of 2), and if everything else fails, you can either kill X or simply reboot. Reboot is not needed, but if you can't get your X down any other way, reboot does it

That should fix the border problem, but read some info about xorg.conf (man pages, google..) to see if you can use some other options too.
 
Old 07-10-2006, 07:18 PM   #3
jaymoney
Member
 
Registered: Mar 2006
Location: Cincinnati, OH
Distribution: Ubuntu 8.10, Xubuntu 8.04, Fedora 10
Posts: 87

Original Poster
Rep: Reputation: 16
i added other resolution choices in the xorg.conf but there was no change, i restarted the computer and still nothing. under system->preferences->screen resolution the only options i have are 800x600 and 640x480. anything else i can try?
 
Old 07-11-2006, 05:32 PM   #4
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Your problem may be that the video chip set in your old Compaq doesn't have a specific driver or that Linux doesn't recognize the chip set. This results in a generic "vesa" driver being used. This driver places limitations on resolutions. Look in your xorg.conf to see what driver is being used. Perhaps a driver is available for your video chipset. I believe that Compaq probably used Intel video chip sets.
 
Old 07-13-2006, 08:25 AM   #5
griv
Member
 
Registered: Jul 2001
Location: Saint-Cloud (France)
Distribution: Ubuntu 6.06
Posts: 35

Rep: Reputation: 15
I had the same problem with my laptop after installing Ubuntu 6.06. I found in my xorg.conf that VESA was used instead of SIS, which is the name of my video card. I replaced "vesa" by "sis" and I could get native resolution and others.
After replacing "vesa" by the name of your video card, maybe you will have to execute "sudo dpkg-reconfigure xserver-xorg", but I am not sure...
 
Old 07-13-2006, 06:11 PM   #6
jaymoney
Member
 
Registered: Mar 2006
Location: Cincinnati, OH
Distribution: Ubuntu 8.10, Xubuntu 8.04, Fedora 10
Posts: 87

Original Poster
Rep: Reputation: 16
i ended up fixing this problem. i had a driver installed for my video card, but i decided to try and change the driver to vesa, and guess what, got rid of the black boarders. thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i fix screen resolution / monitor choice while screen is pretty much unreadabl tinkerdog Fedora 2 09-08-2006 04:53 AM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 02:33 AM
Major screen resolution issue JimBass Linux - Newbie 5 06-05-2004 09:02 PM
Screen scolling problem / resolution issue? - Mdk 9.2 Ragnaar Mandriva 2 02-17-2004 05:02 AM
Unable to configure screen resolution for 15.2" LCD screen in Fedore Core 1 schu Linux - Newbie 3 01-02-2004 06:39 PM


All times are GMT -5. The time now is 02:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration