LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   RPM 4.4.2.3 make issues (http://www.linuxquestions.org/questions/ubuntu-63/rpm-4-4-2-3-make-issues-842878/)

suryaemlinux 11-07-2010 12:43 PM

RPM 4.4.2.3 make issues
 
Hi,
I'm using Ubuntu 10.04 and trying to compile RPM 4.4.2.3 source. I received the following error and I dunno what to do with that. My gcc version is 4.4.3 and make version is 3.81

/usr/lib/libbeecrypt.so: undefined reference to `GOMP_parallel_sections_start'
/usr/lib/libbeecrypt.so: undefined reference to `GOMP_parallel_end'
/usr/lib/libbeecrypt.so: undefined reference to `GOMP_sections_next'
/usr/lib/libbeecrypt.so: undefined reference to `GOMP_sections_end_nowait'
collect2: ld returned 1 exit status
make[3]: *** [rpmdb_archive] Error 1
make[3]: Leaving directory `/root/Downloads/rpm-4.4.2.3/rpmdb'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/root/Downloads/rpm-4.4.2.3/rpmdb'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Downloads/rpm-4.4.2.3'
make: *** [all] Error 2


Thanks for your help

stress_junkie 11-07-2010 01:08 PM

RPM v4.7.2 is available in the Ubuntu 10.04 repository. Why not just install it from there?

knudfl 11-07-2010 03:11 PM

RPM 4.4.2.3 : This is the RH EL5 / CentOS 5.5 default rpm version.
The SRC RPM source code includes 37 patches. Some are for bug fixing.
The error, you show, is the first of the many errors.
'export CC=gcc-4.1' before configuring (./configure) will fix it.
Will not fix all the other errors. Compiling is not possible on Ubuntu, AFAIK.


If you really think, you need an old 'rpm-4.4.2', you can do :
1) Remove all rpm, librm with Synaptic.
2) sudo dpkg -r libbeecrypt-dev
3) sudo dpkg -r libbeecrypt7
.... Those cannot be removed with apt : Will then install rpm-4.7.
4) sudo dpkg -i libbeecrypt6_4.1.2-6build1_<arch>.deb
5) sudo dpkg -i librpm4.4_4.4.2.1-1ubuntu6_<arch>.deb
6) sudo dpkg -i rpm_4.4.2.1-1ubuntu6_<arch>.deb
.... Where <arch> is i386 or amd64.
The packages are from Ubuntu Hardy http://packages.ubuntu.com/hardy/rpm
....

suryaemlinux 11-08-2010 01:10 PM

Quote:

Originally Posted by stress_junkie (Post 4151961)
RPM v4.7.2 is available in the Ubuntu 10.04 repository. Why not just install it from there?

Well, a good question. I must have RPM v4.4.2.3 to make my LTIB work. As a matter of fact, I already have 4.7 or so in my system. I should downgrade that before installing LTIB.

Thanks,

suryaemlinux 11-08-2010 01:11 PM

Quote:

Originally Posted by knudfl (Post 4152023)
RPM 4.4.2.3 : This is the RH EL5 / CentOS 5.5 default rpm version.
The SRC RPM source code includes 37 patches. Some are for bug fixing.
The error, you show, is the first of the many errors.
'export CC=gcc-4.1' before configuring (./configure) will fix it.
Will not fix all the other errors. Compiling is not possible, AFAIK.


If you really think, you need an old 'rpm-4.4.2', you can do :
1) Remove all rpm, librm with Synaptic.
2) sudo dpkg -r libbeecrypt-dev
3) sudo dpkg -r libbeecrypt7
.... Those cannot be removed with apt : Will then install rpm-4.7.
4) sudo dpkg -i libbeecrypt6_4.1.2-6build1_<arch>.deb
5) sudo dpkg -i librpm4.4_4.4.2.1-1ubuntu6_<arch>.deb
6) sudo dpkg -i rpm_4.4.2.1-1ubuntu6_<arch>.deb
.... Where <arch> is i386 or amd64.
The packages are from Ubuntu Hardy http://packages.ubuntu.com/hardy/rpm
....

Thanks for your reply. Let me try this out and reply you.


Thanks,

knudfl 11-08-2010 02:28 PM

I did compile some parts of LTIB once on Ubuntu 8.10.
which has the rpm version, you ask for, 4.4.2.3.

Ubuntu 8.10 packages : "The old archive"
http://old-releases.ubuntu.com/ubuntu/pool/main/r/rpm/


LTIB Ubuntu http://www.imxdev.org/wiki/index.php..._config_ubuntu
..

suryaemlinux 11-08-2010 02:47 PM

Quote:

Originally Posted by knudfl (Post 4152912)
I did compile some parts of LTIB once on Ubuntu 8.10.
which has the rpm version, you ask for, 4.4.2.3.

Ubuntu 8.10 packages : "The old archive"
http://old-releases.ubuntu.com/ubuntu/pool/main/r/rpm/


LTIB Ubuntu http://www.imxdev.org/wiki/index.php..._config_ubuntu
..

I tried 4.4.2.1 rpm package as well (Not .deb install but make) it failed at the same place as well. Let me try it out with installing .deb packages.

suryaemlinux 11-08-2010 08:52 PM

Quote:

Originally Posted by knudfl (Post 4152912)
I did compile some parts of LTIB once on Ubuntu 8.10.
which has the rpm version, you ask for, 4.4.2.3.

Ubuntu 8.10 packages : "The old archive"
http://old-releases.ubuntu.com/ubuntu/pool/main/r/rpm/


LTIB Ubuntu http://www.imxdev.org/wiki/index.php..._config_ubuntu
..

Hi,
Thanks for your input. Installing rpm 4.4.2.3 done the trick. As you mentioned, I installed libbeecrypt6_4.1.2-6build1 as well. Now, I'm done with my LTIB installation.

Thanks a lot, man.


All times are GMT -5. The time now is 04:35 AM.