LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Restricted Nvidia drivers not listed in Hardware Drivers (8.04 Hardy Heron, liveCD) (http://www.linuxquestions.org/questions/ubuntu-63/restricted-nvidia-drivers-not-listed-in-hardware-drivers-8-04-hardy-heron-livecd-653567/)

shroomy_bee 07-04-2008 08:45 AM

Restricted Nvidia drivers not listed in Hardware Drivers (8.04 Hardy Heron, liveCD)
 
Wanting to test the nvidia drivers work before installing to hard drive,

I can see where in the file manager the restricted drivers are,

but the Hardware Drivers lists nothing at all, so I can't Enable them.

Also downloaded Nvidia's own linux driver,

http://www.nvidia.co.uk/object/linux....14.05_uk.html

but (1) it gives me 'permission denied' when I try to copy or move it to Ubuntu from a USB save (even when I am logged in as root, so I maybe need to chmod it)

& (2) the advice here

https://help.ubuntu.com/community/NvidiaManual

says it's best to use Ubuntu's provided drivers first anyway, before trying out the one Nvidia provides - or at least that's what I take this to mean:

"Obtaining Needed Software


Before you begin, it is strongly advised that your already have Xorg working acceptably with the 'nv' drivers included."


So I'm not sure how to proceed. Tried here too,

https://help.ubuntu.com/community/Bi...erHowto/Nvidia

and in answer to the Prerequisites listed, - I'm wanting to enable the full 3D (eg: running some of Ubuntu's games and screensavers I can see that the graphics are very slow / dropping many frames, plus the Hardware Testing does not show up the testcard bars),
I get a line of text to print out from that command given,
and the card is a 8600GT.

Again though, the guide there is saying to Enable the provided drivers using Hardware Drivers, and I can't because they don't show up there!


cheers for any advice for this.

I'd prefer to try the Ubuntu provided drivers first, & see how they do with the card.

jdines 07-04-2008 09:55 AM

A couple of things you need to know ...
 
" ... it gives me 'permission denied' when I try to copy or move it to Ubuntu from a USB save (even when I am logged in as root, so I maybe need to chmod it)"

The Live CD mounts are Read Only. You will need to install to the Hard Drive first, then reboot and continue to install the drivers from NVIDIA.

"I get a line of text to print out from that command given, and the card is a 8600GT."

You may need to install a driver that is for a similiar card, if there is not one that matches exactly. For example, on my Mandriva system the card is identified as GeForce 6100 nForce 430, but I use the driver listed as NVIDIA GeForce FX to GeForce 8800.

jay73 07-04-2008 04:07 PM

Don't worry about those drivers, should be a piece of cake. Simply do the install and then enable the proprietary drivers from System > Administration > Hardware drivers. No manual install required at all unless you are using the 9xxx series.

shroomy_bee 07-06-2008 10:11 AM

I kinda suspected that but wanted to test it out first on the CD. Ah well then, installation first! Thanks.

silkstone 07-06-2008 10:16 AM

You should have no problem with the 8600GT - it is supported by the restricted nvidia driver (the one for newer cards) in the Ubuntu repos, and you should be invited to install it automatically as soon as the full Ubuntu install is complete.

There are some very good guides to setting up full multimedia support once you have Ubuntu up and running. The following link is especially good - if you follow it carefully you should be fine. The tutorial looks longer than it really is, as it covers all versions of Ubuntu.

http://ubuntuforums.org/showthread.php?t=766683


All times are GMT -5. The time now is 09:21 PM.