LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 06-03-2005, 02:22 PM   #1
bengoodger
LQ Newbie
 
Registered: May 2005
Location: Lostwithiel, Cornwall, Great Britain
Distribution: Ubuntu
Posts: 20

Rep: Reputation: 0
Angry Really, REALLY wierd networking issue...


My Hoary box isn't connecting correctly to the Internet. I have disabled ipv6, etc. Apparently I need to use an MTU of 1400, but can't find out how to. Can anyone tell me how?

Thanks.
 
Old 06-03-2005, 02:29 PM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally posted by bengoodger
I need to use an MTU of 1400, but can't find out how to.
Code:
ifconfig eth0 mtu 1400
and according to this you make it stick by editing your /etc/network/interfaces...


Last edited by win32sux; 06-03-2005 at 02:35 PM.
 
Old 06-03-2005, 02:39 PM   #3
bengoodger
LQ Newbie
 
Registered: May 2005
Location: Lostwithiel, Cornwall, Great Britain
Distribution: Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks.

ifconfig not only brings down the connection, but doesn't change the mtu to any effect (synaptic still doesn't work, etc). I'll try booting into ubuntu and changing the interfaces file.
 
Old 06-03-2005, 02:53 PM   #4
bengoodger
LQ Newbie
 
Registered: May 2005
Location: Lostwithiel, Cornwall, Great Britain
Distribution: Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 0
(Now in Ubuntu)

It seems /etc/network/interfaces already has mtu 1400 at the bottom, which is odd. Yet, eth0 is still running at 1400. Any ideas?

Results of ifconfig:

Code:
eth0      Link encap:Ethernet  HWaddr 00:10:DC:FF:44:6F
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:815 errors:0 dropped:0 overruns:0 frame:0
          TX packets:933 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:416291 (406.5 KiB)  TX bytes:131010 (127.9 KiB)
          Interrupt:23 Base address:0xbc00
My /etc/network/interfaces, sans comments:

Code:
auto lo
iface lo inet loopback


mapping hotplug
	script grep
	map eth0

iface eth0 inet dhcp
mtu 1400
Incidentally I'm running AOL Broadband with a Netgear DG632 router connected directly to my box. Also, I have no problems in Windows since changing the MTU. I'm very close to my telephone exchange (500 yards or so), and apparently this could affect the connection.
 
Old 06-05-2005, 06:18 PM   #5
r0jaws
Member
 
Registered: Feb 2005
Location: Norfolk, UK
Distribution: Ubuntu
Posts: 40

Rep: Reputation: 15
I use AOL in the UK as well and found the easiest solution was to change the MTU in my Linksys Router to 1400 to connect, it meant not having to "ifconfig" any of my boxes to connect as the router sorted it, I checked out the website for Netgear and they do make referance to the ability to do this with their routers,

"Instructions for changing MTU on other NETGEAR devices is found in the Reference Manuals." found here
not terribly helpful I know, but it solved my problem, and 2 of my friends as well.
 
Old 06-05-2005, 06:27 PM   #6
r0jaws
Member
 
Registered: Feb 2005
Location: Norfolk, UK
Distribution: Ubuntu
Posts: 40

Rep: Reputation: 15
also i had previously changed,

/etc/sysconfig/network-scripts/ifcfg-eth0

by adding

MTU=1400

to the end, this was in Mandrake tho and before I changed the MTU of my linksys router, but may be worth a try.
 
Old 06-06-2005, 12:06 PM   #7
bengoodger
LQ Newbie
 
Registered: May 2005
Location: Lostwithiel, Cornwall, Great Britain
Distribution: Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 0
My router's already set to 1400, which is why I'm so perplexed at this problem. Could AOL's proxy server have something to do with this?
 
Old 06-06-2005, 05:36 PM   #8
r0jaws
Member
 
Registered: Feb 2005
Location: Norfolk, UK
Distribution: Ubuntu
Posts: 40

Rep: Reputation: 15
Doubtful it's the server as your windows seems to work ok, The only trouble I've had with their servers was with their SMTP server about a month ago, it threw a wobble and acted funny for a day or so.

I did notice the result of your ifconfig
Quote:
eth0 Link encap:Ethernet HWaddr 00:10C:FF:44:6F
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Indicating your MTU still = 1500?. How are you modifying /etc/network/interfaces? VI as root? or sudo?
have you tried with the = character inserted? You are typing "sudo ifconfig eth0 mtu 1400"?
Noddy i know but just checking. Is that the ifconfig result you get after you've attempted to change the mtu?
 
Old 06-06-2005, 07:41 PM   #9
r0jaws
Member
 
Registered: Feb 2005
Location: Norfolk, UK
Distribution: Ubuntu
Posts: 40

Rep: Reputation: 15
ok, had a bit of a look and come up with 2 options,
first have a look here for a Debian based work around.
Or (make a backup first) modify
/etc/ppp/options
then find,
#mtu <n>
change to,
mtu 1400
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wierd networking problem kenwih Linux - Networking 2 10-31-2005 07:25 PM
wierd networking issues ruwach Linux - Networking 2 12-14-2004 09:55 AM
wierd networking problem (vpn) pezzer55 Linux - Networking 0 09-30-2004 04:43 PM
Wierd Networking Unleashed :) gr00ve Linux - Networking 1 03-16-2004 12:17 PM
wierd Samba issue artman62 Linux - Networking 2 08-13-2002 08:59 PM


All times are GMT -5. The time now is 12:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration