LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-17-2005, 04:14 PM   #1
beta-glitch
LQ Newbie
 
Registered: Feb 2005
Posts: 10

Rep: Reputation: 0
R40e Laptop ACPI & Ubuntu


Hi

First of all, I'm not very knowledgable with Linux at all, but I have a very good knownledge of windows, hardware, and general PC concepts.

I've had lots of problems with ACPI Linux Support and my IBM R40e Laptop. I've not installed any distro without having to disable ACPI (I've tried several distro's recently), and only ever semi-sorted out ACPI on Novell Linux Desktop 9, by moving files in /lib/modules/{kernelver}/kernel/drivers/acpi/ (I think processor.ko and thermal.ko come to mind).

Now, I've install ubuntu (5.04 hoarty preview) and my initial impressions are good, so I want to keep it, thus I want ACPI sorted. I went into the folder above, and noticed an IBM_acpi.ko file. I think this must have been added with later kernels, and I'm guessing default kernel configurations don't load the hardware specific modules (such as toshiba, asus, IBM etc.).

I'm wanting step by step instructions on how to fix this if it is possible. I'm not sure whether I have to change a config file to load the modules, or recompile the kernel. If I do need to recompile the kernel, sould you also provide help to do that.

Many thanks
 
Old 03-17-2005, 04:47 PM   #2
chrisstooss
Member
 
Registered: Jan 2005
Location: Slovenia
Distribution: Ubuntu linux 5.10
Posts: 108

Rep: Reputation: 15
I've not installed any distro without having to disable ACPI (I've tried several distro's recently)

I dont get this sentence. Do you want to enable acpi or not?
 
Old 03-17-2005, 04:49 PM   #3
beta-glitch
LQ Newbie
 
Registered: Feb 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by chrisstooss
I've not installed any distro without having to disable ACPI (I've tried several distro's recently)

I dont get this sentence. Do you want to enable acpi or not?
sorry. I meant I've not successfully installed a distro without having to turn ACPI off
 
Old 03-18-2005, 09:21 PM   #4
leif81
LQ Newbie
 
Registered: Aug 2004
Location: kingston, canada
Distribution: Fedora
Posts: 20

Rep: Reputation: 0
I don't remember all the steps I used to successfully get ACPI working on my Asus M3N laptop with debian...but a big factor is adjusting the boot parameters.

Make sure you have 'acpi=on' and 'nolapic'. I forget what nolapic does but it's really important for acpi working

I'm using LILO as my boot manager so the file I had to edit was /etc/lilo.conf and then of course I had to run 'lilo' from the prompt to update the settings I made.

Maybe this will help.

Last edited by leif81; 03-18-2005 at 09:23 PM.
 
Old 03-19-2005, 12:23 PM   #5
beta-glitch
LQ Newbie
 
Registered: Feb 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by leif81
I don't remember all the steps I used to successfully get ACPI working on my Asus M3N laptop with debian...but a big factor is adjusting the boot parameters.

Make sure you have 'acpi=on' and 'nolapic'. I forget what nolapic does but it's really important for acpi working

I'm using LILO as my boot manager so the file I had to edit was /etc/lilo.conf and then of course I had to run 'lilo' from the prompt to update the settings I made.

Maybe this will help.
I have acpi=off in my boot parameters, because it won't boot without it. What I'm wanting to do is make ACPI the best it can for battery and AC status (I've had it working in another distro by moving the processor.ko and thermal.ko ACPI modules)

there is a kernel patch described Here, but I don't know how or where to apply this (location of kernel sources?)

any help will be much appreciated.
 
Old 03-19-2005, 12:39 PM   #6
leif81
LQ Newbie
 
Registered: Aug 2004
Location: kingston, canada
Distribution: Fedora
Posts: 20

Rep: Reputation: 0
Your kernel sources should be in /usr/src/. Poke around in there for them.

With my Asus laptop I had to install some kernel modules called acpi4asus.

Did you try acpi=on with the additional parameter 'nolapic' ? Because that is very key. Mine would not boot with acpi=on until i additionally included the nolapic parameter.
 
Old 03-19-2005, 07:38 PM   #7
chrisstooss
Member
 
Registered: Jan 2005
Location: Slovenia
Distribution: Ubuntu linux 5.10
Posts: 108

Rep: Reputation: 15
Try acpi=force or try to install acpi in synaptic
 
Old 03-22-2005, 06:07 AM   #8
beta-glitch
LQ Newbie
 
Registered: Feb 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by chrisstooss
Try acpi=force or try to install acpi in synaptic
this didn't work either, and AFAIK acpi was installed

I also forgot to mention last time that I tried the 'nolapic' parameter, with no joy

I've now moved onto Fedora Core 3 now, so it's no longer an issue

Thanks to all who tried to help though!
 
Old 03-23-2005, 10:41 AM   #9
MetroWonk
LQ Newbie
 
Registered: Mar 2005
Location: Washington, DC
Distribution: Gnoppix, DSL, Warty
Posts: 2

Rep: Reputation: 0
LiveCD boot for Thinkpads

You have an interesting problem, and I'm not sure this will help...

I've only used the Ubuntu LiveCDs, but under the boot options the Hoary Preview LiveCD offers a special boot parameter exclusively for Thinkpads.

I'm not yet experienced enough to appreciate how this parameter changes things, but it may offer you a clue to figuring out your ACPI problem.

_MetroWonk
 
Old 05-08-2005, 10:07 PM   #10
nikor
LQ Newbie
 
Registered: May 2005
Posts: 1

Rep: Reputation: 0
There is a solution to your problem on this site: http://pc.freeshell.org/tp/
Good luck
 
Old 05-09-2005, 06:00 PM   #11
beta-glitch
LQ Newbie
 
Registered: Feb 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by nikor
There is a solution to your problem on this site: http://pc.freeshell.org/tp/
Good luck
thanks, but I had already pointed out this site in an earlier post. My question was how to APPLY the fix listed. I have no idea about kernel compilingand all related stuff. I was kinda wanting a definative guide on kernel compiling or some steps on how to recompile it specific to Ubuntu.

I still experience the problem on all distributions on linux. It's kinda put me off buying IBM stuff again. Intrestingly enough, SuSE 9.3 installed without having to disable ACPI, but once installed started to hang on startup again. it seems SuSE 9.3 uses a kernel that implements the fix listed on the page above, but only during installation??? strange.

Anyway, Linux seems to be causing me too many headaches on this laptop, so I think I'll give up for now. See what the future of linux desktop brings before trying again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
acpi for (K)ubuntu snow_bound Ubuntu 4 08-26-2005 06:54 PM
ACPI issue on IBM thinkpad r40e SmellyLlama Suse/Novell 4 04-18-2005 07:04 AM
Looking for complex laptop powersave & acpi HOWTO VertX Linux - Laptop and Netbook 1 03-03-2005 11:15 PM
Getting a laptop: touchpad locking & bios conflicts & other possible laptop problems? mandrakemikael Linux - Laptop and Netbook 2 12-09-2004 07:15 AM
kernel 2.4.20 & acpi-20021212-2.4.20.diff => no /proc/acpi Tinkster Linux - Software 5 03-24-2003 01:56 PM


All times are GMT -5. The time now is 10:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration