LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Question to Edgy users (http://www.linuxquestions.org/questions/ubuntu-63/question-to-edgy-users-505753/)

Cyran 11-28-2006 10:16 PM

Question to Edgy users
 
Do you get some sort of occasional lag? that may last for about a second and that stops every current processes?

I never detected such behaviour with Dapper. My installation of Edgy is for the most part operational, it's only problem is this irritating lag. Usually it occurs if i'm running a web browser or just normal multitasking, but in most cases the web browser appears to be the cause.


Note: Yes, I have the proper video card drivers installed.

Thanks in advance..

aysiu 11-28-2006 11:09 PM

Nope. Edgy's working smoothly for me.

IndyGunFreak 11-29-2006 12:07 AM

Quote:

Originally Posted by aysiu
Nope. Edgy's working smoothly for me.

Same here...

IGF

Redeye2 11-29-2006 01:52 AM

I recently read that edgy's kernel changed the preemption model to voluntary. If you're willing to do it, you could recompile the kernel and change the frequency to 1000mhz and the preemption model to see if it helps.

Sir Loin 11-29-2006 05:17 PM

That happens to me a lot. Ubuntu just sucks. Try using Gentoo - it's faster.

fragos 11-29-2006 05:31 PM

I've noticed that when I'm running tvtime, xorg grabs and releases large amounts of CPU. There also seems to be a lag when terminal opens. The window comes up but there is a short delay before the prompt is seen. I don't remember either of these characteristics with Dapper. I'll stick with Edgy and look forward to Fiesty.

Redeye2 11-29-2006 10:43 PM

Quote:

Originally Posted by Sir Loin
That happens to me a lot. Ubuntu just sucks. Try using Gentoo - it's faster.

Lol. Gentoo is for people who have plenty of time to spare.

Cyran 11-30-2006 03:51 PM

Quote:

Originally Posted by Redeye2
I recently read that edgy's kernel changed the preemption model to voluntary. If you're willing to do it, you could recompile the kernel and change the frequency to 1000mhz and the preemption model to see if it helps.

Have any links that might help? compiling the kernel is new to me, and looks somewhat difficult.

lin_user2004 12-01-2006 12:35 AM

Quote:

Originally Posted by Cyran
Have any links that might help? compiling the kernel is new to me, and looks somewhat difficult.

Tbis should help http://ubuntuforums.org/showthread.php?t=217657

Redeye2 12-01-2006 01:00 AM

Quote:

Originally Posted by lin_user2004

That's a good guide but I'd install the Ubuntu kernel source package and compile that one instead of a vanilla one from kernel.org. That way everything you have now will work after changing that couple parameters.

If you're using restricted modules, make sure you create a symlink to the exact name of your new kernel inside /lib/modules to ensure that the firmwares are loaded. The symlink should point to an existing kernel module directory.
For example, if your existing kernel is 2.6.17-10-generic, there should be a folder called exactly like that inside /lib/modules. You'll want your new kernel to use those modules (since it's the same kernel source with a couple configuration tweaks). If your new kernel ends up being named something like 2.6.17-10-generic-custom, then make a link inside /lib/modules called 2.6.17-10-generic-custom that points to /lib/modules/2.6.17-10-generic

ctkroeker 12-01-2006 03:59 PM

Quote:

CyranI never detected such behaviour with Dapper. My installation of Edgy is for the most part operational, it's only problem is this irritating lag. Usually it occurs if i'm running a web browser or just normal multitasking, but in most cases the web browser appears to be the cause.
Same thing here. I wonder if a install of firefox from their site will work better than the one that ships in edgy? Note to self: gotta try it sometime.

TheScottSwanson 01-23-2007 12:51 PM

I also get this periodic lag or freeze. I am running Edgy Eft on a Core 2 Duo/Centrino Duo laptop (HP nc8430).

My `uname -a` is

Linux widebuntu 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 GNU/Linux

I am surprised to not see "PREEMPT" after "SMP". Is this the reason for the lag? How do I enable kernel preemption?

Thanks for any help.

Regards,

Scott


All times are GMT -5. The time now is 04:40 AM.