LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-03-2009, 12:59 AM   #1
avinash.rao
Member
 
Registered: Jun 2008
Posts: 197

Rep: Reputation: 30
Smile Problem with Language on LTSP client on Ubuntu 9.04


Dear all,

I am testing LTSP on Ubuntu Server 9.04 - 64-bit + ubuntu desktop 9.04
on a HP XW4600 workstation with 2GB RAM.

dpkg -l | grep ltsp
ii ltsp-server 5.1.65-0ubuntu2
Basic LTSP server environment
ii ltsp-server-standalone 5.1.65-0ubuntu2
Complete LTSP server environment
ii ltspfs 0.5.10-0ubuntu1
Fuse based remote filesystem for LTSP thin c

After installing LTSP, i couldnot find lts.conf file under
/var/lib/tftboot/ltsp/i386/ directory, instead it was in
/opt/ltsp/i386/usr/share/doc/ltsp-client-core/examples/lts.conf and
/opt/ltsp/i386/etc/lts.conf

The lts.conf file under /var directory just Donot use this file, it
has been moved to /var/lib/tftboot/ltsp/i386/ . but its not there or i
guess i have to create it.I copied the lts.conf file from
/opt/ltsp/i386/usr/share/doc/ltsp-client-core/examples/ to
/var/lib/tftboot/ltsp/i386/ and it looks something like this.

# Global defaults for all clients
# if you refer to the local server, just use the
# "server" keyword as value
# see lts_parameters.txt for valid values
################
[default]
X_COLOR_DEPTH=16
LOCALDEV=True
SOUND=True
NBD_SWAP=True
SYSLOG_HOST=server
#XKBLAYOUT=de
#LDM_DEBUG=no

The ltsp client boots, but the language is in German So, i commented the
#XKBLAYOUT=de to disable the option and rebooted the client but i am
getting the same thing. Also, the client takes more time to boot than
normal.

can anybody help me
Avinash
 
Old 08-03-2009, 11:48 AM   #2
avinash.rao
Member
 
Registered: Jun 2008
Posts: 197

Original Poster
Rep: Reputation: 30
I figured this out. I configured XKBLAYOUT=en option in lts.conf file. It didn't work in the beginning, but after a couple of reboots it did! But, i am facing the following problems.

I am having problems mounting a 80GB NTFS USB drive on LTSP client.But it mounts on the server without any problems.

Also, if i plug in any USB drive on the server, this comes up in all the LTSP clients and they are in write mode which means they can view and change the contents of the drive! how can i stop this from appearing in all the LTSP client machines. I removed the "Access external storage devices automatically" in User Privileges but it still appears.

And, the LTSP client boots really slow, it takes more than a minute which was not the case with earlier version of LTSP and hardy. Infact, the server with Samba, LTSP, DHCP boots faster.

Avinash
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing a USB printer on a LTSP client avinash.rao Ubuntu 9 07-20-2009 09:40 AM
Ubuntu 8.10 ltsp problem? Silver565 Linux - Server 4 03-21-2009 11:05 PM
LTSP 5 mount usb on client as localdev problem. lievendp Linux - Server 1 12-08-2008 03:42 AM
LTSP - Client PC JoFly Linux - Software 2 01-16-2006 10:07 AM
ltsp client hbnavadia Red Hat 1 06-14-2004 03:54 AM


All times are GMT -5. The time now is 01:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration