LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 05-10-2007, 01:28 PM   #1
I_AM
Member
 
Registered: Mar 2005
Posts: 103

Rep: Reputation: 15
poor font quality in ubuntu, need help!


I need help to get the BEST, sharpest, most crisp font quality (including proper size) in Ubuntu Feisty Fawn, to match Windows as much as possible (Vista). I've tried so much, no matter what I've done I cannot get the fonts as crisp as Windows at all.

I installed 32bit Ubuntu Feisty Fawn and by default, the resolution was properly set to 1280x800 (widescreen) on 60Hz refresh. Do I need to install/enable 915resolution?

I'm struggling to get the best font quality possible

What I've done
- msttcorefonts http://www.warrenguy.com/docs/ubuntu...ing-fonts.html
- freetype http://ubuntuforums.org/showthread.php?t=343670
- copy over all segoe*, calabra* and tahoma* fonts from Windows
- cloned firefox 2 font settings of Windows into here in Ubuntu
- I have gtk2-engines-pixbuf enabled by Ubuntu's default (double checked via synaptic)

Comparison:

Linux

http://img517.imageshack.us/img517/1...apshot1wj0.png
http://img359.imageshack.us/img359/6...apshot6yj2.png


Windows

http://img382.imageshack.us/img382/2...dowsxt4er8.png
http://img80.imageshack.us/img80/457...dowshf6oq2.png

Linux
http://img522.imageshack.us/img522/6...apshot2bo7.png

Windows
http://img382.imageshack.us/img382/8...dowslc4rn5.png

Notice text is getting bolded too much and somehow larger in linux? Why?

Also, Vista is nice and bright. Linux is somewhat "flat" in contrast. Not horrible, but just not as nicely bright for some reason. How would I corrrect this? How do I make sure my card settings is set to 32bit color depth too?

Keep in mind I'm new to linux!

Specs:
Sony Vaio FE770G Laptop
Core 2 Duo 1.83GHz
2GB Memory
Creative Soundblaster Live! 24-bit External USB
Intel 945GM / 950 Chipset (graphics)
Intel PRO/Wireless 3945ABG Network Connection
Intel PRO/100 VE Network Connection
15.4" Widescreen (1280x800)
Intellipoint Wireless Laser 6000 Mouse
 
Old 05-10-2007, 07:46 PM   #2
iggy_mon
Member
 
Registered: Aug 2003
Location: PA, USA
Distribution: Mandriva Ubuntu
Posts: 98

Rep: Reputation: 15
i hope this helps...

http://www.howtoforge.com/sharp_fonts_gnome

from the article...
You might have noticed that fonts are quite fuzzy on Linux desktops which can make your eyes ache if you have to sit in front of your computer all day long. Font rendering is still a little bit awkward and one of the last weaknesses of Linux desktops. This tutorial shows how you can make GNOME and all GNOME applications (such as Evolution, the file browser Nautilus, etc.) use sharp fonts. In fact, we will use the Microsoft Windows standard font, Tahoma,...

post a note if it works (or doesn't).

ty
--iggy
 
Old 05-10-2007, 08:03 PM   #3
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
System > Preferences > Fonts ; but this will not work for all applications.
 
Old 05-11-2007, 12:40 AM   #4
Patrick K
Member
 
Registered: Apr 2007
Distribution: Feisty (Ubuntu Studio)/Edgy
Posts: 69

Rep: Reputation: 15
That worked very well for me, thanks. I can finally read my screen without going to clown sized fonts.
 
Old 05-11-2007, 12:42 PM   #5
I_AM
Member
 
Registered: Mar 2005
Posts: 103

Original Poster
Rep: Reputation: 15
I already applied http://www.howtoforge.com/sharp_fonts_gnome as well, but look at the comparison of font size and boldness. They are still getting bolded, enlarged for GOD knows what reason, in linux.

Linux:
http://www.imagehost.ro/pict//112035194644a95749e50.png
Look at the fonts all over the screen, mainly the forum category titles
and text on right column too. They are bigger, bolder. I do not know why.

Windows:
http://www.imagehost.ro/pict//112035394644a96bba186.png

See now in Windows, this is how it SHOULD appear in linux.

How can I fix this?

My current font settings:

Ubuntu
http://www.imagehost.ro/pict//112037114644a9c7e97b0.png

Firefox
http://www.imagehost.ro/pict//112037394644a9e396549.png
(firefox setting matches exact settings in default firefox windows settings)

Right now, I have .fonts.conf file with this, taken from the link you mentioned and unchanged:

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

<!-- Give all fonts light hinting and subpixel smoothing -->
<!--
<match target="font">
    <edit mode="assign" name="rgba">
        <const>rgb</const>
    </edit>
    <edit mode="assign" name="hinting">
        <bool>true</bool>
    </edit>
    <edit mode="assign" name="hintstyle">
        <const>hintslight</const>
    </edit>
    <edit mode="assign" name="antialias">
        <bool>true</bool>
    </edit>
</match>
-->

<!--
     <match target="font">
        <test qual="all" name="rgba"><const>unknown</const></test>
           <edit name="rgba" mode="assign"><const>rgb</const></edit>
     </match>
-->

<!--  Do not smooth Fixedsys  -->
<match target="font">
    <test name="family">
        <string>FixedsysTTF</string>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!--  Do not smooth Tahoma 8pt and under  -->
<match target="font">
    <test name="family">
        <string>Tahoma</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>9</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!--  Do not smooth Times New Roman or Courier New for 12pt and under  -->
<match target="font">
    <test name="family">
        <string>Times New Roman</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>13</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<match target="font">
    <test name="family">
        <string>Courier</string>
        <string>Courier New</string>
        <string>Courier 10 Pitch</string>
    </test>
    <test compare="less" name="size" qual="any">
        <double>11</double>
    </test>
    <edit name="antialias">
        <bool>false</bool>
    </edit>
</match>

<!-- Do not autohint Courier New, Fixedsys, Tahoma, or Times New Roman -->
<match target="font">
    <test name="family">
        <string>Courier New</string>
        <string>Times New Roman</string>
        <string>Tahoma</string>
        <string>FixedsysTTF</string>
    </test>
    <edit mode="assign" name="hintstyle">
        <const>hintslight</const>
    </edit>
    <edit mode="assign" name="autohint">
        <bool>false</bool>
    </edit>
</match>

<match target="pattern">
            <test qual="any" name="family">
                    <string>Bitstream Vera Sans</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Arial</string>
            </edit>
</match>
    <match target="pattern">
            <test qual="any" name="family">
                    <string>Helvetica</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Arial</string>
            </edit>
</match>
<match target="pattern">
            <test qual="any" name="family">
                    <string>Palatino</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Georgia</string>
            </edit>
</match>
</fontconfig>
 
Old 05-11-2007, 04:28 PM   #6
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
The most direct and strait forward way to solve this problem is with System-> Preferences-> Font. I'm a fan of DejaVu Sans Condensed. Choose the fonts and sizes you wish to use on the desktop. Rendering is set much simpler by selecting from the four visual samples presented. "Best Shapes" worked best on my LCD. These four choices will set the parameters mentioned above but avoid having you experiment with unworkable permutations of the parameters. The details button will offer further options like resolution in dots/in which are set by the four choices in the main window.
 
Old 05-14-2007, 11:50 AM   #7
I_AM
Member
 
Registered: Mar 2005
Posts: 103

Original Poster
Rep: Reputation: 15
http://browsershots.org/website/http...s.com/#success

That's my site. I use 96dpi, 1280x800 resolution and 24bit.

The windows one is the smoothest and in Vista, it is even smoother (but they show XP)

Somehow, PLD linux is a lot better by default than Ubuntu. What they do , Ubuntu should learn from. PLD linux, it does not mysteriously enlarge fonts and bold them 10x more than they should be.
http://ubuntuforums.org/images/uf/misc/progress.gif
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Svideo out to TV quality is really poor vdemuth Linux - Hardware 6 01-01-2007 06:39 PM
poor sound quality verbose Linux - Hardware 6 09-11-2006 04:29 AM
Very Poor Font/Image Quality after installing Nvidia Drivers Please Help DYNO Linux - Hardware 1 12-25-2004 02:17 PM
poor sound quality slackware_03 Linux - Distributions 10 09-23-2004 04:17 PM
Poor Quality DVDs guygriffiths Linux - Software 13 12-03-2003 01:37 PM


All times are GMT -5. The time now is 11:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration