LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-15-2007, 08:02 AM   #1
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 542

Rep: Reputation: 30
package source configure error


I've downloaded some source files from sourceforge and the instructions are simple, to run ./configure and then make install.

First command falls over:

Code:
$ ./configure
bash: ./configure: /bin/sh: bad interpreter: Permission denied
What does the above mean and how do I fix it please?

Thanks.
 
Old 05-15-2007, 10:43 AM   #2
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 41
What distribution are you using? And did you do make install with SU ?
 
Old 05-15-2007, 12:39 PM   #3
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,244

Rep: Reputation: 45
Make sure you've installed the build-essential package.
 
Old 05-16-2007, 02:46 AM   #4
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 542

Original Poster
Rep: Reputation: 30
Distro=Kubuntu Fiesty

I've tried doing this with "sudo ./configure" and logging in as root and also tried "su " to root.

Nothing works.

What is build-essential package? According to apt-manager and synaptic, it is installed anyway.

Last edited by keratos; 05-16-2007 at 02:48 AM.
 
Old 05-16-2007, 04:29 AM   #5
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 41
Do you have execution rights on the disk you're trying to compile it on? Why not try:

sudo cp yourdir /yourdir

And then do:

sudo ./configure

This i've seen somewhere:


Code:
This usually means that you are compiling your package in a partition which does not allow the execution of code. Normally, this occurs on user-mounted systems, where the following options are de facto:

/dev/hda-foo on /directory/foo type ext3 (rw,noexec,nosuid,nodev)

To fix this problem, you can either:

- unmount the partition, and re-mount it with the proper options,
- or move the binary/package to another partition that has exec rights
To check this do:

cat /boot/grub/grub.conf

or when using lilo:

cat /etc/lilo.conf

and check for the corresponding harddisk.
 
Old 05-16-2007, 04:33 AM   #6
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 120Reputation: 120
you should only really need super user privileges for the make install step

Can you try with another package? Is configure executable?

Last edited by billymayday; 05-16-2007 at 04:35 AM.
 
Old 05-16-2007, 09:03 AM   #7
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 542

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by puntjuh
Do you have execution rights on the disk you're trying to compile it on? Why not try:

sudo cp yourdir /yourdir

And then do:

sudo ./configure

This i've seen somewhere:


Code:
This usually means that you are compiling your package in a partition which does not allow the execution of code. Normally, this occurs on user-mounted systems, where the following options are de facto:

/dev/hda-foo on /directory/foo type ext3 (rw,noexec,nosuid,nodev)

To fix this problem, you can either:

- unmount the partition, and re-mount it with the proper options,
- or move the binary/package to another partition that has exec rights
To check this do:

cat /boot/grub/grub.conf

or when using lilo:

cat /etc/lilo.conf

and check for the corresponding harddisk.

WOW! Nice 1 buddy. This has fixed it!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error due to wxWidgets while installing aMule source package Unforgiven79 Linux - Desktop 3 03-24-2007 08:42 AM
Yum Error: Transaction Check Error package x(which is newer than package y)... godsk Linux - Newbie 0 06-05-2006 07:13 AM
firefox configure error : No package 'xft' found logicalfuzz Linux - Software 2 09-30-2005 05:38 AM
configure:Error: Module source already has to be below src/modules/ to be activated Kevnathan Linux - Security 3 12-09-2004 03:31 AM
Msttcorefonts Package: Error processing Msttcorefonts (--configure) davidas Linux - Software 3 04-18-2004 02:12 PM


All times are GMT -5. The time now is 12:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration