LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   package not found(while installing these dependencies in ubuntu gail-3.0,autopoint) (http://www.linuxquestions.org/questions/ubuntu-63/package-not-found-while-installing-these-dependencies-in-ubuntu-gail-3-0-autopoint-4175437294/)

ahmed12345 11-15-2012 12:50 PM

package not found(while installing these dependencies in ubuntu gail-3.0,autopoint)
 
hello,
i tried installing gail-3.0 dependencies in ubuntu.it says package not found.
then i tried setting GAIL_CFLAGS=<output of pkg-config --cflags gail> it says like reenterant not found.
>> GAIL_LIBS=<output of pkg-config --libs gail>.
i kindly request you to plz suggest me step by step procedure for installing gail-3.0

thank you.

knudfl 11-15-2012 01:13 PM

Welcome to LQ.

Which Ubuntu ? Version, please.

If you have Ubuntu 11.10 .. 12.10 : "gail-3.0" is a package config file,
provided by 'libgail-3-dev' : /usr/lib/pkgconfig/gail-3.0.pc

And : The package libgail-3-dev is built from the gtk+3.0 source.
http://packages.ubuntu.com/oneiric/libgail-3-dev
http://packages.ubuntu.com/oneiric/i...3-dev/filelist

.

ahmed12345 11-15-2012 11:42 PM

my ubuntu version is 10.04.4.
 
kindly reply
Quote:

Originally Posted by knudfl (Post 4830175)
Welcome to LQ.

Which Ubuntu ? Version, please.

If you have Ubuntu 11.10 .. 12.10 : "gail-3.0" is a package config file,
provided by 'libgail-3-dev' : /usr/lib/pkgconfig/gail-3.0.pc

And : The package libgail-3-dev is built from the gtk+3.0 source.
http://packages.ubuntu.com/oneiric/libgail-3-dev
http://packages.ubuntu.com/oneiric/i...3-dev/filelist

.


knudfl 11-16-2012 03:40 AM

There is no gtk3 for Ubuntu 10.04.x. Thus no *gail-3*.
The first Ubuntu to have gtk3 is version 11.10 .

The easy way to use gtk3 applications :
Install the new "LTS", Ubuntu 12.04. (LTS = Long time supported.)

Which application is it, that requires gtk3 / gail-3.0 ?
.

tommcd 11-17-2012 05:30 AM

Quote:

Originally Posted by ahmed12345 (Post 4830158)
i tried installing gail-3.0 dependencies in ubuntu.it says package not found.

Are you using any third party repositories on your Ubuntu install??
This includes all of those all too often problematic PPA repos.
Third party repositories can often cause problems like this.
For best results, stick with the standard Ubuntu repositories and you will avoid problems like this.

ahmed12345 11-19-2012 04:18 AM

how to install autopoint package for ubuntu12.04 version.
 
hello,
i tried installing package autopoint in ubuntu 12.04 it says package not found. so how do i install autopoint in ubuntu12.04 please guide
thank you

knudfl 11-19-2012 06:02 AM

# 6

sudo apt-get update
sudo apt-get install autopoint

ahmed12345 11-19-2012 07:09 AM

could not locate package libsecret-1-dev in ubuntu12.04.
 
Hello
i tried installing libsecret-1-dev in ubuntu 12.04 but it throws an error saying could not locate package libsecret-1-dev. requesting u to please guide me what is the procedure to make it compatable.
i also tried $ sudo apt-get update
$ sudo apt-get install libsecret-1-dev
thank you

knudfl 11-19-2012 09:39 AM

# 8 : $ apt-cache search libsecret-1-dev : No package libsecret* for Ubuntu 12.04 .

1) Please add two lines to /etc/apt/sources.list : sudo gedit /etc/apt/sources.list
Code:

deb-src http://de.archive.ubuntu.com/ubuntu/ quantal main
deb-src http://dk.archive.ubuntu.com/ubuntu/ quantal-updates main

2) sudo apt-get update
3) sudo apt-get install fakeroot
4) sudo apt-get build-dep vala-0.18
5) cd <new-folder-1>/
6) apt-get -b source vala-0.18=0.18.0-0ubuntu1
7) sudo dpkg -i valac-0.18_0.18.0* libvala-0.18* valac-0.18-vapi_0.18.0-0ubuntu1*
8) sudo apt-get build-dep libsecret
8a) exit
9) cd <new-folder-2>/
10) apt-get -b source libsecret=0.11-0ubuntu0.12.10.1
11) sudo dpkg -i libsecret-1-0_0.11* libsecret-common* libsecret-1-dev_0.11* gir1.2-secret*

Don't know what requires 'libsecret-1-dev', but if you want to install / use
bleeding edge applications : Better install Ubuntu 12.10 Quantal.

.

ahmed12345 11-19-2012 11:04 PM

how do i build webkit gtk on ubuntu 12.1
 
hello,
we are basically trying to build webkit gtk on ubuntu12.1, and all the required depenndencies are installed.i m following the guide in this website: http://trac.webkit.org/wiki/BuildingGtk
please guide me in building the webkitgtk on ubuntu12.1
thank you.

knudfl 11-20-2012 03:28 AM

# 10

apt-cache search webkitgtk

sudo apt-get install libwebkitgtk-3.0-0
( http://packages.ubuntu.com/precise-u...ebkitgtk-3.0-0 )

Standalone demo : $ /usr/lib/webkitgtk-3.0-0/libexec/GtkLauncher


.

ahmed12345 11-21-2012 06:34 AM

how to debug the webkitgtk code on ubuntu 12.10
 
Hello,
i have built the webkitgtk+ on ubuntu 12.10 and i have to customize the browser and basically the webkit contains modules like Javascript,Webcore,Drosera..
so how do i debug these modules(Javascript,Webcore).please guide me in details how do i debug it.
thank you



Quote:

Originally Posted by ahmed12345 (Post 4830158)
hello,
i tried installing gail-3.0 dependencies in ubuntu.it says package not found.
then i tried setting GAIL_CFLAGS=<output of pkg-config --cflags gail> it says like reenterant not found.
>> GAIL_LIBS=<output of pkg-config --libs gail>.
i kindly request you to plz suggest me step by step procedure for installing gail-3.0

thank you.



All times are GMT -5. The time now is 08:19 PM.