LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-24-2013, 02:15 AM   #1
NightStranger
LQ Newbie
 
Registered: Dec 2004
Location: North of Germany
Distribution: Ubuntu
Posts: 23

Rep: Reputation: 0
Nvidia graphic card: lower resolution, glx performance for one user


Distro: Ubuntu 10.04 (Lucid Lynx)
--------------------------------------------------

Hallo forum

in my system I have installed a Nvidia graphic card:

Code:
lspci:

03:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6610 XL] (rev a2)
I have installed Nvidia's proprietary driver
Code:
dpkg -l nvidia*

[...]
ii  nvidia-173                        173.14.22-0ubuntu11.2             NVIDIA binary Xorg driver, kernel module and VDPAU library
[...]
For settings, I use "NVIDIA X Server Settings", but I mainly use the default settings.
Only screen resolution is changed from "Auto" to 1920 x 1200
I got the modification saved in xorg.conf (not merged).

Now, xorg.conf looks like this:

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Fri Apr  9 10:35:18 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 94.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6610 XL"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1920x1200 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Login as 1st user (admin), the screen resolution starts with 1920x1200 as expected.
The GLX performance looks like this which seems OK.

Code:
glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
27252 frames in 5.0 seconds
27782 frames in 5.0 seconds
27776 frames in 5.0 seconds
CPU load is up to 100 % (is this normal?)

When I log in as 2nd user (no admin), the screen resolution starts with 1280x1024 instead of 1920x1200

GLX performance is also much worse:
Code:
 glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
6807 frames in 5.0 seconds
6907 frames in 5.0 seconds
6963 frames in 5.0 seconds
6825 frames in 5.0 seconds
GLX-info looks like this:

Code:
 glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control, 
    GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer, 
    GLX_ARB_fbconfig_float
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync, 
    GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGI_swap_control, GLX_NV_float_buffer, GLX_ARB_fbconfig_float, 
    GLX_EXT_fbconfig_packed_float, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_framebuffer_sRGB, GLX_NV_present_video
GLX version: 1.3
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control, 
    GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer, 
    GLX_ARB_fbconfig_float, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6610 XL/PCI/SSE2/3DNOW!
OpenGL version string: 2.1.2 NVIDIA 173.14.22
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
OpenGL extensions:
[...]
The display is a flat screen Samsung 244T connected via VGA.

Additional issues (both admin and no-admin)

When I just scroll the views (e. g. browser) with my mouse wheel, the motion looks "bumpy" (not smooth) and the CPU load goes up to 100 % (AMD Sempron 2800+, 1,5 GB RAM).

Who can help me to trace and solve this problem?

thanks in advance and kind regards

Rai
 
Old 08-24-2013, 02:36 AM   #2
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
10.04 is end of life, out of support (for desktop use). Upgrade to a newer version, or a different distro.

https://wiki.ubuntu.com/Releases

glxgears is not a benchmark.

nVidia 6XXX cards (including the very rare 'GeForce 6610 XL' model) should use the 195.36 drivers with 10.04, up to the 304.XX drivers with newer/current distros. 173.XX will work, but the newer drivers work better.
 
Old 08-24-2013, 02:41 AM   #3
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,973

Rep: Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768
You might want to at least get the latest driver, 195.36 if cascade is correct.

But Nvidia keeps per user configs so you could easily have different settings for each user. To set it as each user run NvidiaConfig.

Also, as noted, glxgears is not a good benchmark.
 
Old 08-28-2013, 12:53 AM   #4
NightStranger
LQ Newbie
 
Registered: Dec 2004
Location: North of Germany
Distribution: Ubuntu
Posts: 23

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by astrogeek View Post
But Nvidia keeps per user configs so you could easily have different settings for each user.
That is, what I also suspect. But I could not find any nvidia related config file in the user's home directory. Do you have an idea, where the user settings can be found?

Quote:
To set it as each user run NvidiaConfig.
I also tried this, but the settings are not stored for the next log in. So I consider to delete the user settings, if I find them, and use the system settings instead.

Rai
 
Old 08-28-2013, 02:44 AM   #5
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,973

Rep: Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768
Quote:
Originally Posted by NightStranger View Post
That is, what I also suspect. But I could not find any nvidia related config file in the user's home directory. Do you have an idea, where the user settings can be found?


I also tried this, but the settings are not stored for the next log in. So I consider to delete the user settings, if I find them, and use the system settings instead.

Rai
I am not on my Nvidia system at the moment so cannot check exactly - but I recall that I had to add a line to my X startup script to load the user configs. I use fluxbox and had to add it to ~/.fluxbox/startup, but you can add it in ~/.xinitrc for any DE.

Maybe someone can point the right way - I'll be back at my Nvidia box tomorrow.
 
Old 08-28-2013, 08:55 PM   #6
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,973

Rep: Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768Reputation: 768
OK, here is how it works...

When you run NvidiaConfig it creates a file in the user's home directory...

Code:
~/.nvidia-settings-rc
When X starts the DE or window manager, you need to do the following before the exec line that starts the DE/WM...

Code:
nvidia-settings --load-config-only
That line loads the per-user config file for that X session.

In my own case it goes into my ~/.fluxbox/startup script, but you can add it to the ~/.xinitrc or other script that starts the DE/WM, just as long as it appears before the exec line.

You should also have a man page with more info:

Code:
man nvidia-settings
Good luck!
 
Old 08-29-2013, 01:36 PM   #7
NightStranger
LQ Newbie
 
Registered: Dec 2004
Location: North of Germany
Distribution: Ubuntu
Posts: 23

Original Poster
Rep: Reputation: 0
Thanks for your support.

Quote:
When you run NvidiaConfig it creates a file in the user's home directory...

Code:

~/.nvidia-settings-rc
I could find the config file and I moved it out of the way (renamed it). Now the display of all users have the same configuration with full resolution
Quote:
You might want to at least get the latest driver, 195.36 if cascade is correct.
I downloaded the driver from here http://www.nvidia.com/object/linux_d...195.36.15.html and installed it successfully.

Unfortunally, the jumpy scrolling of a view e. g. in Firefox still persists. I have checked "soft scrolling" and "use HW accelleration if available" in FF settings. CPU usage still rises up to 100 % during scrolling.

Maybe I have to live with this?
 
Old 08-31-2013, 02:35 AM   #8
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
Quote:
Originally Posted by NightStranger View Post
I downloaded the driver from here http://www.nvidia.com/object/linux_d...195.36.15.html and installed it successfully.
My suggestion that 10.04 should be using 195.36.XX drivers is because that is the drivers in the 10.04 repos.

Using jockey to get the repos drivers should still work. Even though 10.04 is 'end of life' for desktop use, its still supported as a server. But becauise its no longer supported for desktop use, its not a good idea to keep using it as a desktop....
 
  


Reply

Tags
glxgears, nvidia, resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia-glx Resolution hellasyoda Linux - Software 3 08-30-2007 09:16 AM
Can't load the nvidia glx (may be lacking \etc\rc.d\init.d\nvidia-glx) Starchild Fedora 1 07-27-2007 06:44 AM
GLX module failure on Nvidia card dssrjol Fedora 4 05-28-2007 11:49 AM
Nvidia GeForce 4 MX 440 poor performance nvidia glx drivers jollyjoice Linux - Hardware 7 06-07-2006 09:02 AM
Nvidia GLX Segfaulting ONLY with user xeran Linux - General 2 10-16-2005 12:58 PM


All times are GMT -5. The time now is 01:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration