LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 06-21-2006, 03:55 AM   #1
openfun
Member
 
Registered: Nov 2004
Location: Netherlands
Distribution: Mandrake, Red Hat, Debian
Posts: 34

Rep: Reputation: 15
Question nvidia driver 8762 kernel module mismatch x module


I just upgraded my ubuntu to dapper 6.06. Then I tried the latest nvidia driver 8762. However after the installation, I got an error indicated as followings:

The NVIDIA module has the version 1.0-7174, but this X module has the version 1.0-8762. Please make sure that the kernel module and all NVIDIA driver components have the same version.

I just tried something like, removing the old kernel module and reinstalled the driver with a compilation of the kernel, but it still doesn't work. Could anybody here please post an instruction of solving such a problem? Thank you so much in advance!


OpenFun
 
Old 06-21-2006, 02:24 PM   #2
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK - South Coast.
Distribution: Ubuntu (usually the latest....)
Posts: 2,672
Blog Entries: 9

Rep: Reputation: 45
It may be that one of the sources you have listed in your /etc/apt/sources.list is incorrect/out of date.

My recent install of Kubuntu had some updates, which I applied. This caused me no end of grief, because when the updates where released, some of the repositories/mirrors didn't seem to have all the packaged.

It took a lot of digging to find the answer, which was to add an additional repository/mirror to my sources.list file.

I'd suggest that you take a look at the Ubuntu sources.list generator and get it to produce a new sources.list (move the existing one to /etc/apt/sources.list.old and then add the new one).

It may be worth making the change to the sources.list, but then remove the old version of the nvidia driver and then re-install the whole thing i.e.
Code:
sudo apt-get remove nvidia-glx && nvidia-kernel-common
and then do the opposite with
Code:
sudo apt-get install nvidia-glx && nvidia-kernel-common
The one thing I'm not sure of, is whether K/Ubuntu install the kernel-sources/kernel header files by default. The nvidia driver needs them usually, especially if you get the nvidia driver from the main www.nvidia.com site and then run their installer i.e. sh NVIDIA-Linux-x86-*************pkg1.run - without the kernel-sources/headers it will "bin you out" every time!

If I've got a handle on what your problem actually is, then that should (in theory) do the trick.

regards

John
 
Old 06-22-2006, 03:29 AM   #3
openfun
Member
 
Registered: Nov 2004
Location: Netherlands
Distribution: Mandrake, Red Hat, Debian
Posts: 34

Original Poster
Rep: Reputation: 15
Thanks BigJohn:

Actually I didn't follow your instruction. I just removed two files of the nvidia module in my kernel (the file name I forgot now), then reinstalled the driver using the package from nvidia official website. Then it works. However such a tricky way may not work under different situations. Yet at least, I feel happy with it.
 
Old 06-22-2006, 02:14 PM   #4
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK - South Coast.
Distribution: Ubuntu (usually the latest....)
Posts: 2,672
Blog Entries: 9

Rep: Reputation: 45
Quote:
Originally Posted by openfun
Thanks BigJohn:

Actually I didn't follow your instruction. I just removed two files of the nvidia module in my kernel (the file name I forgot now), then reinstalled the driver using the package from nvidia official website. Then it works. However such a tricky way may not work under different situations. Yet at least, I feel happy with it.
Excellent, if that method worked for you.

It's my understanding that it's often best to do this through one of the package managers though, as that way the system registers it's presence and should then offer any upgrades that might come up.

regards

John
 
Old 06-22-2006, 07:33 PM   #5
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
When you install with the Nvidia installer, X can't be running. I found that trying things like logout, init 3 and various 3 key combinations got me to a terminal session but still left X running in the background. I have discovered that if you reboot into Recovery you will be at level 3 command line as root. No sudo required but you have to remember that roots home directory is different than yours and the old ~ now points to a different directory. You have to use /home/{user} instead of ~.
 
Old 06-27-2006, 10:02 PM   #6
PDR60
Member
 
Registered: Aug 2003
Location: Oakland, TN
Distribution: Debian, Kubuntu
Posts: 257

Rep: Reputation: 30
The easiest way to stop the x server is to issue (in a console)
Code:
sudo /etc/init.d/kdm stop
you can also use start to restart x.

I found the easiest way to install the 8762 version(the latest) of the nvidia driver is to first update to the latest kernel and header packages. I think its .25 now. Then install the matching latest modules that match the new kernel. That's the nvidia-glx, nvidia-kernel-common and the linux-restricted-modules that all match your new kernel. This can all be done through adept. It also will use the ubuntu sources so future upgrades will be done through the adept updater. After all this is done, a reboot will show the Nvidia splash screen and you'll also get the nvidia setting listed in the "System" menu. If you don't see the Nvidia splash screen then open up the "System Settings" and go to the display setup. Once there, go to "Adminiatrator Mode", select the "Hardware" tab and click on the "Configure" button on the graphics card. Find your card under "Manufactures->Nvidia->card name", set the memory amount correctly, and click on "Proprietary". Save by closing the "Systems settings" . To restart the X-Server just hit CTRL+ALT+Backspace. You should see the Nvidia splash screen now!!

I used to install through the Nvidia script but this is easier and it seems to be staying current with the Nvidia driver releases. I'm adding this all to my install How-To along with the cedega install and a couple of games. It should be up there tomorrow

http://www.linuxloader.com/modules.p...howpage&pid=28

PDR60

Last edited by PDR60; 06-27-2006 at 10:10 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA version mismatch between kernel module and x windows s|k Linux - Hardware 6 03-05-2006 01:37 AM
kernel module mismatch vmniza Linux - Newbie 3 02-01-2005 02:44 PM
Mismatch between NVIDIA Kernal and X module ccin1492 Linux - Distributions 10 03-01-2004 12:14 PM
Kernel-module Version Mismatch !!! lionking_x Linux - Networking 1 02-02-2004 02:07 PM
Kernel-module Version Mismatch !!! lionking_x Linux - Software 1 02-02-2004 02:06 PM


All times are GMT -5. The time now is 09:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration