LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   ns2.29 installation in ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/ns2-29-installation-in-ubuntu-826560/)

bolmeteus 08-16-2010 12:39 PM

ns2.29 installation in ubuntu
 
I have successfully installed ns-2.29 on ubuntu and even patched in mannasim. the "make file" of ns2 is sucessful as well.

The problem arises, whenever i try to run a tcl file.. eg: example1.tcl
it gives an error regarding nam. I have installed nam-1.11 and configured it too.

It is however unable to open the graphical window. Moreover, no trace files are created, nor any output is found in "nam.out"

Anyone who can guide me, please ? !!
:banghead:

knudfl 08-16-2010 02:22 PM

Welcome to LQ. .. .. :) ..

Assume ns-allinone-2.29.3.tar.gz :
The only one that works with mannasim.

Creating a usable nam :
cd ns-allinone-2.29/tk8.4.11/
patch -p0 < tk-8.4-lastevent.patch
http://bugs.gentoo.org/attachment.cgi?id=161242
http://bugs.gentoo.org/show_bug.cgi?id=225999
... and then run ./install again.

Not all files <example>.tcl will create ' nam.out '.
Please provide a link to the code "example1.tcl".

Please also read other LQ threads tagged ns2 , ns229 , mannasim.
Example : LQ Search >>> 'Tag Name' = mannasim
..

rami_hachem 02-08-2011 02:55 AM

test
 
this is my first msg

rami_hachem 02-08-2011 02:56 AM

Hi sir,
I am trying to install ns2.29.2 on ubuntu 8.04
can you help if you have the procedure on how to do it please

thanks

knudfl 02-08-2011 02:46 PM

Post #4 , @rami_hachem : Welcome to LQ.

Please use ns-allinone-2.29.3 ( Please read post #2 )
http://sourceforge.net/projects/nsna...allinone-2.29/

http://sourceforge.net/projects/nsna...ar.gz/download
> > ns-allinone-2.29.3.tar.gz
This is the version, that can be used on Ubuntu.

..


All times are GMT -5. The time now is 11:45 AM.