LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 06-09-2012, 07:43 AM   #1
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,340

Rep: Reputation: 42
no ibus


Hi, I have a new installation of Ubuntu 12.04 I'm having trouble with ibus.

This morning it was working fine. This afternoon, on reboot, it is not present in the top bar of my screen. I tried running im-config, and checked the radio button 'ibus'

I also tried system settings > Language. Normally, one should be able to choose the input method there, but that function does not work, please see screenshot. Where it says 'keyboard input method system' no amount of clicking will elicit a response.

Any tips out there? I need my Chinese input!
Attached Images
File Type: png Screenshot from 2012-06-08 14:58:39.png (47.1 KB, 4 views)
 
Old 06-09-2012, 08:21 AM   #2
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Sitting in front of my computer.
Distribution: Debian
Posts: 1,008
Blog Entries: 2

Rep: Reputation: 254Reputation: 254Reputation: 254
Try opening Ibus preferences. It should be somewhere in the Settings or Preferences menu, whichever Ubuntu uses.
In IBus/Preferences/General, enable Show icon on system tray.
That should work.
 
Old 06-09-2012, 08:32 AM   #3
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,340

Original Poster
Rep: Reputation: 42
Thanks, but no that is not possible. Ibus is not accessible, so I can't adjust the preferences that way.

What I've done is uninstall everything connected with ibus, then reinstalled. Some older language choices were removed. Now it works again. I think the people at Ubuntu have changed things, but forgot to mention it. Now I can choose Sunpinyin. pinyin has gone. Probably there was a clash of libraries or whatever, I'm no expert. Languages has also disappeared from System Settings. Anyway, it works again. Time for bed, see if it works tomorrow morning!!
 
Old 06-09-2012, 09:07 AM   #4
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Sitting in front of my computer.
Distribution: Debian
Posts: 1,008
Blog Entries: 2

Rep: Reputation: 254Reputation: 254Reputation: 254
If the Ibus preferences dialogue does not have an entry in the settings menu, it is probably another problem with the monster called Unity. Yet another reason to not use Ubuntu.
 
Old 06-09-2012, 12:51 PM   #5
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,340

Original Poster
Rep: Reputation: 42
I only installed Ubuntu because Fedora 17 has too many problems. But the ibus always worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iBus adding languages Pedroski Ubuntu 3 09-28-2011 07:14 PM
[SOLVED] Ibus Does Not Work - Anyone? hitmen Linux - Newbie 2 09-22-2011 09:08 PM
[SOLVED] how to use ibus in urxvt in fvwm haiyuan_victor Linux - Desktop 3 09-07-2011 05:13 AM
pinyin and ibus Pedroski Linux - Software 15 10-21-2010 06:36 AM
[Call for testing] ibus SlackBuild grissiom Slackware 6 05-19-2009 10:39 AM


All times are GMT -5. The time now is 04:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration