LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2010, 09:19 AM   #1
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
No boot splash with Ubuntu Lucid 10.04 LTS.


Hello all,

Just got Lucid stable LTS and installed it on my dell optiplex 330n desktop. Most of the things are fine but theres no grub menu or boot splash. I have no way to tell if system is booting. It directly takes me to login screen. Before that there is nothing on the screen. After that I can login and work normally.
The issue could be with the graphics controller. Its Intel integrated.

Below is the output from lspci -vv

Code:
00:02.1 Display controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
	Subsystem: Dell Device 0220
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Region 0: Memory at dfe80000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 
Old 04-30-2010, 10:51 AM   #2
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Is Ubuntu the only operating system on your computer?
If so, then you will not see the grub menu on bootup. If you wish to see the grub menu on bootup, then edit /etc/default/grub file, and uncomment the line:
Code:
GRUB_HIDDEN_TIMEOUT=0
reference: https://wiki.ubuntu.com/Grub2
See the section: grub (/etc/default/grub) in that tutorial.
I believe that if you hit the Esc key on bootup, then you will see the grub menu even if it is hidden. This was true for grub-legacy. I believe it is still true for grub2.
So is Ubuntu the only operating system on your computer? And...
Did you do a clean install of Ubuntu 10.04? Or did you upgrade from 9.10 or 8.04LTS?

Last edited by tommcd; 05-01-2010 at 06:39 AM.
 
Old 04-30-2010, 10:52 AM   #3
caffemisto
LQ Newbie
 
Registered: Jul 2009
Location: Central California
Distribution: Slackware
Posts: 17

Rep: Reputation: 0
I have the same issue with my Dell GX280 and I agree it has something to do with the graphics card. I'm using an ATI PCI-X XL300 video card. I did however received a message during boot that said: unsupported video mode or something like that, but only once. Never seen that message again. I'm thinking the only way to see what's going on during boot is to disable bootsplash(or whatever) to be able to see all the boot time messages. But since I'm able to login and the computer is working fine, I'm leaving everything as is.

Last edited by caffemisto; 04-30-2010 at 10:53 AM.
 
Old 04-30-2010, 11:04 AM   #4
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by caffemisto View Post
I have the same issue with my Dell GX280 and I agree it has something to do with the graphics card.
What graphics card do you have?
If you have nvidia or ati, have you installed the proprietary drivers?
 
Old 04-30-2010, 10:00 PM   #5
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
I also had the same problem on my Acer Aspire One (on which I used the Lucid Lynx to replace Linpus). It was more common in the Betas, but I do know why the problem exists (at least on my computer): I noticed that Ubuntu's Plymouth theme (in /lib/plymouth) did not exist. However, it soon fixed itself. Probably a bug in the way the kernel mounts the root drive: It probably mounts it but doesn't see the files (sometimes). Just wait a few boots and see what happens. It took my configuration WEEKS to finally fix itself.

Edit: The boot splash reappeared on my netbook as soon as an update was released. You see, Ubuntu sometimes installs but fails to copy some files. Of course, this was with a USB drive.

Last edited by Kenny_Strawn; 04-30-2010 at 10:01 PM.
 
Old 05-01-2010, 08:00 PM   #6
dreamweaver547
LQ Newbie
 
Registered: Nov 2009
Location: England
Distribution: Ubuntu 9.10, OpenSUSE 11.2
Posts: 28

Rep: Reputation: 15
removed

...

Last edited by dreamweaver547; 05-01-2010 at 08:02 PM. Reason: removed
 
Old 05-03-2010, 12:11 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by tommcd View Post
Is Ubuntu the only operating system on your computer?
If so, then you will not see the grub menu on bootup. If you wish to see the grub menu on bootup, then edit /etc/default/grub file, and uncomment the line:
Code:
GRUB_HIDDEN_TIMEOUT=0
So is Ubuntu the only operating system on your computer? And...
Did you do a clean install of Ubuntu 10.04? Or did you upgrade from 9.10 or 8.04LTS?
The line is already uncommented by default. I did a clean install. Previously had Karmic and this issue was never there.
 
Old 05-03-2010, 12:00 PM   #8
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by linuxlover.chaitanya View Post
The line is already uncommented by default. I did a clean install. Previously had Karmic and this issue was never there.
So, as I asked in my last post:
Is Ubuntu the only OS on the computer??
If so, then you will not see the grub2 menu on bootup.
https://wiki.ubuntu.com/Grub2#grub%2...efault/grub%29
If you hit the Esc key on bootup, do you then see the grub2 menu??
 
Old 05-04-2010, 12:32 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Original Poster
Rep: Reputation: Disabled
Yes Ubuntu is the only OS and Esc key does not bring the boot menu. This key has been shifted to Shift key according to some. But I do not see splash screen. That is the problem.
 
Old 05-04-2010, 12:37 AM   #10
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by linuxlover.chaitanya View Post
Yes Ubuntu is the only OS and Esc key does not bring the boot menu. This key has been shifted to Shift key according to some. But I do not see splash screen. That is the problem.
The Shift key does not seem to be working either. No grub menu and no splash screen.
 
Old 05-04-2010, 10:06 AM   #11
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by linuxlover.chaitanya View Post
This key has been shifted to Shift key according to some. But I do not see splash screen. That is the problem. ...
The Shift key does not seem to be working either. No grub menu and no splash screen.
Yes, you are right. Now that I think of it, grub2 now uses the shift key instead of Esc. My boot menu is always shown since I always have several OSs installed. So I never have to push any keys to get the menu.

Ok. I just realized something. According to the Ubutnu wiki, the
GRUB_HIDDEN_TIMEOUT=0 line in /etc/default/grub should be commented out, not uncommented as I had previously posted. So to display the grub menu on bootup, comment out that line in /etc/default/grub. See:
https://wiki.ubuntu.com/Grub2#grub%2...efault/grub%29
Quote:
GRUB_HIDDEN_TIMEOUT=0
The menu will be hidden unless a # symbol is present at the beginning of this line.
( # GRUB_HIDDEN_TIMEOUT=0 )
Sorry for the mistake. I am still learning the finer points of grub2 myself.
So comment out: # GRUB_HIDDEN_TIMEOUT=0 in /etc/default/grub. Then reboot and see if you get the grub menu.

Last edited by tommcd; 05-04-2010 at 10:09 AM.
 
Old 05-05-2010, 12:07 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Original Poster
Rep: Reputation: Disabled
@Tom,

Will try and post the outcome.
 
Old 05-05-2010, 12:10 AM   #13
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by tommcd View Post
Yes, you are right. Now that I think of it, grub2 now uses the shift key instead of Esc. My boot menu is always shown since I always have several OSs installed. So I never have to push any keys to get the menu.

Ok. I just realized something. According to the Ubutnu wiki, the
GRUB_HIDDEN_TIMEOUT=0 line in /etc/default/grub should be commented out, not uncommented as I had previously posted. So to display the grub menu on bootup, comment out that line in /etc/default/grub. See:
https://wiki.ubuntu.com/Grub2#grub%2...efault/grub%29

Sorry for the mistake. I am still learning the finer points of grub2 myself.
So comment out: # GRUB_HIDDEN_TIMEOUT=0 in /etc/default/grub. Then reboot and see if you get the grub menu.

Thanks it works. I have the grub menu. But I still do not have splash screen but that seems to be a bug and most probably has been filed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Top things to do after installing Ubuntu 10.04 LTS Lucid Lynx LXer Syndicated Linux News 1 04-29-2010 08:03 PM
LXer: Ubuntu 10.04 LTS Lucid Lynx Release Candidate Is Out [See What's New] LXer Syndicated Linux News 0 04-22-2010 09:20 PM
LXer: How to upgrade to Ubuntu 10.04 LTS Lucid Lynx LXer Syndicated Linux News 0 04-06-2010 10:31 PM
LXer: Ubuntu 10.04 LTS Lucid Lynx beta1 Screenshot tour LXer Syndicated Linux News 0 03-20-2010 02:20 AM
LXer: Ubuntu Lucid Lynx (10.04 LTS) Alpha 3 is here LXer Syndicated Linux News 0 02-26-2010 01:00 PM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration