LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Network manager unable to connect to unsecured wireless - WPA networks fine :S (http://www.linuxquestions.org/questions/ubuntu-63/network-manager-unable-to-connect-to-unsecured-wireless-wpa-networks-fine-s-480057/)

phyre-x 09-03-2006 02:05 PM

Network manager unable to connect to unsecured wireless - WPA networks fine :S
 
i have a small problem with my wireless that has come to my attention in which i cannot connect to unsecured networks, i have been using my WPA secured network now fine without many problems but when i tried connecting to an unsecured network elsewhere it would not connect, i know the network is accessible without access list alteration etc because i have a windows laptop aswel which connected fine.

my setup is using the ndiswrapper driver for a broadcom chipset (not ideal i know) and network manager with wpa supplicant etc installed.

any thoughs ?

thanks

randell6564 09-03-2006 05:17 PM

Quote:

Originally Posted by phyre-x
i have a small problem with my wireless that has come to my attention in which i cannot connect to unsecured networks, i have been using my WPA secured network now fine without many problems but when i tried connecting to an unsecured network elsewhere it would not connect, i know the network is accessible without access list alteration etc because i have a windows laptop aswel which connected fine.

my setup is using the ndiswrapper driver for a broadcom chipset (not ideal i know) and network manager with wpa supplicant etc installed.

any thoughs ?

thanks

If you are connecting to your WPA secured network without problems then why the need to connect to other unsecured networks?

phyre-x 09-03-2006 08:13 PM

its my laptop so really need full functionality of my wireless for roaming, university etc.

randell6564 09-03-2006 08:32 PM

Quote:

Originally Posted by phyre-x
its my laptop so really need full functionality of my wireless for roaming, university etc.

So, you are moving around with your laptop and will need to connect to random networks? Thats possible, but even though they are unsecured, you will still need to know the name of the network that you want to connect to. I can get unsecured networks here at home only if I enter the NAME of the unsecured network that I am trying to connect to.

I suppose that there are scripts available that when executed will scan for networks, making the name available to you, but I believe thats illegal.

randell6564 09-03-2006 08:37 PM

Anyway.,have you familiarized yourself with System>Administration>Networking?

You should see 'Wireless connection' along with 'Ethernet connection' and 'Modem Connection'.

With me, I select 'Wireless Connection', click on 'Properties' and enter the network name, choose 'DHCP' and I'm in! Again, this only works if I know the name of the network.

phyre-x 09-04-2006 10:36 AM

ok first off scanning for wireless networks is not illegal , its why we have the broadcast ssid option on our routers. public wifi networks are ment to be accessed. im very familiar with gnome network utility which also displays me a list of available wireless network on the drop down under ssid , im guessing your card does not support the scan function. im trying to use gnome network manager becasue it is more targetted to moving around between networks and making the experience less intrusive.

thankyou for your contribution but you fail to see my point

oiper 04-24-2007 03:05 PM

network manager
 
phyre-x, I'm with you on this. The Network Manager picks up my University's wireless ssid, but refuses to connect. While spinning it's wheels, it will set the ssid, but never tries to run dhclient. All the secure networks I use work problem free. I am also using ndiswrapper.

This is quite frustrating and I have to set up scripts to workaround the issue for now.

randell6564 04-24-2007 07:54 PM

Yeah.,My Bad guys! Actually I have not seen replys to this post for a very long time! (I do not even LIVE at the same address anymore!)

I guess I must have half-read the OP. I was thinking that you were trying to connect to an unsecured wireless network without permission. THAT would be illegal.

Quote:

The Network Manager picks up my University's wireless ssid, but refuses to connect. While spinning it's wheels, it will set the ssid, but never tries to run dhclient.
Are you sure that you entered the name of the ESSID correctly?
This sounds really stupid, but I had the very same problem when I moved. I just unplugged my machine and plugged it into the wall of my new home, and suddenly could not access the internet even though my wireless antenna could SEE the network!

It turns out that the ESSID was entered incorrectly.
Check out my thread concerning this issue.

Hope this helps!

allanf 05-16-2011 11:11 AM

Quote:

Originally Posted by randell6564 (Post 2724052)
Yeah.,My Bad guys! Actually I have not seen replys to this post for a very long time! (I do not even LIVE at the same address anymore!)

I guess I must have half-read the OP. I was thinking that you were trying to connect to an unsecured wireless network without permission. THAT would be illegal.



Are you sure that you entered the name of the ESSID correctly?
This sounds really stupid, but I had the very same problem when I moved. I just unplugged my machine and plugged it into the wall of my new home, and suddenly could not access the internet even though my wireless antenna could SEE the network!

It turns out that the ESSID was entered incorrectly.
Check out my thread concerning this issue.

Hope this helps!

I realize that t a lot of time has passed since this post and you are probably no longer in school, but you may be traveling and may still have this issue. I just checked into a hotel and my wireless did every thing but get the IP/GW/DNS due to wpa_supplicant. My solution was to kill the wpa_supplicant and then have "dhcpcd" ask for a new dhcp via (dhcpcd -n wlan). If you are using another dhcp client please follow the directions for that client.


All times are GMT -5. The time now is 11:31 PM.