LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 10-27-2007, 09:52 AM   #1
netjack
Member
 
Registered: Sep 2003
Location: Italy
Distribution: ubuntu 12.04 64 bit
Posts: 89

Rep: Reputation: 15
Network device name


Hi,
I'm trying to configure Opendns.com servers as dns servers, following this guide: https://www.opendns.com/start?device=ubuntu

Step 2 explains the modifications on dhclient.conf; after that I'm required to do
Code:
$ sudo ifdown eth0 && sudo ifup eth0
which returns
Code:
ifdown: interface eth0 not configured
Ignoring unknown interface eth0=eth0.
I've been looking around, but could not find the name of my network device. Where do I find it?

thx
 
Old 10-27-2007, 10:12 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Try running the command 'sudo ifconfig' ( without the quotes ). That should list your interfaces by name. What type of card do you have?
 
Old 10-28-2007, 02:39 AM   #3
netjack
Member
 
Registered: Sep 2003
Location: Italy
Distribution: ubuntu 12.04 64 bit
Posts: 89

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by camorri View Post
Try running the command 'sudo ifconfig' ( without the quotes ).
This returns that I have indeed an eth0:

Code:
eth0      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::240:f4ff:fe6f:1aac/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:55430 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37500 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:81005016 (77.2 MB)  TX bytes:2923984 (2.7 MB)
          Interrupt:9 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
Quote:
Originally Posted by camorri View Post
What type of card do you have?
It's a NIC Fast Ethernet PCI Realtek RTL8139 Realtek Family card.

thx

Last edited by netjack; 11-14-2007 at 02:44 AM. Reason: Hiding personal info
 
Old 11-03-2007, 10:07 AM   #4
Zelige
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Rep: Reputation: 0
Further help needed

Hi chaps, this discussion was really helpful to find. I am a complete Ubuntu beginner and don't know what to do next.

I receive the same response from the Terminal as netjack -

ifdown: interface eth0 not configured
Ignoring unknown interface eth0=eth0.

I don't know what this means at all.

I follow camorri's instructions and receive similar response but don't know what to do with it.

Can you help?
 
Old 11-03-2007, 12:54 PM   #5
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Zelige,

Quote:
ifdown: interface eth0 not configured
This simply means the interface is not active, or not configured. Your ethernet interface may not be called 'eth0' To find out what any interface is called on your system, in a konsole run the comand 'sudo ifconfig'. In Ubuntu you will be prompted for the root password, enter it, press enter, the command should run and display all interfaces. On the left side of the display you will see the name(s) of the interface(s).

To activate an interface, you need the name, then run the command 'sudo ifconfig nameofinterface up' ( without the quotes, you need the root password. Just change thenameofinterface to the name of the interface.

If it has not need configured, then not much will happen. You will need to configure the interface.
 
Old 11-03-2007, 01:05 PM   #6
Zelige
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Rep: Reputation: 0
Camorri, thanks for that, when I run the sudo command I receive -

eth0 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17 Base address:0xe000

eth1 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::216:e3ff:fe61:c96b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5079 errors:0 dropped:0 overruns:0 frame:0
TX packets:4627 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3447454 (3.2 MB) TX bytes:1073277 (1.0 MB)

eth2 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:16 Base address:0xc000 Memory:b0101000-b0101fff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:43 errors:0 dropped:0 overruns:0 frame:0
TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2521 (2.4 KB) TX bytes:2521 (2.4 KB)

I really am new to all this: does this mean I have more than one ethernet interface - eth0, eth1 and eth2?

Last edited by Zelige; 11-13-2007 at 04:08 AM. Reason: real IP addresses shown
 
Old 11-13-2007, 04:29 AM   #7
Zelige
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Rep: Reputation: 0
Network device name?

Hi, I am still confused_ what is my network device name>? It looks to me like it is eth0 - but this is not recognised by the console.
 
Old 11-13-2007, 09:07 AM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
It appears to me as if you have three ethernet interfaces. Only eth1 had an IP address when you posted the output. Note the Inet Addr field in eht1.

I don't know your hardware at all. Have a look to see if you have more than one interface installed. Do you need all three? Is there a problem if you use eth1?

It appears eth0 is not configured.
 
Old 11-13-2007, 05:12 PM   #9
gcordoba
LQ Newbie
 
Registered: Nov 2007
Location: Colombia
Distribution: ubuntu
Posts: 7

Rep: Reputation: 0
eth0 not configured

I got the same problem either using Debian or Ubuntu. The commend "ifdown" reports "interface eth0 not configured".

Thus, the question becomes: how can we configure eth0?
Thanks and best regards
 
Old 11-14-2007, 09:14 AM   #10
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
gcordoba,

This is thread hijacking. Please start your own thread.

Quote:
Thus, the question becomes: how can we configure eth0?
My question is, do you really have eth0? Post the results of the command '/sbin/ifconfig' without the quotes. That will list all interfaces, including eth0 if you have it.

You also list two distros, some, like Ubuntu have gui tools to configure the interface. Pick one distro, and go from there.
 
Old 11-15-2007, 05:54 AM   #11
gcordoba
LQ Newbie
 
Registered: Nov 2007
Location: Colombia
Distribution: ubuntu
Posts: 7

Rep: Reputation: 0
OpenDNS and eth0

Thanks for your reply Camorri.
Yes, you are ok. Maybe I need to post a new thread. However, I think my question have some ralationship.

By the way, I found an alternative answer to the OpenDNS question in
https://answers.launchpad.net/ubuntu/+question/16486
that seems to work for someone (not for me...)

About the eth0 confiuration, I found that in my interfaces, the lines
eth0 auto
iface eth0 inet dhcp
were comented. Once I delete the comment the eth0 was not longer reported as "not configured". However, I am still without connection despite ifconfig reports an ip, a network, etc. As that occurs in both Debian and Ubuntu LiveCD I think that it is possible physical problem (like a damaged cable). However, please, do you have an other test that I can do?
Thanks.
 
Old 11-15-2007, 08:01 AM   #12
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
If you use dhcp and you got an adress, it means that the cable and hardware parts are somehow working.
Did you manage to ping by IP?
Are you sure you have no firewall blocking?
 
Old 11-18-2007, 08:17 AM   #13
gcordoba
LQ Newbie
 
Registered: Nov 2007
Location: Colombia
Distribution: ubuntu
Posts: 7

Rep: Reputation: 0
Thanks,
I am nor sure if it is a firewall problem (how to know?). Some of my tryals results in:
ubuntu@ubuntu:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:11:11:00:9A:58
inet addr:192.168.10.101 Bcast:192.168.10.127
Mask:255.255.255.224
inet6 addr: fe80::211:11ff:fe00:9a58/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:970 errors:0 dropped:0 overruns:0 frame:0
TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:125749 (122.8 KB) TX bytes:4985 (4.8 KB)
Base address:0xdf40 Memory:fcfe0000-fd000000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

ubuntu@ubuntu:~$ ping 137.222.20.146
connect: Network is unreachable
ubuntu@ubuntu:~$ sudo dhclient
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:11:11:00:9a:58
Sending on LPF/eth0/00:11:11:00:9a:58
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPOFFER from 192.168.0.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.1
SIOCADDRT: No such process
bound to 192.168.10.101 -- renewal in 3980 seconds.
ubuntu@ubuntu:~$

It is interesting the SIOCADDRT report. Does that have something to do? How can I be sure if the problem deals with a firewall (even using a LiveCd)?
With best regards,
Gustavo
 
Old 11-18-2007, 08:41 AM   #14
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Could you post some information on your network connection? I know you have an ethernet card, you have got an IP address, so the DHCP request works. You probably have a router. Is that correct? What type of router is it? Make model etc. Is it ADSL or cable?

What is the gateway IP address? Can you ping that far? What is in your /etc/resolv.conf file? It should have the IP addreses of your ISP's DNS servers.

Firewalls, a router is usually a firewall. Have you looked at the configuration of the router? You can also run a firewall in linux. However if you have not configured it, or installed one, it is unlikely you are running one under linux. You would know if you had configured one.
 
Old 12-06-2007, 11:00 AM   #15
gcordoba
LQ Newbie
 
Registered: Nov 2007
Location: Colombia
Distribution: ubuntu
Posts: 7

Rep: Reputation: 0
Hi,
I just re-installed all the system...without success.
I tried to ping the gateway without success. Any direct command like route add, etc allows this machine to take the gateway. Then, I asked to the people of the server and they provide me with a small lines to append to /etc/rc.local

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

/sbin/ifconfig eth0 xxx.xxx.xxx.xx netmask 255.255.255.0 up
/sbin/route add -net default gw xxx.xxx.xxx.xx

Note that exit 0 command has been dropped, otherwise the tip doesnt work.

Despite the success, I thick that this is a bug-like for some machines or servers.
Thanks for your time,
Gustavo
 
  


Reply

Tags
configuration, device, network, opendns


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
network device down varun_saa Mandriva 16 02-10-2010 08:11 AM
Where is the network device? essdeeay Linux - Networking 1 04-21-2006 10:10 AM
3c905C network card in docking station. Cannot activate network device eth0. pathelms Linux - Networking 4 04-12-2006 02:55 PM
Network card not working? Cannot activate network device eth0 lifeonitsown Linux - Networking 1 11-17-2005 06:30 AM
no network device?!?! sjefke37 Linux - Newbie 8 03-28-2004 12:58 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration