LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Mouse and keyboard stop working when X server starts (http://www.linuxquestions.org/questions/ubuntu-63/mouse-and-keyboard-stop-working-when-x-server-starts-751010/)

Parent5446 08-28-2009 10:51 PM

Mouse and keyboard stop working when X server starts
 
I randomly started up my laptop one day and the mouse and keyboard stopped responding once GDM's login screen came up. Everything works fine from the console, but even if I run startx from the login shell the mouse and keyboard do not work, even though everything else in GNOME runs perfectly.

I am using an HP dv6426us laptop running Ubuntu 9.04 (i686 architecture with the 2.6.28-15-generic kernel). Below is a copy of my xorg.conf file, just in case there might be something wrong with that. I will try and put more information on, but seeing as I have to use a different computer to post this thread, copying over log files and stuff is difficult for the moment (though I am going to try and copy them over to a flash drive).

Code:

Section "Monitor"
    Identifier  "Configured Monitor"
Endsection

Section "Screen"
      Identifier    "Default Screen"
      Monitor      "Configured Monitor"
      Device        "Configured Video Device"
      SubSection    "Display"
              Virtual 2432 800
      EndSubSection
EndSection

Section  "Device"
        Identifier      "Configured Video Device"
EndSection

Section "ServerFlags"
        Option  "DontZap"    "False"
Endsection


Parent5446 09-07-2009 10:30 PM

New Problems
 
1 Attachment(s)
Some more information has surfaced. I used "Xorg -configure" to make a new configuration file, and below was the result, but it still did not work.

Code:

Section "ServerLayout"
        Identifier    "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/X11/misc"
        FontPath    "/usr/share/fonts/X11/cyrillic"
        FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/X11/Type1"
        FontPath    "/usr/share/fonts/X11/100dpi"
        FontPath    "/usr/share/fonts/X11/75dpi"
        FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load  "record"
        Load  "dri2"
        Load  "glx"
        Load  "extmod"
        Load  "dri"
        Load  "dbe"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "NoAccel"                    # [<bool>]
        #Option    "SWcursor"                  # [<bool>]
        #Option    "ColorKey"                  # <i>
        #Option    "CacheLines"                # <i>
        #Option    "Dac6Bit"                    # [<bool>]
        #Option    "DRI"                        # [<bool>]
        #Option    "NoDDC"                      # [<bool>]
        #Option    "ShowCache"                  # [<bool>]
        #Option    "XvMCSurfaces"              # <i>
        #Option    "PageFlip"                  # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName  "Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
        BusID      "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport  0 0
                Depth    1
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    4
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    8
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    15
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    16
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

Looking into the log file, I found that the AllowEmptyInput option on the ServerFlags was set to true, which meant the server was disabling any devices with certain mouse and keyboard drivers, hence my problem. I quickly reverted the configuration file to its original form and added the following:

Code:

Section "ServerFlags"
        Option          "AllowEmptyInput"      "false"
EndSection

Finally, it worked. However it left a number of other problems. When I logged in, an error box came up saying HAL could not be started (see the uploaded screenshot). I checked the init script and confirmed it was not running. If I start it up, the keyboard starts acting strange, and whenever I press a key it acts like I pressed two or three times. The entire system works fine if I leave HAL off, but having it off is stopping certain GNOME capabilities, such as the brightness tool on one of my panels.

divukman 12-03-2009 03:20 PM

Hey,

I had the same problem with my toshiba laptop and I used your solution:

Code:

Section "ServerFlags"
        Option          "AllowEmptyInput"      "false"
EndSection

Just got it working. Thanks! I 'll go into details later! But X works, keyboard works :-).


All times are GMT -5. The time now is 05:55 AM.