-   Ubuntu (
-   -   Mounting an HFS+ HDD on Ubuntu URGENT! (

Altiris 03-30-2013 11:06 AM

Mounting an HFS+ HDD on Ubuntu URGENT!
I need help mounting an HFS+ HDD on Ubuntu, so far I have created a /media/DISK1 folder and a /mnt/DISK1. I have also installed hfsutils and two other hfs things.

I tried using the command:

sudo mount -o force -t hfsplus /dev/sdb /mnt/DISK1
But I get:

mount: wrong fs type, bad option, bad superblock on /dev/sdb,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

What do I need to do?

ronlau9 03-30-2013 12:36 PM

What kind of HD ?
If I put a USB HD with is formatted in HFS+ linux Mint just read fine .
Without mounting or so
So what is you're problem

acid_kewpie 03-30-2013 12:37 PM

this isn't urgent for us, please don't mark it as such. And you didn't even say please or thank you.

273 03-30-2013 03:25 PM

Perhaps you just need to address the partition not the device by mounting /dev/sdb1 ? I've not used HFS+ though so I can't be certain that's needed but it generally is for other file systems.

ronlau9 03-30-2013 04:02 PM

To be honest I really do not know what his problem is both Linux Mint and UBUNTU STUDIO just read hfs+ file system by default .
It even find the partition names by default .
It can not write by default to a HFS file system

John VV 03-30-2013 07:27 PM

A few things are needed for us to help

what version of ubuntu is this ?
hfs+ should just auto mount if it is a usb drive

If not , then you have somethings turned off or not installed

then with the usb drive plugged in run

su -
--- type in the root password when asked ( or use "sudo" instead of su - ) ---
--- and this ---
fdisk -l

those two commands will show what the usb drive is and just how it is seen by the OS

All times are GMT -5. The time now is 07:12 AM.