LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 05-18-2006, 11:19 PM   #1
resnostyle
LQ Newbie
 
Registered: Mar 2006
Posts: 23

Rep: Reputation: 15
mounting a samba share


i have had about enough looking through other links because they have yet to help me. i am trying to mount a samba share and i have tried different syntax methods and nothing seems to work.

one more problem i am having is when i try to view the network through my linux machine it asks for authentication and i dont know what the username or password is..
 
Old 05-18-2006, 11:27 PM   #2
paul_mat
Member
 
Registered: Nov 2004
Location: Townsville, Australia
Distribution: Fedora Core 5, CentOS 4, RHEL 4
Posts: 855

Rep: Reputation: 30
try

mount -t smbfs -o username=administrator //server/share /mnt/samba

enter no password

or

mount -t cifs -o username=administrator //server/share /mnt/samba
 
Old 05-19-2006, 08:44 AM   #3
resnostyle
LQ Newbie
 
Registered: Mar 2006
Posts: 23

Original Poster
Rep: Reputation: 15
ok i entered each and got seperate error messages:

mount -t smbfs -o username=administrator //server/share /mnt/samba

10685: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed


mount -t cifs -o username=administrator //server/share /mnt/samba

mount error 13=permission denied
refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

i imagine because i havent set permissions to it?

Last edited by resnostyle; 05-19-2006 at 08:46 AM.
 
Old 05-19-2006, 12:45 PM   #4
SweetLou
Member
 
Registered: Oct 2004
Distribution: Debian Testing
Posts: 171

Rep: Reputation: 30
Did you change "administrator" to your username on the box that you are trying to connect? And change the server and mount points to something you have? I mount mine through /etc/fstab so that they are mounted at boot.

//192.168.1.2/wwwroot /mnt/vprMatrix smbfs username=<myusername>,password=<mypassword>,rw,users,umask=0000,uid=1000,gid=1000 0 0

Of course this will not work for you unless you happen to have the same mount points, Windows box share and your username and password are <myusername> and <mypassword> uid and gid. You need to change these for your system.
 
Old 05-19-2006, 02:16 PM   #5
resnostyle
LQ Newbie
 
Registered: Mar 2006
Posts: 23

Original Poster
Rep: Reputation: 15
ok.. what is the password it keeps asking for? when i input

smbmount //ubuntu/share /mnt/share
 
Old 05-19-2006, 02:58 PM   #6
manishsingh4u
Member
 
Registered: Oct 2005
Location: Pune, India
Distribution: OpenSUSE 11.0
Posts: 422

Rep: Reputation: 30
Are you using "sudo" or "root" to mount these shares?
 
Old 05-19-2006, 04:17 PM   #7
resnostyle
LQ Newbie
 
Registered: Mar 2006
Posts: 23

Original Poster
Rep: Reputation: 15
which one should i use?
 
Old 05-19-2006, 06:37 PM   #8
manishsingh4u
Member
 
Registered: Oct 2005
Location: Pune, India
Distribution: OpenSUSE 11.0
Posts: 422

Rep: Reputation: 30
Quote:
which one should i use?
U can use anyone.
Anyway, if you use sudo, the system would ask for your password first. Then again at the next line, it would ask for the share password. If there's no share password, don't enter anything, just press enter. If there's a password, type it and press enter.
OR
If you use root account to mount a share, the eystem would ask for only the share password.
And sorry, for answering late as I was watching a movie on my Kubuntu from a share at my friend's Windows XP machine. Here's what I did
Code:
mann@Manish:~$ sudo mount -t smbfs //nitin/c /home/mann/Desktop/nitin_c -o "username=mann"
Password:
Password:
mann@Manish:~$
 
Old 05-19-2006, 11:26 PM   #9
resnostyle
LQ Newbie
 
Registered: Mar 2006
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by manishsingh4u
U can use anyone.
Anyway, if you use sudo, the system would ask for your password first. Then again at the next line, it would ask for the share password. If there's no share password, don't enter anything, just press enter. If there's a password, type it and press enter.
OR
If you use root account to mount a share, the eystem would ask for only the share password.
And sorry, for answering late as I was watching a movie on my Kubuntu from a share at my friend's Windows XP machine. Here's what I did
Code:
mann@Manish:~$ sudo mount -t smbfs //nitin/c /home/mann/Desktop/nitin_c -o "username=mann"
Password:
Password:
mann@Manish:~$

IT WORKED!!! Alright.. Now I just gotta get my XP machine to see it
 
Old 05-20-2006, 04:47 AM   #10
manishsingh4u
Member
 
Registered: Oct 2005
Location: Pune, India
Distribution: OpenSUSE 11.0
Posts: 422

Rep: Reputation: 30
Quote:
IT WORKED!!! Alright.. Now I just gotta get my XP machine to see it
U must use same workgroup or domain on both machines for this. Although not very necessary, but, it's good to do it.
 
Old 05-20-2006, 09:22 AM   #11
resnostyle
LQ Newbie
 
Registered: Mar 2006
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by manishsingh4u
U must use same workgroup or domain on both machines for this. Although not very necessary, but, it's good to do it.
yea i had already done that... samba could see the network but no body could see it
 
Old 05-20-2006, 09:42 AM   #12
manishsingh4u
Member
 
Registered: Oct 2005
Location: Pune, India
Distribution: OpenSUSE 11.0
Posts: 422

Rep: Reputation: 30
Here's my /etc/samba/smb.conf
Code:
[global]
workgroup = mca
server string = ubuntu
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
security = share
encrypt passwords = true
passdb backend = tdbsam guest
obey pam restrictions = yes
guest account = nobody
invalid users = root
passwd program = /usr/bin/passwd %u
socket options = TCP_NODELAY

[mann]
   path = /home/mann
   writable = yes
   public = no
   create mask = 0755
   valid users = mann

[bharat]
   path = /home/bharat
   writable = yes
   public = no
   create mask = 0755
   valid users = bharat

[daniel]
   path = /home/daniel
   comment = daniel's folder
   writable = yes
   public = no
   create mask = 0755
   valid users = daniel

[d]
   path = /media/hda5
   writable = no
   browsable = yes
   public = yes

[e]
   path = /media/hda6
   writable = no
   browsable = yes
   public = yes

[f]
   path = /media/hda7
   writable = no
   browsable = yes
   public = yes
My network works fine with my two fellow Windows XP machies. I have Kubuntu 5.10. See if it helps u.

Last edited by manishsingh4u; 05-20-2006 at 09:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting samba share glock19 Linux - General 13 07-15-2013 09:50 PM
Mounting Samba Share linux_or_bust Linux - Software 6 02-16-2005 10:38 AM
samba share mounting bacon22 Linux - Software 1 01-24-2004 08:13 AM
Mounting Samba shares and Samba Share Login time112852 Linux - Software 1 09-14-2003 03:23 PM
Mounting a Samba Share msjenkins Linux - Software 0 07-16-2003 11:19 PM


All times are GMT -5. The time now is 10:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration