LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   mounting a samba share (http://www.linuxquestions.org/questions/ubuntu-63/mounting-a-samba-share-446279/)

resnostyle 05-18-2006 10:19 PM

mounting a samba share
 
i have had about enough looking through other links because they have yet to help me. i am trying to mount a samba share and i have tried different syntax methods and nothing seems to work.

one more problem i am having is when i try to view the network through my linux machine it asks for authentication and i dont know what the username or password is..

paul_mat 05-18-2006 10:27 PM

try

mount -t smbfs -o username=administrator //server/share /mnt/samba

enter no password

or

mount -t cifs -o username=administrator //server/share /mnt/samba

resnostyle 05-19-2006 07:44 AM

ok i entered each and got seperate error messages:

mount -t smbfs -o username=administrator //server/share /mnt/samba

10685: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed


mount -t cifs -o username=administrator //server/share /mnt/samba

mount error 13=permission denied
refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

i imagine because i havent set permissions to it?

SweetLou 05-19-2006 11:45 AM

Did you change "administrator" to your username on the box that you are trying to connect? And change the server and mount points to something you have? I mount mine through /etc/fstab so that they are mounted at boot.

//192.168.1.2/wwwroot /mnt/vprMatrix smbfs username=<myusername>,password=<mypassword>,rw,users,umask=0000,uid=1000,gid=1000 0 0

Of course this will not work for you unless you happen to have the same mount points, Windows box share and your username and password are <myusername> and <mypassword> uid and gid. You need to change these for your system.

resnostyle 05-19-2006 01:16 PM

ok.. what is the password it keeps asking for? when i input

smbmount //ubuntu/share /mnt/share

manishsingh4u 05-19-2006 01:58 PM

Are you using "sudo" or "root" to mount these shares?

resnostyle 05-19-2006 03:17 PM

which one should i use?

manishsingh4u 05-19-2006 05:37 PM

Quote:

which one should i use?
U can use anyone.
Anyway, if you use sudo, the system would ask for your password first. Then again at the next line, it would ask for the share password. If there's no share password, don't enter anything, just press enter. If there's a password, type it and press enter.
OR
If you use root account to mount a share, the eystem would ask for only the share password.
And sorry, for answering late as I was watching a movie on my Kubuntu from a share at my friend's Windows XP machine. Here's what I did
Code:

mann@Manish:~$ sudo mount -t smbfs //nitin/c /home/mann/Desktop/nitin_c -o "username=mann"
Password:
Password:
mann@Manish:~$


resnostyle 05-19-2006 10:26 PM

Quote:

Originally Posted by manishsingh4u
U can use anyone.
Anyway, if you use sudo, the system would ask for your password first. Then again at the next line, it would ask for the share password. If there's no share password, don't enter anything, just press enter. If there's a password, type it and press enter.
OR
If you use root account to mount a share, the eystem would ask for only the share password.
And sorry, for answering late as I was watching a movie on my Kubuntu from a share at my friend's Windows XP machine. Here's what I did
Code:

mann@Manish:~$ sudo mount -t smbfs //nitin/c /home/mann/Desktop/nitin_c -o "username=mann"
Password:
Password:
mann@Manish:~$



IT WORKED!!! Alright.. Now I just gotta get my XP machine to see it :study:

manishsingh4u 05-20-2006 03:47 AM

Quote:

IT WORKED!!! Alright.. Now I just gotta get my XP machine to see it
U must use same workgroup or domain on both machines for this. Although not very necessary, but, it's good to do it.

resnostyle 05-20-2006 08:22 AM

Quote:

Originally Posted by manishsingh4u
U must use same workgroup or domain on both machines for this. Although not very necessary, but, it's good to do it.

yea i had already done that... samba could see the network but no body could see it :cry:

manishsingh4u 05-20-2006 08:42 AM

Here's my /etc/samba/smb.conf
Code:

[global]
workgroup = mca
server string = ubuntu
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
security = share
encrypt passwords = true
passdb backend = tdbsam guest
obey pam restrictions = yes
guest account = nobody
invalid users = root
passwd program = /usr/bin/passwd %u
socket options = TCP_NODELAY

[mann]
  path = /home/mann
  writable = yes
  public = no
  create mask = 0755
  valid users = mann

[bharat]
  path = /home/bharat
  writable = yes
  public = no
  create mask = 0755
  valid users = bharat

[daniel]
  path = /home/daniel
  comment = daniel's folder
  writable = yes
  public = no
  create mask = 0755
  valid users = daniel

[d]
  path = /media/hda5
  writable = no
  browsable = yes
  public = yes

[e]
  path = /media/hda6
  writable = no
  browsable = yes
  public = yes

[f]
  path = /media/hda7
  writable = no
  browsable = yes
  public = yes

My network works fine with my two fellow Windows XP machies. I have Kubuntu 5.10. See if it helps u.


All times are GMT -5. The time now is 02:52 AM.