LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 07-20-2006, 06:40 PM   #1
ErrorBound
Member
 
Registered: Apr 2006
Posts: 280

Rep: Reputation: 31
Mounted /home on its own partition, now I can't login to X


As the title says. (Kubuntu dapper) Created a new ext3 partition and edited fstab. It mounts on /home at startup no problem. I copied all of the contents of the old /home into the new one, including hidden files.

However when i restart, kdm shows up and asks for a login. If I login as a normal user, the screen goes blank for a second and then the login screen returns. I can login to X as root, and I can login using any user at a text-based login.

Once after I restarted X and tried again, I got a hint that the problem might be with /usr/bin/kstartupconfig. I tried changing the permissions on it to allow normal users access (chmod +x /usr/bin/kstartupconfig), but no dice on that.

Ideas?
 
Old 07-20-2006, 06:50 PM   #2
ErrorBound
Member
 
Registered: Apr 2006
Posts: 280

Original Poster
Rep: Reputation: 31
Whooooops sorry about this post. Got it working almost immediately after posting. Needed to change the ownership of the home directories back to their respective owners.

Curse that root's midas touch.

Last edited by ErrorBound; 07-20-2006 at 06:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't allow partion permissions for a vfat partition, mounted as my home folder DrD Linux - General 19 07-26-2006 01:26 PM
NIS : Home dir not mounted p_test Linux - Networking 2 03-11-2006 11:28 AM
Gnome login problem with mounted /home partition steveybaby2 Slackware - Installation 8 01-06-2004 08:11 AM
Gnome login problem with mounted /home partition steveybaby2 Linux - Newbie 2 01-02-2004 10:41 AM
Windows partition is now mounted at /home!!!! jcksrobbins LinuxQuestions.org Member Success Stories 12 10-06-2003 05:53 PM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration