LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2006, 06:34 PM   #1
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
Mount ntfs as writable


How can I mount NTFS as writable? What programs do I need to download, etc.
 
Old 01-13-2006, 06:43 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Generally, this is a BAD idea. Write support in linux is not reliable and many people have hosed up their windows partitions this way.

However, the option you're looking for is Captive NTFS. I'm not sure if you have to install anything by default or just mount normally with the defaults,users,rw,umask=000 in the fstab line for the partition

Try this post:http://homes.esat.kuleuven.be/~decoc..._partitions_re

Last edited by pljvaldez; 01-13-2006 at 06:48 PM.
 
Old 01-13-2006, 06:49 PM   #3
halvy
Member
 
Registered: Aug 2005
Location: Boston Massachussets, USA
Distribution: my own Debian creation :)
Posts: 884

Rep: Reputation: 40
you can (i heard) use symlinks via fat32 for your personal date/desktop stuff.

and/or put linux inside windoze (ie co-linux) which will allow both win and lin to see each other since they are on the same partitian (sorta)... again, i'v only heard rumors about these feats.

good luck.
 
Old 01-13-2006, 06:54 PM   #4
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Thanks guys.

I'm not actually going to store anything on the Windows hard drive, but I am having trouble copying and pasting so I can backup My Documents, etc. I realise that I should have said this in the first place, but I didn't, and I am now. So, how can I copy and paste files from my Windows drive (after it is mounted as read only) and set myself as the owner, and make the files writable? I get an error in Konqueror.
 
Old 01-13-2006, 07:14 PM   #5
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
What error are you getting?

Unmount the partition and add this to your /etc/fstab (of course changing the /dev and mount point as required):

/dev/hda1 /media/windows ntfs defaults,users,ro,nls=utf8,umask=0222 0 0

Then remount the partition and you should be able to copy the files as a user.
 
Old 01-13-2006, 07:20 PM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
If by "copying and pasting", you are referring to the icons in konqueror, this is just a shortcut to copy files. Where are you trying to copy the files to? If you are trying to move files to a linux writable partition, one handy way of doing it is to split the konqueror's window, so that the source directory is on the left and the destination is on the right. Then you can select the files you want to copy over and drop then on the left.

If you are saying that the files you copied are read-only, then you can change the permissions of the file after copying.

An option to consider, is to use the "uid=" option in the /etc/fstab entry. This will make you the owner of the files which will allow you to change the permissions on them after you copy the file to a writable partition. Otherwise, you may have to su to root first.

For example, suppose that your user name is "sandrews", then you may wish to edit the /etc/fstab entry for the ntfs drive to something like this:
Code:
/dev/hda1            /xp                  ntfs       defaults,uid=sandrews      0 0
 
Old 01-13-2006, 07:27 PM   #7
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
It's wierd, when I copy the files, I type sudo konqueror (I've also used run as...) and try to change the permissions of the folder. But I get a window titled error, and it then says the name of the directory in the window, no description.
 
Old 01-13-2006, 07:30 PM   #8
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Are you changing the permissions after they're copied or before? You probably have to do it after since you're read-only...
 
Old 01-13-2006, 09:07 PM   #9
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
I'm changing the permissions once the files are in my home directory
 
Old 01-13-2006, 09:20 PM   #10
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
Upgrade your kernel to 2.6.15 which has expanded save NTFS write capability.
 
Old 01-14-2006, 03:57 PM   #11
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
How are you trying to change the permissions?
Are you a member of the "wheel" group. I'm not sure but maybe you need to be a member to su to root in your system.

Try bringing up a shell, su'ing to root and use the "chown" command.

Code:
cd ~
su
>root_password

chown <username>:<groupname> <file list to change>
If this still doesn't work, give us a long listing of a file you are trying to change, and the error you are getting. Cut an paste so that you get it exact.

Last edited by jschiwal; 01-14-2006 at 03:59 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount iso writable? CoolAJ86 Linux - General 7 10-04-2008 01:12 AM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
Mounting NTFS as writable jon_k Linux - Software 3 05-24-2004 01:14 AM
can't access ntfs mount through nfs mount bezoomny Linux - Networking 9 04-14-2004 10:25 AM
cant mount ntfs on 2.4.24 weeds84 Debian 7 02-24-2004 06:50 PM


All times are GMT -5. The time now is 04:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration