LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Mount ntfs as writable (http://www.linuxquestions.org/questions/ubuntu-63/mount-ntfs-as-writable-403097/)

simeandrews 01-13-2006 06:34 PM

Mount ntfs as writable
 
How can I mount NTFS as writable? What programs do I need to download, etc.

pljvaldez 01-13-2006 06:43 PM

Generally, this is a BAD idea. Write support in linux is not reliable and many people have hosed up their windows partitions this way.

However, the option you're looking for is Captive NTFS. I'm not sure if you have to install anything by default or just mount normally with the defaults,users,rw,umask=000 in the fstab line for the partition

Try this post:http://homes.esat.kuleuven.be/~decoc..._partitions_re

halvy 01-13-2006 06:49 PM

you can (i heard) use symlinks via fat32 for your personal date/desktop stuff.

and/or put linux inside windoze (ie co-linux) which will allow both win and lin to see each other since they are on the same partitian (sorta)... again, i'v only heard rumors about these feats.

good luck.

simeandrews 01-13-2006 06:54 PM

Thanks guys.

I'm not actually going to store anything on the Windows hard drive, but I am having trouble copying and pasting so I can backup My Documents, etc. I realise that I should have said this in the first place, but I didn't, and I am now. So, how can I copy and paste files from my Windows drive (after it is mounted as read only) and set myself as the owner, and make the files writable? I get an error in Konqueror.

pljvaldez 01-13-2006 07:14 PM

What error are you getting?

Unmount the partition and add this to your /etc/fstab (of course changing the /dev and mount point as required):

/dev/hda1 /media/windows ntfs defaults,users,ro,nls=utf8,umask=0222 0 0

Then remount the partition and you should be able to copy the files as a user.

jschiwal 01-13-2006 07:20 PM

If by "copying and pasting", you are referring to the icons in konqueror, this is just a shortcut to copy files. Where are you trying to copy the files to? If you are trying to move files to a linux writable partition, one handy way of doing it is to split the konqueror's window, so that the source directory is on the left and the destination is on the right. Then you can select the files you want to copy over and drop then on the left.

If you are saying that the files you copied are read-only, then you can change the permissions of the file after copying.

An option to consider, is to use the "uid=" option in the /etc/fstab entry. This will make you the owner of the files which will allow you to change the permissions on them after you copy the file to a writable partition. Otherwise, you may have to su to root first.

For example, suppose that your user name is "sandrews", then you may wish to edit the /etc/fstab entry for the ntfs drive to something like this:
Code:

/dev/hda1            /xp                  ntfs      defaults,uid=sandrews      0 0

simeandrews 01-13-2006 07:27 PM

It's wierd, when I copy the files, I type sudo konqueror (I've also used run as...) and try to change the permissions of the folder. But I get a window titled error, and it then says the name of the directory in the window, no description.

pljvaldez 01-13-2006 07:30 PM

Are you changing the permissions after they're copied or before? You probably have to do it after since you're read-only...

simeandrews 01-13-2006 09:07 PM

I'm changing the permissions once the files are in my home directory

KimVette 01-13-2006 09:20 PM

Upgrade your kernel to 2.6.15 which has expanded save NTFS write capability. :)

jschiwal 01-14-2006 03:57 PM

How are you trying to change the permissions?
Are you a member of the "wheel" group. I'm not sure but maybe you need to be a member to su to root in your system.

Try bringing up a shell, su'ing to root and use the "chown" command.

Code:

cd ~
su

>root_password

chown <username>:<groupname> <file list to change>

If this still doesn't work, give us a long listing of a file you are trying to change, and the error you are getting. Cut an paste so that you get it exact.


All times are GMT -5. The time now is 05:17 PM.