LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-05-2013, 02:25 AM   #1
Basti890
LQ Newbie
 
Registered: Mar 2013
Distribution: Ubuntu 12.04 64Bit
Posts: 5

Rep: Reputation: Disabled
Missing libGL.so.1 after changing Graphiccard - Fehlenede libGL.so.1 Bibliothek


-----German (english below) ----
Hi Leute,

ich hab das Problem, dass nach dem Ausbau meiner Nvidia Graka Steam nicht mehr startet, weil Wies der titel schon sagt libGL.so.1 fehlt.

Ich hab schon im Internet gesucht aber nur veraltete Beiträge gefunden(2005) mit lösungen die mir persönlich zu kompliziert für einen einsteiger erscheinen, bzw nicht mehr in den Paketlisten verfügbar sind.
u.A. waren das :
Code:
sebastian@sebastian-HP-Elite-7500-Series-MT:~$ sudo apt-get install xlibmesa-gl
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Paket xlibmesa-gl ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Paket »xlibmesa-gl« hat keinen Installationskandidaten
sebastian@sebastian-HP-Elite-7500-Series-MT:~$ sudo apt-get install xlibmesa-glu
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Paket xlibmesa-glu ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Paket »xlibmesa-glu« hat keinen Installationskandidaten
Wenn ich find | grep libGL.so.1 mache erhalte ich:
Code:
./.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/nvidia-cg-toolkit/examples/Tools/trace/libGL.so.1.gz
./.local/share/Steam/ubuntu12_32/steam-runtime.old/i386/usr/share/doc/nvidia-cg-toolkit/examples/Tools/trace/libGL.so.1.gz
Wo bekomm ich die libGL.so.1 am einfachsten her? ich will nicht dei stabilität meines System gefährten, da ichb auf diesem PC auch meine Programmier-Arbeiten verrichte.

MfG Basti890

EDIT: was ich vergessen hab, ich hab Ubuntu 12.04LTS 64Bit ;D
------ English -------

Under construction Please be patient or use Google Translator :P

Last edited by Basti890; 03-05-2013 at 02:29 AM.
 
Old 03-05-2013, 03:10 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,202

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
Run this command:
Quote:
ls -l /usr/lib64/libGL*
You should see something like
Quote:
lrwxrwxrwx 1 root root 10 Dec 16 12:28 /usr/lib64/libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root 12 Dec 16 12:28 /usr/lib64/libGL.so.1 -> libGL.so.1.2
-rwxr-xr-x 1 root root 547424 Jul 10 2012 /usr/lib64/libGL.so.1.2
-rw-r--r-- 1 root root 657308 Nov 4 2010 /usr/lib64/libGLEW.a
lrwxrwxrwx 1 root root 16 Dec 16 12:27 /usr/lib64/libGLEW.so -> libGLEW.so.1.5.7
lrwxrwxrwx 1 root root 16 Dec 16 12:27 /usr/lib64/libGLEW.so.1.5 -> libGLEW.so.1.5.7
-rw-r--r-- 1 root root 389992 Nov 4 2010 /usr/lib64/libGLEW.so.1.5.7
lrwxrwxrwx 1 root root 11 Dec 16 12:28 /usr/lib64/libGLU.so -> libGLU.so.1
lrwxrwxrwx 1 root root 19 Dec 16 12:28 /usr/lib64/libGLU.so.1 -> libGLU.so.1.3.08004
-rwxr-xr-x 1 root root 447072 Jul 10 2012 /usr/lib64/libGLU.so.1.3.08004
You will notice libGL.so --> libGL.so.1 --> libGL.so.1.2. That's the mesa ones. If you have Nvidia stuff, symlinks will point to libGL.so.<nvidia version number>
 
1 members found this post helpful.
Old 03-05-2013, 03:17 AM   #3
Basti890
LQ Newbie
 
Registered: Mar 2013
Distribution: Ubuntu 12.04 64Bit
Posts: 5

Original Poster
Rep: Reputation: Disabled
Code:
root@sebastian-HP-Elite-7500-Series-MT:~# ls -l /usr/lib64/libGL* 
ls: Zugriff auf /usr/lib64/libGL* nicht möglich: Datei oder Verzeichnis nicht gefunden
:O I just checked it, I even dont have a lib64 directory in /usr
 
Old 03-05-2013, 07:38 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,202

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
I presumed without asking. Most 64 bit distros use /usr/lib for 32 bit and /usr/lib64 for 64bit.
The rest use /usr/lib for 64 bit and /usr/lib32 for 32 bit.

Make that command
Quote:
ls -l /usr/lib/libGL*
 
Old 03-05-2013, 07:54 AM   #5
Basti890
LQ Newbie
 
Registered: Mar 2013
Distribution: Ubuntu 12.04 64Bit
Posts: 5

Original Poster
Rep: Reputation: Disabled
Code:
root@sebastian-HP-Elite-7500-Series-MT:~# ls -l /usr/lib/libGL*
ls: Zugriff auf /usr/lib/libGL* nicht möglich: Datei oder Verzeichnis nicht gefunden
actually it has deletet this lib, after atuocealn or autoremove Iguess, my question is more How can i install those and relatet libs?
 
Old 03-05-2013, 02:45 PM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,202

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
You should mention your distribution. It helps to know.

The simplest way is to reinstall Mesa.
 
Old 03-06-2013, 01:48 AM   #7
Basti890
LQ Newbie
 
Registered: Mar 2013
Distribution: Ubuntu 12.04 64Bit
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
You should mention your distribution. It helps to know.

The simplest way is to reinstall Mesa.
I'm using Ubuntu 12.04.1 LTS 64Bit
with the 3.2.0-38-generic-kernel.

OK and how do i install Mesa?
I just tried http://phoronix.com/forums/showthrea...aphics-Drivers
but steam still doesn't start (I didn't installed an alternel driver yet, cause I don't know which one to use for my Onboard Grafik, via Ivy-Bridge [INTEL])

If u need any additional Informations just tell me.
 
Old 03-06-2013, 08:35 AM   #8
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,202

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
I'm not a debian man at all. There's something called apt-get which installs stuff and does messing for you. It's command line with a man page so read that.

Mesa is probably already installed. If you uninstall it, it may break stuff. What you really want is an upgrade, or a reinstall. man apt-get is your friend.
 
Old 03-12-2013, 07:30 AM   #9
Basti890
LQ Newbie
 
Registered: Mar 2013
Distribution: Ubuntu 12.04 64Bit
Posts: 5

Original Poster
Rep: Reputation: Disabled
Talking [solved] !

I solved the problem by following the instructions here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Pacman cannot satisfy dependencies because of missing libgl Skyer Linux - Newbie 3 12-18-2011 01:15 PM
Cannot compile OpenGL program because libGL.a is missing lasindi Slackware 4 04-12-2009 04:09 PM
libGL.so file missing? Xandor Linux - Software 2 10-25-2005 01:42 AM
Missing libGL.so.1 doctorwebbox Debian 12 04-14-2005 01:00 PM
libGL.so.1(LIBGL) for SuSE 9.1? darkmatter333 Suse/Novell 1 12-17-2004 10:23 PM


All times are GMT -5. The time now is 09:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration