LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-26-2014, 09:24 AM   #1
EigenFunctions
LQ Newbie
 
Registered: Jul 2014
Posts: 8

Rep: Reputation: Disabled
lubuntu/boot-repair "forcepae" option


I have several laptops that run Win/XP and, because of lack of support for XP, I want to add a Ubuntu installation to each. I first created a LiveCD! of lubuntu v13.10 and ran it on a Sony laptop (win7) just to see if I liked Ubuntu - I do (and still do).
My first conversion is an IBM T42 machine, so I tried to install v13.10 - it died with the pae error. So I created an ISO CD with v14.04 and used the forcepae option. It took three (3) tries to get it loaded, but it finally worked. It nicely created a dual boot system with Linux and xp and both worked. Because of the two crashes, there were two rather large partitions of incomplete installations on the HD. I foolishly decided to delete these two partitions and I did. That changes the numbering of the partitions and it would boot only into grub rescue. I was able to find a set of grub rescue commands to get it to boot (either Linux or xp). However, those four (4), somewhat long, commands had to be entered at each boot. So I tried boot-repair. The boot-repair iso disk (2013-05-07 version) DOES NOT support forcepae. So, within Linux, I installed boot-repair and ran it. The laptop will not boot because of the pae issue. Prior to running boot-repair, the info dump is at (paste.ubuntu.com) 7858790, after is at 7859502. Looking though the grub.cfg and grub.lst after running boot-repair, it appears the xp selection is NOT there. Also, I see forcepae in several places. But it will not boot.

Can anyone help?
 
Old 07-27-2014, 02:18 AM   #2
sidzen
Member
 
Registered: Feb 2014
Location: GMT -7
Distribution: Handy | Slacko 5.7
Posts: 30

Rep: Reputation: Disabled
All that is said here regarding the probable source of your forcepae option is that, "it is possible . . ." (that's not enough for me, however).

OP needs a non-PAE kernel 32-bit distro, such as those within the links below:

http://sourceforge.net/projects/anti.../Final/MX-14/n

http://www.bodhilinux.com/downloads_desktop.php

Radeon graphics may necessitate addendum to kernel line in GRUB of "nomodeset."

EDIT: add Salix Openbox to that list

Last edited by sidzen; 07-27-2014 at 09:58 AM. Reason: addendum
 
Old 07-27-2014, 11:28 PM   #3
ondoho
Senior Member
 
Registered: Dec 2013
Distribution: arch linux / crunchbang
Posts: 1,024

Rep: Reputation: 144Reputation: 144
crunchbang also has a non-pae version:
http://crunchbang.org/download => 32bit => older computers (non-pae)
or directly via bittorrent:
http://crunchbang.org/torrents/crunc...86.iso.torrent
 
Old 07-27-2014, 11:58 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,352

Rep: Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042
OP doesn't need anything of the sort - and seems to know what s/he wants.
If forcePAE works, that implies the hardware is PAE capable but doesn't report that fact correctly.

I'm surprised boot-repair installs classic grub rather than grub2 - but I wouldn't avise anyone to use boot-repair. You should be able to get it to boot by highlighting the -generic entry and hitting "e" as the messages indicate to edit. Then go down to the kernel line and add " forcepae" (no quotes). Personally I'd aso remove the "quiet splash" so you can see what's happening.
Once up and running, edit /etc/default/grub and add forcepae to the GRUB_CMDLINE_LINUX, save that and run "sudo update-grub". That should get the XP entry added.
At some pont you need to get grub2 installed, but with luck that will come in by default on the next update.
 
1 members found this post helpful.
Old 07-28-2014, 01:43 AM   #5
sidzen
Member
 
Registered: Feb 2014
Location: GMT -7
Distribution: Handy | Slacko 5.7
Posts: 30

Rep: Reputation: Disabled
@syg00
"OP doesn't need anything of the sort," yet, "you need to get grub2 installed."

I guess nobody knows as much as syg00! I learned something today, thanks!
 
Old 07-28-2014, 04:04 PM   #6
EigenFunctions
LQ Newbie
 
Registered: Jul 2014
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
OP doesn't need anything of the sort - and seems to know what s/he wants.
If forcePAE works, that implies the hardware is PAE capable but doesn't report that fact correctly.

I'm surprised boot-repair installs classic grub rather than grub2 - but I wouldn't avise anyone to use boot-repair. You should be able to get it to boot by highlighting the -generic entry and hitting "e" as the messages indicate to edit. Then go down to the kernel line and add " forcepae" (no quotes). Personally I'd aso remove the "quiet splash" so you can see what's happening.
Once up and running, edit /etc/default/grub and add forcepae to the GRUB_CMDLINE_LINUX, save that and run "sudo update-grub". That should get the XP entry added.
At some pont you need to get grub2 installed, but with luck that will come in by default on the next update.
Thanks so much for the help! I think I'm getting closer to a solution.

I was able to boot-up by hitting "e" as you suggested (I actually found that by experimenting). I agree, I'd like to get Grub 2 (as I did initially). However, the /etc/default/grub file already has what you suggested adding:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="forcepae"

I tried moving the forcepae to the default line, but that didn't help. I tried adding a " -- " before forcepae and that didn't seem to help either (the double dash is required in the "e" method). I tried putting forcepae in both places. By "didn't help", I mean forcepae did not show in the menu.lst file.

Also, XP doesn't show up in the menu.lst file either. I need to have the option of booting either OS.
 
Old 07-28-2014, 04:19 PM   #7
EigenFunctions
LQ Newbie
 
Registered: Jul 2014
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
OP doesn't need anything of the sort - and seems to know what s/he wants.
If forcePAE works, that implies the hardware is PAE capable but doesn't report that fact correctly.

I'm surprised boot-repair installs classic grub rather than grub2 - but I wouldn't avise anyone to use boot-repair. You should be able to get it to boot by highlighting the -generic entry and hitting "e" as the messages indicate to edit. Then go down to the kernel line and add " forcepae" (no quotes). Personally I'd aso remove the "quiet splash" so you can see what's happening.
Once up and running, edit /etc/default/grub and add forcepae to the GRUB_CMDLINE_LINUX, save that and run "sudo update-grub". That should get the XP entry added.
At some pont you need to get grub2 installed, but with luck that will come in by default on the next update.
If not boot-repair, then what is the alternative? I have no bias, I'm looking for whatever works.

Last edited by EigenFunctions; 07-28-2014 at 04:21 PM.
 
Old 07-28-2014, 07:04 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,352

Rep: Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042
Maybe boot-repair only updated the MBR, and all the bits for grub2 are still in place. What does this show
Code:
grub-install -V
Note that there may be a mix of grub/grub2, and I don't know enough of apt/dpkg to be able to tell definitively. Even on a "pure" grub2 system grub-legacy shows up because of the way they handled the change from grub to grub2 using grub-pc.
I would be inclined to get things working (or break it totally) and remove/re-install grub completely - see this for a pretty good overview.

As for boot-repair, there probably isn't a better automated offering. I like the data it gives if you don't proceed - but I would use that info for manual corrections, not allow it to do the updates.

Last edited by syg00; 07-28-2014 at 07:05 PM. Reason: typos
 
1 members found this post helpful.
Old 07-29-2014, 06:02 PM   #9
EigenFunctions
LQ Newbie
 
Registered: Jul 2014
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
Maybe boot-repair only updated the MBR, and all the bits for grub2 are still in place. What does this show
Code:
grub-install -V
Note that there may be a mix of grub/grub2, and I don't know enough of apt/dpkg to be able to tell definitively. Even on a "pure" grub2 system grub-legacy shows up because of the way they handled the change from grub to grub2 using grub-pc.
I would be inclined to get things working (or break it totally) and remove/re-install grub completely - see this for a pretty good overview.

As for boot-repair, there probably isn't a better automated offering. I like the data it gives if you don't proceed - but I would use that info for manual corrections, not allow it to do the updates.
Code:
grub-install -v
results in: "grub-install (GNU GRUB 0.97)"

So it would seem, the legacy grub is installed...

BTW - EigenFunctions is a he not a she...

Last edited by EigenFunctions; 07-29-2014 at 06:47 PM. Reason: Append BTW
 
Old 07-29-2014, 08:05 PM   #10
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,352

Rep: Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042
At least some of legacy grub is installed.
Did you run the grub-update I suggested above ?. It would need to be run after each change to the default file.
You could just update the menu.lst to add the forcepae to each kernel line, to save having to interrupt the boot each time - doesn't fix the XP missing though.

I'd purge grub and re-install it from scratch - see the doco I linked above; go down to "Purging & Reinstalling GRUB 2". Ignore all the references to chroot, and enter the commands in "via terminal commands" using sudo.
Once that's done, check the default file - it should be back to "factory default" - add the forcepae option again, then run the "sudo update-grub" and re-boot.
 
1 members found this post helpful.
Old 08-02-2014, 03:01 PM   #11
EigenFunctions
LQ Newbie
 
Registered: Jul 2014
Posts: 8

Original Poster
Rep: Reputation: Disabled
I tried the Purging & Reinstalling GRUB 2 as suggested but it did not help. The last few lines of the process were:

Quote:
Installing for i386-pc platform.
Installation finished. No error reported.
Saving menu.lst backup in /boot/grub/menu.lst_backup_by_grub2_postinst
Running update-grub Legacy to hook our core.img in it
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-3.13.0-24-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-24-generic
Found initrd image: /boot/initrd.img-3.13.0-24-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Win XP Pro on /dev/sda1
Found Windows NT/2000/XP on /dev/sda5
done
So it looks like it knows about the XP and linux partitions and, at one point, it did have a message about the --forcepae requirement (it asked and I said yes, keep the option). The procedure said, if all is right, run
Code:
sudo upgrade-from-grub-legacy
all is NOT well, so I didn't run it!

Then I rebooted, after the manual edits as usual, I was able to run Linux. Also, when I run
Code:
grub-install -V
I get
Quote:
grub-install (GRUB) 2.02~beta2-9ubuntu1
I looked at the grub.cfg and, except for order, everything looks correct. Do I run
Code:
sudo get-apt install Grub
--or--
Code:
sudo upgrade-from-grub-legacy
or both?

Can you help?

Last edited by EigenFunctions; 08-02-2014 at 06:04 PM. Reason: fix my dumb error!
 
Old 08-02-2014, 03:24 PM   #12
EigenFunctions
LQ Newbie
 
Registered: Jul 2014
Posts: 8

Original Poster
Rep: Reputation: Disabled
Yipee! It now works! It boots up with a menu of boot options. I was able to boot-up in both Linux and XP!

What I forgot to do was the Post-Restore Commands:
Code:
sudo update-grub
sudo grub-probe -t device /boot/grub
sudo grub-install /dev/sda
sudo grub-install --recheck /dev/sda
I now have a system to work with!

It does seem to be slow to boot, should I run:
Code:
sudo upgrade-from-grub-legacy
My next task is to get my networked printer working!

Last edited by EigenFunctions; 08-02-2014 at 03:27 PM. Reason: forgot "upgrade-from-grub-legacy"
 
Old 08-06-2014, 08:18 PM   #13
EigenFunctions
LQ Newbie
 
Registered: Jul 2014
Posts: 8

Original Poster
Rep: Reputation: Disabled
As was requested, I ran
Code:
sudo upgrade-from-grub-legacy
I booted-down and booted-up again and it all seemed to work.

I still have many other issue to fix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 6 03-21-2013 10:35 AM
2.6.9 Kernel boot panic, "append correct root= boot option" jindex Linux - Newbie 6 04-06-2012 04:28 AM
unpredictable "delete" "move to trash" or "cut" file menu option dorianrenato Linux - General 3 11-28-2011 06:41 PM
Stuck on "GRUB_" Screen - Will boot from Live CD "Boot from first hard disk" option Snowman11 Linux - Newbie 10 02-01-2009 06:52 PM
where is the "enter root password or Contrl-D to continue" after FS repair at boot jg167 Red Hat 0 11-17-2004 01:20 AM


All times are GMT -5. The time now is 05:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration