LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Low Screen Resolution w/Feisty & Nvidia Drivers (http://www.linuxquestions.org/questions/ubuntu-63/low-screen-resolution-w-feisty-and-nvidia-drivers-560937/)

dcarrco 06-11-2007 01:59 PM

Low Screen Resolution w/Feisty & Nvidia Drivers
 
i have just installed ubuntu 7.04. i have an nvidia GeForce 6200 w/256MB of ram. i have two princeton VL173 flat panels that i run at 1280x1024 in XP. i have loaded the latest nvidia driver that is available pre-compiled through the add/remove programs interface. the highest resolution i can get is 1024x768 in either twinview or single monitor mode. i have tried expanding my refresh rates in the xorg.conf file, i have tried various settings with nvidia-settings, and i have gone through the X86config script and input the reolutions i want. i have looked through these forums and searched on google. i have made sure that the resolution i want is listed under the DEPTH 24 section in the MONITOR subsection of xorg.conf. it still refuses to allow a choice higher than 1024x768.

heres my xorg.conf. i HAVE already tried adding different refresh rates and adding different meta modes. those dont work and x server wont start if there are other meta modes. this is my working .conf file.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Thu Nov 9 17:56:12 PST 2006

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Princeton Graphics Systems VL173"
HorizSync 31.0 - 60.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "metamodes" "CRT-0: 1024x768 +0+0, CRT-1: 1024x768 +1024+0; CRT-0: 640x480 +0+0, CRT-1: nvidia-auto-select +640+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection




thanks for any help.

buggabill 06-12-2007 01:00 PM

Check out http://us.download.nvidia.com/XFree8...ppendix-g.html to get help on setting the correct settings for this line
Code:

Option "metamodes" "CRT-0: 1024x768 +0+0, CRT-1: 1024x768 +1024+0; CRT-0: 640x480 +0+0, CRT-1: nvidia-auto-select +640+0"
It looks like your metamodes line might not be set up correctly?

dcarrco 06-12-2007 06:30 PM

thanks, ill try anything
 
thanks bill. i will take a look. i played with the meta mode line before, and the X server would no longer start. but, i will take a closer look and read the link, and see if wisdom lies within.

dcarrco 06-13-2007 12:19 PM

well, i tried the install method 2 from http://doc.gwos.org/index.php/Latest_nvidia_feisty which installs the latest nvidia drivers and recompiles the kernel. i tried editing the metamode line and adding 1280x1024,1280x1024 as an option. i have tried everything i can think of and continue to have a max resolution (even though twinview works fine) of 1280x960 (which is not readable on my monitors, fuzzy and washed out). but try as i might, i cannot get to 1280x1024. any other suggestions, anyone?

heres my new metamodes line, as suggested by the link bill gave me:
Option "metamodes" "CRT-0: 1024x768 +0+0, CRT-1: 1024x768 +1024+0; 1280x1024,1280x1024"

and the latest (new install of ubuntu and recompile of downloaded video driver) xorg.conf

Section "Monitor"
Identifier "VL173"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Princeton Graphics Systems VL173"
HorizSync 31.0 - 60.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "VL173"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "metamodes" "CRT-0: 1024x768 +0+0, CRT-1: 1024x768 +1024+0; 1280x1024,1280x1024"
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection


All times are GMT -5. The time now is 06:05 AM.