LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 02-03-2009, 09:33 AM   #1
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6 on my desktop, Ubuntu 12.04 LTS on my server, Ubuntu 12.04 on my netbook and the wife's PC
Posts: 1,200

Rep: Reputation: 96
Lost option to "Open with text editor" executable script in 8.04


With Ubuntu 7.10 and prior I could create a script on my desktop, make it executable and all was well. If I right clicked on the file I was presented an option to "Open with text editor" so I could fix the inevitable errors. With 8.04 I have noticed that the "Open with text editor" option disappears after I make the file executable. I have to "Open with other application" then select Text editor. Quite inefficient.

Can anyone offer a change this behavior in 8.04?

TIA,

Ken
 
Old 02-03-2009, 10:14 AM   #2
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
That's right, but if you click on "Open" you will be prompted with a dialog that let you chose one of "Run in Terminal", "Display", "Cancel" or "Run". If you chose Display the file will be open with the default Text Editor.

If you actually want to add that option again, just select Properties, go to the Open With tab and make a default application different from Text Editor (for example OpenOffice, see screenshot 1). In this way when you right-click the entry "Open with Text Editor" will appear (see screenshot 2) since it is not the default application anymore. But if you click on "Open" and then "Display" the file will be feed into OpenOffice.
Attached Images
File Type: png screenshot1.png (23.5 KB, 7 views)
File Type: png screenshot2.png (14.3 KB, 5 views)
 
Old 02-04-2009, 11:49 AM   #3
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6 on my desktop, Ubuntu 12.04 LTS on my server, Ubuntu 12.04 on my netbook and the wife's PC
Posts: 1,200

Original Poster
Rep: Reputation: 96
Thanks colucix. Open then Display is probably a good enough method. Most curious how making the file executable changes the Open with text editor behavior. Must be an improvement :-)

Ken
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 6 03-21-2013 11:35 AM
Installed jEdit, only get "Starting Programmer's Text Editor" Nathan1993 Ubuntu 6 03-29-2006 01:02 AM
"ftp: u: unknown option" when script runs through VNC viewer Fillys6 Linux - Networking 7 12-22-2005 08:11 PM
Konqueror's "text view" option makes text green. newtwolinux Suse/Novell 2 08-26-2005 07:45 AM
Compiling KDE 3.2.0 - "Can't open perl script "/dcopidlng/kalyptus" linuxgamer09483 Linux - Software 3 04-09-2004 09:25 PM


All times are GMT -5. The time now is 06:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration