LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Login screen doesn't show up (http://www.linuxquestions.org/questions/ubuntu-63/login-screen-doesnt-show-up-729393/)

ANO1453 05-29-2009 03:32 PM

Login screen doesn't show up
 
I just updated my 8.4.2 kubuntu to the newest version through a command-line session ("apt-get dist-upgrade")

When I rebooted, all went fine, but instead of a login screen I found a 'disrupted' screen (I mean, no images, only some random coloured pixels).

I tried to lower the reolution through the vesa=788 command, but the outcome was the same.

Is it a graphics driver problem? I used my ATI Mobility Radeon HD2600 on the other system with no problems. Do I need to install drivers? If so, how?


Help appreciated
P.S.: LG E500-VAP36P laptop.

hasienda 05-30-2009 08:33 AM

Starting point
 
Quote:

Originally Posted by ANO1453 (Post 3556957)
I just updated my 8.4.2 kubuntu to the newest version through a command-line session ("apt-get dist-upgrade")

When I rebooted, all went fine, but instead of a login screen I found a 'disrupted' screen (I mean, no images, only some random coloured pixels).

I tried to lower the reolution through the vesa=788 command, but the outcome was the same.

The vesa kernel option is exclusively for the (boot) terminal. But, you're looking for a X-Session login prompt, well?
Quote:

Originally Posted by ANO1453 (Post 3556957)
Is it a graphics driver problem? I used my ATI Mobility Radeon HD2600 on the other system with no problems. Do I need to install drivers? If so, how?

Don't know, if you have issues with the driver module for your graphics card. Your Ubuntu uses Xorg as Xserver, right? At first you could change your driver by editing /etc/X11/xorg.conf like this:
Code:

Section "Device"
 Identifier "ATI Mobility Radeon HD260"                # your alias
 Driver "radeonhd"

to make it look like
Code:

Section "Device"
 Identifier "ATI Mobility Radeon HD260"                # your alias
 Driver "vesa"

and make sure, you have installed xserver-xorg-video-vesa . You get at least a working X again.

Check, if the "radeon" driver is working then. I see xserver-xorg-video-radeon but no xserver-xorg-video-radeonhd package here inside my Debian repository list. You may have on in Ubuntu. If you used ATI's proprietary Catalyst/fglrx, atisetup may help. Otherwise you could try dpkg-reconfigure xserver-xorg to start from a new, clean xorg.conf . I found corresponding information at https://help.ubuntu.com/community/RadeonHD , that my help you to go further on. Use http://de.forestle.org/search.php?q=radeonhd+ubuntu to see even more.

ANO1453 05-30-2009 10:19 AM

This is how my xorg.conf looked like:
Quote:

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
I've followed the instructions on that link you provided but no luck. I'm going to try to repeat it, but this time purging the old drivers, if any.

xorg.conf is supposed to be that way?

hasienda 05-30-2009 06:16 PM

Quote:

Originally Posted by ANO1453 (Post 3557513)
This is how my xorg.conf looked like:
[snip]
I've followed the instructions on that link you provided but no luck. I'm going to try to repeat it, but this time purging the old drivers, if any.

xorg.conf is supposed to be that way?

Well, yes, at least for Debian/Ubuntu & Co.
Your xorg.conf is quite minimalistic. You might try something from my configuration, even if I run a quite old ATI card compared to you:
Code:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    # for compiz
    Option          "AIGLX" "on"
EndSection

Section "Files"

        # path to defoma fonts
#    FontPath        "/usr/share/fonts/X11/cyrillic"
#    FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load          "bitmap"
    Load          "dbe"
    Load          "ddc"
    Load          "extmod"
    Load          "freetype"
    Load          "glx"
    Load          "int10"
    Load          "record"
    Load          "v4l"
    Load          "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "de"
    Option        "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/psaux"
    Option        "Protocol" "ImPS/2"
EndSection

Section "Monitor"
    Identifier    "Belinea 101751"
    HorizSync      30.0 - 84.0
    VertRefresh    56.0 - 75.0
    Option        "DPMS"
EndSection

Section "Device"
 Identifier "X800 XL"                # your alias
 Driver "radeon"
 Option "AccelMethod" "XAA"
 # XAA/EXA
 Option "AccelDFS"    "1"
 # 1/0 On for PCIE, off for AGP
 # Manpage: Use  or  don't  use accelerated EXA DownloadFromScreen hook
 # when possible.
 Option "AGPMode" "1"
 # 1-8 Does not affect PCIE models.
 Option "AGPFastWrite" "1"
 # 1/0 Does not affect PCIE models. Not recommended.
 Option "GARTSize" "64"
 # 0-64 Megabytes of gart (system) memory used.
 # Wrongly defaults to 8MB sometimes, see your logfile.
 # Bigger seems better.
 Option "EnablePageFlip" "1"
 # 1/0 Increases 3D performance substantially
 # seemingly in XAA mode only
 Option "ColorTiling" "1"
 # 1/0 Increases 3D performance substantially
 # affected stability only positively on my system
EndSection

#Section "Device"
##    Driver          "nv"
##    Driver          "vesa"
#    # for compiz
#    # from http://www.debianadmin.com/how-to-install-compiz-in-debian.html
#    Option          "AllowGLXWithComposite" "True"
#    Option          "RenderAccel" "True"
##    Option          "backingstore" "True"
#    Option          "TripleBuffer" "True"
#    # one more according to Debian README
#    Option          "XAANoOffscreenPixmaps" "True"
#    Identifier    "nVidia Corporation G70 [GeForce 7600 GT]"
#    Driver        "nvidia"
#EndSection

Section "Screen"
    Identifier    "Default Screen"
#    Device        "nVidia Corporation G70 [GeForce 7600 GT]"
    Device        "X800 XL"
    Monitor        "Belinea 101751"
    DefaultDepth    24
    # for Nvidia
#    Option        "NvAGP" "1"
    # for compiz
#    Option          "XAANoOffscreenPixmaps"
#    Option          "AddARGBGLXVisuals" "True"
    SubSection    "Display"
        Depth      1
        Modes      "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      4
        Modes      "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      8
        Modes      "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      15
        Modes      "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      16
        Modes      "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      24
        Modes      "1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option          "Composite" "Enable"
EndSection

Section "DRI"
        Group      "video"
        Mode        0660
EndSection

As you'll see, there are some parts left from a Nvidia card used before. So don't get confused by the comments.

ANO1453 05-31-2009 04:33 AM

Well, I've repeated the whole process of the radeonhd drivers install and, when I inserted the command startx I got a blue background screen and two notes (from the Knotes app). The keyboard and the mouse didn't work.

I rebooted, thinking that if I got a display, even that minimal, then X should be up again.
I tried to sudo apt-get dist-upgrade again. As the computer wasn´t working, that should be because some essential packages were missing.

There was a dependencies problem with kdebase-data and kdebase-runtime-data. It say that there are unmet dependencies that are not installable.
It seems a dependecies issue...


All times are GMT -5. The time now is 07:22 PM.