LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-17-2005, 02:55 PM   #1
ploosh
Member
 
Registered: Feb 2005
Location: Santa Monica, CA, USA
Distribution: Ubuntu 5.04
Posts: 35

Rep: Reputation: 15
Lilo with Ubuntu, dual boot with Mandrake


First, I apologize for a lilo question. I'm not finding answers in the other threads I've searched which makes me wonder if it's an Ubuntu issue. Perhaps you can help.

I just installed Ubuntu (Hoary install) on an existing dual-boot system. I installed it over the previous WinXP partition. Ubuntu wanted to use Grub as the bootloader, but it failed on the install. It did however present me with Lilo which was already listed because I had been dual-booting with WinXP/Mandrake.

Now the newb problem.
Ubuntu loads fine (love it), but I'm not presented with a menu to choose to boot into Mandrake, which I had hoped for. I checked the partitions to see how things were listed and it looks like:
Code:
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031  27862.734  primary   ext3        boot
2      27862.734  38154.375  extended              lba
5      27862.765  37636.655  logical   ext3
6      37636.686  38154.375  logical
I then brought up the lilo.conf file and edited it to be (not listing the comments):
Code:
boot=/dev/hda
root=/dev/hda1
install=menu
map=/boot/map
delay=40
vga=normal
default=Linux
image=/vmlinuz
	label=Linux
	read-only
	initrd=/initrd.img
image=/vmlinuz.old
	label=LinuxOLD
	read-only
	optional
	initrd=/initrd.img.old
other=/dev/hda5
	label="Mandrake 10.1"
When I then /sbin/lilo I receive a message:
Code:
Warning: LBA32 addressing assumed
Reading boot sector from /dev/hda
Warning: Kernel & BIOS return differing head/sector geometries for device 0x80
    Kernel: 65535 cylinders, 16 heads, 63 sectors
      BIOS: 1024 cylinders, 255 heads, 63 sectors
Warning: '/proc/partitions' does not match '/dev' directory structure.
    Name change: '/dev/dm-0' -> '/dev/evms/hda1'
    Name change: '/dev/dm-1' -> '/dev/evms/hda5'
    Name change: '/dev/dm-2' -> '/dev/evms/hda6'
Using MENU secondary loader
Calling map_insert_data

Boot image: /vmlinuz -> boot/vmlinuz-2.6.10-4-386
Mapping RAM disk /initrd.img -> boot/initrd.img-2.6.10-4-386
Added Linux *

Skipping /vmlinuz.old
Boot other: /dev/hda5, loader CHAIN
Fatal: First sector of /dev/hda5 doesn't have a valid boot signature
Now there are a bunch of useful Ubuntu comments in the lilo.conf file, but I don't think they'd be causing a problem (although I haven't tested that yet). Any idea of what I am missing or doing incorrectly?
 
Old 03-17-2005, 04:44 PM   #2
ploosh
Member
 
Registered: Feb 2005
Location: Santa Monica, CA, USA
Distribution: Ubuntu 5.04
Posts: 35

Original Poster
Rep: Reputation: 15
still thinking....

While it may not be the best solution, I wonder if trying to set Grub as the bootloader is a better option?
 
Old 03-17-2005, 06:34 PM   #3
ploosh
Member
 
Registered: Feb 2005
Location: Santa Monica, CA, USA
Distribution: Ubuntu 5.04
Posts: 35

Original Poster
Rep: Reputation: 15
Tried to set up Grub:
Code:
grub> root (hd0,0)
 Filesystem type unknown, partition type 0x7
Not sure why the filesystem is unknown.?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Booting Ubuntu With Lilo And Mandriva viajante Ubuntu 8 11-06-2005 02:39 PM
LILO Problems With Mandrake 8.1 and Win2K Dual Boot glenn_roth Linux - General 6 03-18-2005 12:47 AM
Lilo freeze on WindozeME/Mandrake 9 dual boot... vince v Linux - General 9 08-27-2004 03:11 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 05:00 PM
LILO problems: Mandrake XP dual-boot with SCSI/IDE venky Linux - General 1 03-30-2003 07:30 AM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration