LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-07-2006, 02:46 AM   #1
DigitalBlue
LQ Newbie
 
Registered: Sep 2005
Location: illinois
Distribution: GoblinX, Mepis, Elive
Posts: 6

Rep: Reputation: 0
Kubuntu Wpa wifi issue


Hey everyone i have Kubuntu 6.06 installed an its worked fine...untill now. i have a home wireless network setup using WPA encryption. On Kubuntu ive had to install knetworkmanager to get the Wpa setup since wlan assistant doesnt do it. I got it to work besides the annyoing prompt to enter my root user pass at each startup. Then all of a sudden it stopped working . i mean my wireless usb dongle is still connected through ndiswrapper and i can still see all the available networks but when i try to connect to to my network with WPA encryption knetworkmanager just hangs and then quits, it stops at 28%. I can still connect when i take the encryption off but who wants to have an open connection when you live in a big city like Chicago. Oh and i would have used Wep but my windows partition that my father uses wont connect to my airport extreme. if its not one thing its the other. I know the Community has to know something. thanks in Advance.
 
Old 07-07-2006, 06:56 PM   #2
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
Maybe wpa-supplicant is not running. I am using WPA with kubuntu and knetwork manager. Try this in a terminal:
Code:
ps -ef | grep wpa
I get:
Code:
root      5179     1  0 Jul07 ?        00:00:00 /sbin/wpa_supplicant -dd -g /var/run/wpa_supplicant-global
bernie   10170  9595  0 00:52 pts/1    00:00:00 grep wpa
I have a love-hate relationship with knetworkmanager. It almost works really well.
 
Old 07-08-2006, 01:52 AM   #3
ErrorBound
Member
 
Registered: Apr 2006
Posts: 280

Rep: Reputation: 31
My wireless didn't work either until I edited manually the config file. Go to /etc/network/interfaces, and edit it to have an entry that looks something like:
Code:
auto wlan0
iface wlan0 inet dhcp
wireless-essid yourNetworkIdHere
wireless-key yourWirelessKeyHere
 
Old 07-08-2006, 02:13 AM   #4
DigitalBlue
LQ Newbie
 
Registered: Sep 2005
Location: illinois
Distribution: GoblinX, Mepis, Elive
Posts: 6

Original Poster
Rep: Reputation: 0
Cool Thanks Everyone

Thank you very much for the input i got it to work again and its continuing to work. The community is what makes linux special. It sets it apart from the big giant closed source OSs . I will continue to use Linux As long as there is a community of individuals like your selves. thanks.
 
Old 07-08-2006, 04:37 AM   #5
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
I'm very glad you got it going.
Praise is good but solutions are also good. There are others also trying to understand this stuff - including me.
So what did you do to fix it?
 
Old 07-08-2006, 12:35 PM   #6
DigitalBlue
LQ Newbie
 
Registered: Sep 2005
Location: illinois
Distribution: GoblinX, Mepis, Elive
Posts: 6

Original Poster
Rep: Reputation: 0
I simply just edited the conf file like error bound said and it works i mean i still have to enter the pass at the prompt after login but thats one step better !
 
Old 07-08-2006, 01:55 PM   #7
ErrorBound
Member
 
Registered: Apr 2006
Posts: 280

Rep: Reputation: 31
Quote:
Originally Posted by DigitalBlue
i still have to enter the pass at the prompt after login but thats one step better !
You have to enter a password to use the wireless? You shouldn't have to...can you describe this?
 
Old 07-08-2006, 04:00 PM   #8
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
This is about networkmanager - a daemon that does an excellent job of maintaining a network connection. If you plug in a cable, it uses that adaptor, if there's no wired network but it finds a known wireless network it uses that. So you can roam about between different wired and wireless networks and it will keep you connected.

Unfortunately it insists on treating wireless keys (WPA at least, probably WEP too) as state secrets, so it likes to put them in a 'wallet'. So it asks for the password for the wallet before it uses the key (at startup), which I think is a bit daft, as you've already logged in. Ubuntu in general has always seemed a bit password happy to me, with all that sudoing.

And if you're too slow with providing the password it gives up on that wireless network and it's a bugger to get it to connect to it after that.

Anyway, any advice on configuring this daemon is appreciated, as it seems very windowsish (not configurable) to me. I've read that you can set up a particular wallet with no password, but haven't worked out to do this.
 
Old 07-08-2006, 06:08 PM   #9
ErrorBound
Member
 
Registered: Apr 2006
Posts: 280

Rep: Reputation: 31
Well you can remove networkmanager if you don't like the password prompts. I use kwifimanager in order to have a taskbar icon to keep an eye on the signal strength, and modified my interfaces file as above, and the wireless works fine, without any password-entering.
 
Old 07-08-2006, 06:11 PM   #10
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
But then you've got to mess about with wpa_supplicant if you want WPA, right?
Does kwifimanager sort out WPA for you?
 
Old 07-09-2006, 01:25 AM   #11
jon23d
Member
 
Registered: May 2006
Location: Kennewick, WA - USA
Distribution: Ubuntu
Posts: 129

Rep: Reputation: 15
On a side note, after having used Fedora, Suse, and Slackware before sticking with Ubuntu (for the time being...) I must say that I rather enjoy the default setup with sudo. I appreciate that I don't have to su or su -c all the time now. It makes life easier and I like not having to use my su password all the time. However, I did enable the root account for the rare occasion...
 
Old 01-18-2007, 04:26 PM   #12
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Rep: Reputation: 15
Quote:
Originally Posted by bernied
This is about networkmanager - a daemon that does an excellent job of maintaining a network connection. If you plug in a cable, it uses that adaptor, if there's no wired network but it finds a known wireless network it uses that. So you can roam about between different wired and wireless networks and it will keep you connected.

Unfortunately it insists on treating wireless keys (WPA at least, probably WEP too) as state secrets, so it likes to put them in a 'wallet'. So it asks for the password for the wallet before it uses the key (at startup), which I think is a bit daft, as you've already logged in. Ubuntu in general has always seemed a bit password happy to me, with all that sudoing.

And if you're too slow with providing the password it gives up on that wireless network and it's a bugger to get it to connect to it after that.

Anyway, any advice on configuring this daemon is appreciated, as it seems very windowsish (not configurable) to me. I've read that you can set up a particular wallet with no password, but haven't worked out to do this.

Anyone found a solution yet?

I have several users besides me on the computer and if on occasion they are not fast enough to write in the password for Kwallet, it creates a problem for them to do it manually.

Any solutions?

Network manager in gnome does not need to use kwallet like software.
 
Old 04-14-2007, 07:14 PM   #13
burninGpi
Member
 
Registered: Mar 2006
Location: Fort McMurray, Canada
Distribution: Gentoo ~amd64
Posts: 163

Rep: Reputation: 30
Quote:
Originally Posted by robertpolson
Network manager in gnome does not need to use kwallet like software.
Really? It wanted my to create a keychain, and asked me for my keychain passwd every time I logged in.

It is possible to create a wallet w/o a passwd, which is convenient if you aren't paranoid about security, but it isn't very secure.

I think it's a bug in KNM, because it should ask for the PSK before associating with the network.
 
Old 04-14-2007, 07:59 PM   #14
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
I gave up on knetworkmanager and just use wpa_supplicant. So wireless comes up during boot, not after you login to kde. The best bit about this is that any shared drives on the network are already mounted by the time my desktop comes up.

The worst bit is that if I want to use it on another wireless network I have to mess about with the config files - and I always forget which ones I need to mess with and need to use the interweb to find out, but I can't because ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Aironet350 wifi do WEP/WPA? ssalman Linux - Wireless Networking 10 09-11-2007 01:09 AM
Wifi and WPA mirto Debian 10 06-22-2006 03:15 PM
Agere / Lucent wifi card under kubuntu Turok Linux - Wireless Networking 2 12-15-2005 02:14 AM
Kubuntu install dwl-650+ wifi card issue esteeven Ubuntu 6 11-27-2005 02:45 PM
Which distro does have out-of-box support for wifi + WPA? hyapadi Linux - Wireless Networking 6 10-04-2005 09:17 AM


All times are GMT -5. The time now is 05:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration