LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-03-2010, 11:28 AM   #1
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,044

Rep: Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100
Kubuntu second logout bug


Kubuntu 10.04 hangs (display dead, even caps lock button not affecting caps lock light) on the second logout.

With several Google searches I found several different consistent descriptions of this bug with various bug numbers assigned. But none had any meaningful looking discussion much less resolution.

Also, most (maybe all) are for previous versions of Kubuntu. But the symptom I see is very clearly that same bug.

The page with closest to meaningful discussion is:

https://bugs.launchpad.net/ubuntu/+s...me/+bug/446316

How do I find out more current status of that bug and/or work arounds?

Does it really affect so few people? Or do so few people use Kubuntu multi user on a local display and log out twice without rebooting?

Edit: I found the workaround myself. But I'd still like to know the status of the bug.

I edited /etc/kde4/kdm/kdmrc and in the section
Code:
[X-:*-Core]
I added the line
Code:
TerminateServer=true

Last edited by johnsfine; 07-03-2010 at 02:54 PM.
 
Old 07-04-2010, 03:38 PM   #2
jtarin
Member
 
Registered: May 2010
Location: Vladivostok, Russia
Distribution: Slackware 13.0, Linux Mint 17.0
Posts: 97

Rep: Reputation: 22
No I've noticed this same behavior, but only as of late. I put it off to some software install because it didn't initially act as such. I'll try your fix and see what happens.I don't have a multi-user environment.

Last edited by jtarin; 07-04-2010 at 03:42 PM.
 
Old 07-04-2010, 03:52 PM   #3
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,044

Original Poster
Rep: Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100
Quote:
Originally Posted by jtarin View Post
No I've noticed this same behavior, but only as of late. I put it off to some software install because it didn't initially act as such.
I have only been using Kubuntu a short time (and only on an old computer I'm using more for experimenting with distributions than for real use). This bug was there from the very first time I logged out a second time without rebooting. I hadn't done any software install beyond Kubuntu 10.04 itself.
 
Old 07-05-2010, 04:46 AM   #4
jtarin
Member
 
Registered: May 2010
Location: Vladivostok, Russia
Distribution: Slackware 13.0, Linux Mint 17.0
Posts: 97

Rep: Reputation: 22
I only say software install associated because that is the first opportunity that I needed to logout in such a manner that it was noticed. Your fix seems to have worked thanks...I was having to to do a hard reboot.
 
Old 07-14-2010, 08:35 PM   #5
jarjieau
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Thanks for the workaround

Thanks for the workaround, johnsfine. I was having the same problem, and had to do a hard boot as well.

Last edited by jarjieau; 07-14-2010 at 08:36 PM. Reason: added name
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] kde4.2 logout bug tux_dude Slackware 2 01-31-2009 08:12 PM
USB Subsystem or Kernel Bug - Only in Kubuntu? Azizcoos Linux - Hardware 1 09-18-2008 07:49 AM
LXer: 2008 CES: Bug Labs Introduces BUG, BUGbase. So Cool! LXer Syndicated Linux News 0 01-09-2008 01:21 AM
2038 bug-Is Debian Bug-Proof? deepclutch Debian 1 08-02-2007 10:59 AM
Kubuntu 5.10 (KDE question mainly - DCOP bug?) ucffool Ubuntu 0 10-09-2005 09:00 AM


All times are GMT -5. The time now is 09:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration