LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 02-17-2006, 01:23 AM   #1
Bondspy007
LQ Newbie
 
Registered: Sep 2005
Posts: 14

Rep: Reputation: 0
Kubuntu not going to KDE desktop?


So I downloaded and burned the ISO for the live version of Kubuntu onto a disc, I boot it up and it goes through all the loading and then it give me a commang line. I don't know much about linux command lines but I need to know how to get to the KDE desktop. Any suggestions? Thanks
 
Old 02-17-2006, 01:38 AM   #2
pyrosim
Member
 
Registered: Jul 2005
Location: Las Cruces, NM
Distribution: Fedora
Posts: 49

Rep: Reputation: 15
try "xinit", then if it opens a sort of graphical console, type "startkde". Other things to try would be "startx" "X" (case sensitive) "gdm" "xdm" and "kdm".
 
Old 02-17-2006, 01:57 AM   #3
Bondspy007
LQ Newbie
 
Registered: Sep 2005
Posts: 14

Original Poster
Rep: Reputation: 0
thanks but when I typed xinit, it gave some critical error and when i did startkde it said done and then went back to the command line and nothing else worked
 
Old 02-17-2006, 10:53 AM   #4
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
I would try this:
Code:
startx
If that doesn't work, try
Code:
sudo /etc/init.d/kdm restart
If that doesn't work, try:
Code:
sudo dpkg-reconfigure xserver-xorg
If that doesn't work, try
Code:
sudo apt-get update
sudo apt-get install kubuntu-desktop
 
Old 02-17-2006, 11:47 AM   #5
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
You may also want to be looking into the file /var/log/Xorg.0.log to see where it is failing to start. You may want to copy this file to a floppy along with the /etc/X11/xorg.conf file then post them here so we can see them. You most likely will have to split the log file into a couple of posts it is fairly big. Ah to actually copy the files try something like this since I see you say you have very little command line experience.

Code:
sudo mount -t vfat /dev/fd0 /media/floppy
cp /var/log/Xorg.0.log /media/floppy/
cp /etc/X11/xorg.conf /media/floppy/
sudo umount /media/floppy
 
Old 02-19-2006, 09:51 PM   #6
kservik
LQ Newbie
 
Registered: Feb 2006
Location: Oslo, Norway
Distribution: Ubuntu 5.10
Posts: 4

Rep: Reputation: 0
I have the same issue. Totally new to Linux and that command line almost made me drop the whole project as I could not find much information to get to a graphical enviroment.

I think I have gotten so far as to installing kubuntu-desktop. I did as "pyrosim" suggested and typed xinit and that worked.

- "startkde", "xdm", "kde" all gave "command not found".
- "gdm" gave "Only root wants to run gdm".
- "startx" gave:

Code:
xauth: creating new authority file /home/charlotte/.serverauth.28046
xauth: creating new authority file /home/charlotte/.Xautority

X: user not authorized to run X server, aborting.
What do I need to do to get a graphical user interface? Should I install another Linux distribution where this is easier?
 
Old 02-19-2006, 10:05 PM   #7
kservik
LQ Newbie
 
Registered: Feb 2006
Location: Oslo, Norway
Distribution: Ubuntu 5.10
Posts: 4

Rep: Reputation: 0
After reading a bit more here,it seems to me that I should have gone for the Kubuntu package?

I was a userfriendly enviroment and not a Linux/Unix command prompt.
 
Old 02-19-2006, 11:54 PM   #8
Bondspy007
LQ Newbie
 
Registered: Sep 2005
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by aysiu
I would try this:
Code:
startx
If that doesn't work, try
Code:
sudo /etc/init.d/kdm restart
If that doesn't work, try:
Code:
sudo dpkg-reconfigure xserver-xorg
If that doesn't work, try
Code:
sudo apt-get update
sudo apt-get install kubuntu-desktop
I tried all those and still nothing
 
Old 02-20-2006, 02:45 PM   #9
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
Quote:
Originally Posted by kservik
I wa[nt
a userfriendly enviroment and not a Linux/Unix command prompt.
Then installing Ubuntu or Kubuntu isn't going to work out, I'm afraid.

Try Mepis, PCLinuxOS, or Linspire.
 
Old 02-21-2006, 09:35 PM   #10
Bondspy007
LQ Newbie
 
Registered: Sep 2005
Posts: 14

Original Poster
Rep: Reputation: 0
I figured I would try Ubuntu to see if I would get a different result and it says that it could not start the graphical user interface and to configure some x thing. When I try to do that it just freezes and i can't do anything
 
Old 02-22-2006, 02:37 AM   #11
kservik
LQ Newbie
 
Registered: Feb 2006
Location: Oslo, Norway
Distribution: Ubuntu 5.10
Posts: 4

Rep: Reputation: 0
I got it working atleast :-)

Boots nicely into the GUI every time now.
 
Old 02-26-2006, 11:42 AM   #12
geesh
Member
 
Registered: Feb 2004
Posts: 47

Rep: Reputation: 15
How did you get it working? Might help me or another
 
Old 03-06-2006, 10:05 PM   #13
Jasman
LQ Newbie
 
Registered: Jan 2005
Posts: 4

Rep: Reputation: 0
Stepping in on this thread. Anyone know why Ubuntu (not Kubuntu, but same difference for this matter) might go to command prompt at boot, but I can log in using su or sudo gdm? I've tried reinstalling and reconfiguring the xserver and reediting the command to use gdm as my primary desktop. I can get into it fine, just not automatically on boot. Any ideas? Should I try reinstalling Ubuntu desktop? Thanks.
 
Old 03-06-2006, 10:39 PM   #14
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
Instead of typing
Code:
startx
try typing
Code:
sudo /etc/init.d/gdm restart
 
Old 03-07-2006, 05:39 AM   #15
Jasman
LQ Newbie
 
Registered: Jan 2005
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by aysiu
Instead of typing
Code:
startx
try typing
Code:
sudo /etc/init.d/gdm restart
If this was a repsonse to my post, it doesn't seem to tell me anything. I've been typing sudo gdm to get into my Gnome desktop. The question is why is Ubuntu booting to a prompt, but then going into gdm with no problem when I invoke gdm at the prompt. Why isn't it just going into gdm?

I should note that for some reason, gdm wasn't initially installed (this is a build of Dapper, and I guess that was a bug). But it installed fine using apt (synaptic).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE on Ubuntu vs. Kubuntu Rory in Toronto Ubuntu 27 06-06-2008 03:07 PM
kubuntu KDE rubella Linux - Newbie 2 11-12-2005 05:55 PM
Can't find NVIDIA-Settings.desktop in Kubuntu 5.4 TitaniumTaz Ubuntu 1 08-08-2005 10:55 AM
kubuntu-desktop on Ubuntu (Hoary Hedgehog) WarpFactor Ubuntu 2 07-10-2005 09:22 AM
Updating KDE in Kubuntu Synthetic47 Linux - Newbie 3 06-24-2005 01:25 AM


All times are GMT -5. The time now is 06:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration