LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 12-25-2008, 06:40 PM   #1
cucolin@
Member
 
Registered: Nov 2003
Location: USA
Distribution: Ubuntu, Fedora
Posts: 415

Rep: Reputation: 31
Kernel panic-not syncing:No init found. Try passing init=option to kernel


the other day i just came back to turn on my pc and i got the error message above while booting the machine. I noticed a few days ago the system was freezing and i had to manually restart it. i tried using a knoppix CD to boot from memory which makes me think is a memory problem. i also tried this: http://ubuntuforums.org/showthread.php?t=135920 with no luck.

i'm trying to reinstall everything and i also get the same error message while trying to install ubuntu from the CD.
thanks
 
Old 12-25-2008, 07:32 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
If the disk has nothing important on it you might try shredding it.
Code:
shred /dev/sda
Shred takes about 24 hours on a 320 GB disk. The first pass is the longest because it is generating random numbers for each location on the disk. It usually takes about 12 hours. The last 24 passes in total take about as long as the first pass by itself. That is because shred is writing one value on each pass to all of the locations on the disk.

Your problem does have the earmarks of a hardware problem but sometimes these things are resolved easier than you might expect. Many times I've mistaken a very small "software" problem such as the wrong value in the MBR as a hardware problem. That is usually because the utilities to manage hardware devices make the same mistake.

Last edited by stress_junkie; 12-25-2008 at 07:38 PM.
 
Old 12-25-2008, 09:26 PM   #3
cucolin@
Member
 
Registered: Nov 2003
Location: USA
Distribution: Ubuntu, Fedora
Posts: 415

Original Poster
Rep: Reputation: 31
thanks, but how can i do this if i'm not able to get a terminal? i just turn on the machine and is idle at:
Starting up......
i don't see a way to follow your steps....thanks again...
 
Old 12-25-2008, 09:32 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Since you can't boot up with a live distro, it sounds like a hardware problem.

Do you not get to the post screen? Try unplugging external usb drives and SD disks. It may also be time to open up the case and clean out the dust bunnies. Be sure to clean out dust from the power supply. While there, make sure all of your IDE/SATA cables are snug.

Then if you get a post screen, enter the bios. Is the time OK? Are the drives detected?
 
Old 12-25-2008, 10:03 PM   #5
cucolin@
Member
 
Registered: Nov 2003
Location: USA
Distribution: Ubuntu, Fedora
Posts: 415

Original Poster
Rep: Reputation: 31
1. yes, i get the post screen.
2. there are NO external usb drives and SD disks.
3. there was some dust bunnies, but nothing in excess.
4. power supply dust - not much.
5. IDE/SATA cables- everything was in place.
6. Time was wrong, i fixed it and still same issue.
7. I decided to change the memory for another pair and IT BOOTED!

It works now.

thanks....jschiwal & stress_junkie!
 
Old 12-26-2008, 06:44 AM   #6
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
cucolin@, I'm glad that you had a spare set of memory to use for testing. If you had to purchase a memory set just to see if that was the problem then you might have spent a long time looking for a no-cost solution first.

jschiwal, I love your signature. I have a zero beer limit. It doesn't take much alcohol to saturate my walnut sized brain.

Last edited by stress_junkie; 12-26-2008 at 06:46 AM.
 
  


Reply

Tags
found, init, kernel, panic


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic - not syncing: No init found. Try passing init= option to kernel. john_schimandle Linux - Embedded & Single-board computer 3 10-10-2008 09:09 AM
Kernel panic - not syncing: No init found. Try passing init= option to kernel. john_schimandle Linux - Newbie 4 10-09-2008 02:40 AM
Kernel panic - not syncing: No init found. Try passing init= option to kernel ranjithmrk Linux - Newbie 4 08-22-2008 02:33 PM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 10:18 PM


All times are GMT -5. The time now is 07:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration