LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 09-08-2012, 11:34 AM   #1
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 12.04 64-bit
Posts: 230

Rep: Reputation: 30
Kernel Panic - not syncing: No init found


I'm using Ubuntu 12.04. The update manager asked for updates and I clicked. After a successful update, I had to restart the machine. On restarting now I get this :

Code:
[1.333062] Kernel Panic - not syncing: No init found. Try passing init=option to kernal. See Linux Documentation/init.txt for guidance.
[1.333106] Pid: 1, comm: swapper/0 Not tainted 3.2.0-30-generic #48-Ubuntu
[1.333141] Call Trace:
[1.333177] [<ffffffff816418a7>] panic+0x91/0x1a4
[1.333213] [<ffffffff8163e2f6>] init_post+0xc5/0xc5
[1.333249] [<ffffffff81cfbd74>] kernel_init+0x164/0x164
[1.333284] [<ffffffff81664b74>] kernel_thread_helper+0x4/0x10
[1.333319] [<ffffffff81cfbc10>] ? start_kernel +0x3bd/0x3bd
[1.333354] [<ffffffff81664b70>] ? gs_change+0x13/0x13
Is there a way to fix this ? Similar errors show in recovery console so can't TTY from there.
[My machine has 2 SATA hard-drives, the 2nd one also has Ubuntu 12.04 which I can boot from]
 
Old 09-08-2012, 12:17 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,153

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
The error that caused the problem is listed somewhere before the part you posted, where the kernel tells you that it's missing the drive that contains your root file system. (The drive is usually identified by a UUID=.... line in /etc/fstab, so you may have some error there.)

Since you can boot from your second drive it should be fairly easy for you to mount the root partition of the first drive and correct the problem.

You could just try running grub-mkconfig on the second drive. That should give you a grub.cfg file that will let you start Ubuntu from either drive.
 
Old 09-08-2012, 12:36 PM   #3
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 12.04 64-bit
Posts: 230

Original Poster
Rep: Reputation: 30
Quote:
The error that caused the problem is listed somewhere before the part you posted, where the kernel tells you that it's missing the drive that contains your root file system
I couldn't see any such text before this.
Quote:
Since you can boot from your second drive it should be fairly easy for you to mount the root partition of the first drive and correct the problem.
How ? I booted via the 2nd hard-drive and opened /media/85da....7f0a/etc/fstab and I get this :
Code:
proc   /proc    proc    nodev,noexec,nosuid 0    0
#/ was on /dev/sda1 during installation
UUID=85da....7f0a   /    ext4     errors=remount-ro 0
What do I have to edit ?
 
Old 09-08-2012, 12:43 PM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,580

Rep: Reputation: 581Reputation: 581Reputation: 581Reputation: 581Reputation: 581Reputation: 581
usually it can't find the root drive when that error shows.

Switch on, Try hitting e on your choice of boot option, e again on the line that has the kernel on it. There's a 'root=<something> and that may be wrong. It wants the system root drive.
 
Old 09-10-2012, 02:07 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,153

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
What you should be looking at is /var/log/dmesg on the problem drive (/media/85.../var/log/dmesg).
 
Old 09-10-2012, 07:27 PM   #6
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,299

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
One thing you should learn from this is to not use Update Mangler to update your box.

If you need a gui to do that install synaptic package manager.

Better use apt-get or aptitude (you will have to install aptitude as Ubuntu does not install it by default any more in their great wisdom).

Those are solid, dependable tools that are actually capable of doing an update/upgrade cycle for you.
 
Old 09-11-2012, 01:34 PM   #7
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 12.04 64-bit
Posts: 230

Original Poster
Rep: Reputation: 30
@PTrenholme : I dont see any referneces to kernel in /media/85da89ca-34a4-4863-90d0-6a7b538b7f0a/var/log/dmesg
This is the last few lines :
Code:
[    9.084421] cfg80211: Updating information on frequency 2452 MHz for a 20 MHz width channel with regulatory rule:
[    9.084424] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.084426] cfg80211: Updating information on frequency 2457 MHz for a 20 MHz width channel with regulatory rule:
[    9.084428] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.084430] cfg80211: Updating information on frequency 2462 MHz for a 20 MHz width channel with regulatory rule:
[    9.084433] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.084435] cfg80211: Updating information on frequency 2467 MHz for a 20 MHz width channel with regulatory rule:
[    9.084437] cfg80211: 2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    9.084440] cfg80211: Updating information on frequency 2472 MHz for a 20 MHz width channel with regulatory rule:
[    9.084442] cfg80211: 2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    9.084444] cfg80211: Updating information on frequency 2484 MHz for a 20 MHz width channel with regulatory rule:
[    9.084447] cfg80211: 2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    9.084449] cfg80211: World regulatory domain updated:
[    9.084451] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[    9.084453] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.084456] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    9.084458] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    9.084460] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.084463] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.102948] logitech 0003:046D:C517.0002: fixing up Logitech keyboard report descriptor
[    9.103681] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1a.2/usb5/5-1/5-1:1.1/input/input5
[    9.103868] logitech 0003:046D:C517.0002: input,hiddev0,hidraw2: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1a.2-1/input1
[    9.125973] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    9.125982] nvidia 0000:01:00.0: setting latency timer to 64
[    9.125988] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[    9.126126] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  295.40  Thu Apr  5 21:37:00 PDT 2012
[    9.562270] init: failsafe main process (769) killed by TERM signal
[    9.596784] vesafb: mode is 1280x1024x32, linelength=5120, pages=0
[    9.596786] vesafb: scrolling: redraw
[    9.596789] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    9.601601] vesafb: framebuffer at 0xe1000000, mapped to 0xffffc90009d80000, using 5120k, total 5120k
[    9.602583] Console: switching to colour frame buffer device 160x64
[    9.602609] fb0: VESA VGA frame buffer device
[    9.775977] type=1400 audit(1347109821.342:5): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=840 comm="apparmor_parser"
[    9.776890] type=1400 audit(1347109821.346:6): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=841 comm="apparmor_parser"
[    9.777278] type=1400 audit(1347109821.346:7): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=841 comm="apparmor_parser"
[    9.777501] type=1400 audit(1347109821.346:8): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=841 comm="apparmor_parser"
[    9.779107] type=1400 audit(1347109821.346:9): apparmor="STATUS" operation="profile_load" name="/usr/lib/cups/backend/cups-pdf" pid=845 comm="apparmor_parser"
[    9.779580] type=1400 audit(1347109821.346:10): apparmor="STATUS" operation="profile_load" name="/usr/sbin/cupsd" pid=845 comm="apparmor_parser"
[    9.780094] type=1400 audit(1347109821.350:11): apparmor="STATUS" operation="profile_load" name="/usr/lib/telepathy/mission-control-5" pid=844 comm="apparmor_parser"
[    9.845462] ppdev: user-space parallel port driver
[    9.859928] Bluetooth: Core ver 2.16
[    9.859975] NET: Registered protocol family 31
[    9.859977] Bluetooth: HCI device and connection manager initialized
[    9.859979] Bluetooth: HCI socket layer initialized
[    9.859981] Bluetooth: L2CAP socket layer initialized
[    9.860659] Bluetooth: SCO socket layer initialized
[    9.862770] Bluetooth: RFCOMM TTY layer initialized
[    9.862775] Bluetooth: RFCOMM socket layer initialized
[    9.862777] Bluetooth: RFCOMM ver 1.11
[    9.865005] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    9.865008] Bluetooth: BNEP filters: protocol multicast
 
Old 09-11-2012, 07:11 PM   #8
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,153

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
"[ 9.562270] init: failsafe main process (769) killed by TERM signal" is strange, but what generated the SIGTERM is not too clear from that extract. I notice, however, that this is from an attempted fail-safe boot. The first message file from which you posted the kernel panic message reported the panic after 1.33 seconds, while this last one lasted 9.6 seconds.

Look at the creation dates of the various dmesg.n.gz files to see if one of them might be a compressed, saved version of the messages generated
by the boot that crashed.

Is there some reason why you can't post the whole dmesg file?

Last edited by PTrenholme; 09-11-2012 at 07:13 PM.
 
Old 09-12-2012, 04:06 AM   #9
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,580

Rep: Reputation: 581Reputation: 581Reputation: 581Reputation: 581Reputation: 581Reputation: 581
OK if you're getting that far into the boot, I withdraw the remark about not finding the root drive. So, something is crashing init. I see a Nvidia module and vesafb, and I predict that one will end in tears, but otherwise you haven't shown us an error.

As you can get in to the system, try adding the word 'debug' to the kernel boot line (manually if you like) to get more explicit messages, and try this command

ldd /sbin/init |grep found

to which the output should be nothing - nada. If it mentions anything, it's missing.
 
Old 09-12-2012, 03:41 PM   #10
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,153

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
The debug option suggested by business_kid, above, might be helpful.

To add that option, boot your working system and, from a terminal window issue the command sudo gedit /media/85.../boot/grub/grub.cfg. Then page down in the file (or search for) the first line that starts with " linux /boot/vmlinuz..." and add " debug" at the end of the line and save the file.

Then reboot and try to boot the failing installation. After it fails, you should have some information in /var/log/syslog.

When I tested this procedure, I could display the interesting part of that file using the command grep 'Sep 12 12:' /var/log/syslog (The 'Sep 12 12:' selects the lines generated today (Sep 12) between noon and 13:00, which is when I rebooted my virtual Ubuntu system. Your date and time will, of course, be different. Do a tail /media/85.../var/log/syslog to see what you need to put in the search part of the grep command.)
 
Old 09-21-2012, 12:40 AM   #11
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 12.04 64-bit
Posts: 230

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by PTrenholme View Post
Is there some reason why you can't post the whole dmesg file?
Here it is : http://pastebin.com/kyBMQDCk
 
Old 09-21-2012, 11:11 AM   #12
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,580

Rep: Reputation: 581Reputation: 581Reputation: 581Reputation: 581Reputation: 581Reputation: 581
From your dmesg output:
Quote:
[ 9.125973] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 9.125982] nvidia 0000:01:00.0: setting latency timer to 64
[ 9.125988] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=nonewns=io+mem
[ 9.126126] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 295.40 Thu Apr 5 21:37:00 PDT 2012
[ 9.562270] init: failsafe main process (769) killed by TERM signal
[ 9.596784] vesafb: mode is 1280x1024x32, linelength=5120, pages=0
[ 9.596786] vesafb: scrolling: redraw
[ 9.596789] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[ 9.601601] vesafb: framebuffer at 0xe1000000, mapped to 0xffffc90009d80000, using 5120k, total 5120k
[ 9.602583] Console: switching to colour frame buffer device 160x64
[ 9.602609] fb0: VESA VGA frame buffer device
This seems to be it. It seems to be throwing out the Nvidia driver for some reason. Try a reinstall of that, as a first move. But there are/were issues with Nvidia drivers and newer kernels - and nvidia were not playing ball, last I heard. I'm using AMD/ATI myself.
 
  


Reply

Tags
kernel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic - not syncing: No init found. Try passing init= option to kernel 5883 Linux - Newbie 2 04-25-2012 12:51 PM
[SOLVED] Diskless: Kernel panic-not syncing: No init found. Try passing init= option to kernel Pier Gentoo 6 10-10-2011 07:17 AM
Kernel panic-not syncing:No init found. Try passing init=option to kernel cucolin@ Ubuntu 5 12-26-2008 07:44 AM
Kernel panic - not syncing: No init found. Try passing init= option to kernel. john_schimandle Linux - Embedded & Single-board computer 3 10-10-2008 10:09 AM


All times are GMT -5. The time now is 06:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration