LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Karmic 9.10 with separate /home partition caused "Could not update ICEauthority" (http://www.linuxquestions.org/questions/ubuntu-63/karmic-9-10-with-separate-home-partition-caused-could-not-update-iceauthority-798084/)

shy_guest 03-26-2010 12:01 PM

Karmic 9.10 with separate /home partition caused "Could not update ICEauthority"
 
I created a separate /home partition after installing Karmic on a new Sony E series computer. I used this HowTo :

http://www.psychocats.net/ubuntu/separatehome

I copied all the files from the old /home/user using

find . -depth -print0 | sudo cpio --null --sparse -pvd /new/

On booting after the change, the new /home is correctly on a separate partition BUT during boot I get a message :

Could not update ICEauthority file /home/user/.ICEauthority

I checked out posts from people with similar problems.

Ownership and permissions for /home/user/.ICEauthority are correct. Deleting the file & waiting for it to be recreated doesn't work. (Not sure I understood the right way to do this.)

But when I compare other hidden files in the new /home/user directory, quite a few now have their ownership changed to root.

& I am unable to connect to my external monitor because of a permission problem (probably connected).

Any ideas or suggestions ? I plan on changing ownerships back, but I'd like to avoid a reinstall.

tommcd 03-27-2010 04:59 AM

Quote:

Originally Posted by shy_guest (Post 3913479)
I created a separate /home partition after installing Karmic on a new Sony E series computer. I used this HowTo :
http://www.psychocats.net/ubuntu/separatehome

Ownership and permissions for /home/user/.ICEauthority are correct. Deleting the file & waiting for it to be recreated doesn't work.

Try renaming the .ICEauthority file to .ICEauthority.bak. Then log out and log back in, or just reboot, and it should be recreated.
Quote:

Originally Posted by shy_guest (Post 3913479)
But when I compare other hidden files in the new /home/user directory, quite a few now have their ownership changed to root.

Open a terminal and run:
Code:

sudo chown -R user:user /home/user/.*
Where user is your user_name. This should change ownership of all the hidden files and directories in your home directory to: user:user, as they should be.

Zeniff 05-10-2010 07:03 PM

Here's what I posted in another thread:
http://ubuntuforums.org/showthread.php?t=1431381

I'm guessing it probably won't help most people with this problem, but I recommend checking to see HOW MANY ~/.ICEauthority files you have.

In my case, two EXTRA files, ~/.ICEauthority-c and ~/.ICEauthority-l already owned by MY USERNAME needed to be renamed/deleted IN ADDITION to changing ~/.ICEauthority from root to my username.

Hope that helps someone~ Have a great day~! ^^/

PushkarApte 06-22-2011 09:41 AM

Quote:

Originally Posted by tommcd (Post 3914211)
Try renaming the .ICEauthority file to .ICEauthority.bak. Then log out and log back in, or just reboot, and it should be recreated.

This worked for me. I was having "Could not update ICEauthority" at login and my pulse audio showed empty label. Both went away after following above. thanks tommcd :)

TobiSGD 06-22-2011 09:43 AM

Deleted: posted in wrong thread

cmaglaughlin 01-05-2012 02:09 PM

try this when all else fails
 
The "could not update," etc... kept popping up after grub loading. It was a pain to have to X(close)the box...So, I have looked for hours how to rectify the situation, and some solutions were just way beyond my scope of expertise. Then a "still small voice" said, "Go to startup applications...System, Preferences, Startup Applications. UNcheck "User Folders Update"...Bingo!!!


All times are GMT -5. The time now is 02:03 PM.