LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Installing nvidia driver for new kernel ??? (http://www.linuxquestions.org/questions/ubuntu-63/installing-nvidia-driver-for-new-kernel-455646/)

bigjohn 06-17-2006 09:12 AM

Installing nvidia driver for new kernel ?[Solved]
 
The other day, I came home from work, to find the installer icon telling me that there was 29 updates/upgrades available.

Great, so I install them. One of which, was a new kernel version - 2.6.15-25-386. So with what I thought was everything installed/updated/upgrade etc, that I was ready to go.

Wrong.

If I just let the system boot itself, it will boot into the new kernel, but that only gets as far as the bootsplash screen - which is frozen. I can get into a console login with alt+F4, but if I then try to run the package manager, and do sudo apt-get install nvidia-glx nvidia-kernel-common it just tells me that the latest version(s) are already installed, so if I then do apt-get remove for the same packages, but then do the apt-get update and apt-get upgrade - finally followed by the apt-get install for the nvidia packages again, it still only seems to be getting the versions for the older kernel version (2.6.15-23-386).

How do I get round this snag please ??

regards

John

m_yates 06-17-2006 04:51 PM

The old kernel should still be there and you should be able to boot into it. If it isn't there, install it from the console:
Code:

sudo apt-get install linux-image-2.6.15-23-386
then reboot into the old kernel and remove the newer kernel:
Code:

sudo dpkg -P linux-image-2.6.15-25-386
On my system, the 2.6.15-23 kernel is installed and the -25 version is not an automatic upgrade. Therefore, I think you should be able to use the -23 version and run updates without automatically installing the newer version. If not you can avoid upgrading the kernel until the nvidia modules for the new kernel are available. You can also pin the kernel to prevent it from being upgraded. See: http://jaqque.sbih.org/kplug/apt-pinning.html Give the kernel package a pin priority of 1001 and it will never be upgraded. You can later remove the pin priority when you want it upgraded.

bigjohn 06-17-2006 07:26 PM

Quote:

Originally Posted by m_yates
The old kernel should still be there and you should be able to boot into it. If it isn't there, install it from the console:
Code:

sudo apt-get install linux-image-2.6.15-23-386
then reboot into the old kernel and remove the newer kernel:
Code:

sudo dpkg -P linux-image-2.6.15-25-386
On my system, the 2.6.15-23 kernel is installed and the -25 version is not an automatic upgrade. Therefore, I think you should be able to use the -23 version and run updates without automatically installing the newer version. If not you can avoid upgrading the kernel until the nvidia modules for the new kernel are available. You can also pin the kernel to prevent it from being upgraded. See: http://jaqque.sbih.org/kplug/apt-pinning.html Give the kernel package a pin priority of 1001 and it will never be upgraded. You can later remove the pin priority when you want it upgraded.

Ok, I could boot into the old kernel and the nvidia driver worked fine in that i.e. the -23 version, but I'm thinking along the lines that it (the linux-restricted-modules for the -25 kernel version) might be available in on one of the mirrors/sources as I've read stuff where people are saying that they've got it fine and others who've yet to run the update, but have looked at whats available to them via synaptic, and it seems to indicate that the packages are available for the -25 so I wonder how or if I can look at a mirror/repo and see if it has the package(s)? Hell I haven't even managed to find out if theres a list of available repositories despite much looking

regards

John

fragos 06-17-2006 08:14 PM

I handled the problem differently. I stayed with the new kernel but edited my /etc/X11/xorg.conf to change the video driver from "nvidia" to "nv" which is the 2D driver and rebooted into the new kernel. I tried to use easyubuntu to get the nvidia 3D driver and it compiled me a new kernel as well. I was at AMD64-generic -23 and the available update made it -generic -25. After easyubuntu was run I also had AMD64-xenon -25 which I've been running after editing xorg.conf to the "nv" driver. I have a Sempron 2800+ 64 bit processor and am a little confused about should I use AMD64-generic or AMD64-xenon. My inclination is to stick with the xenon which I'm assuming is the k8 kernel. anyone able to unconfuse things for me?

m_yates 06-17-2006 09:21 PM

Here is the way to fix it and get the latest kernel:
Code:

sudo apt-get install linux-image-2.6.15-25-686
sudo apt-get install linux-restricted-modules-2.6.15-25-686

For whatever reason, the restricted modules are unavailable for the 386 kernel, but are there for the 686 kernel. I just tried this myself and my Nvidia driver is still working. You can see what is available by searching using synaptic or by using "apt-cache search" from the command line.

bigjohn 06-18-2006 04:52 AM

Quote:

Originally Posted by m_yates
Here is the way to fix it and get the latest kernel:
Code:

sudo apt-get install linux-image-2.6.15-25-686
sudo apt-get install linux-restricted-modules-2.6.15-25-686

For whatever reason, the restricted modules are unavailable for the 386 kernel, but are there for the 686 kernel. I just tried this myself and my Nvidia driver is still working. You can see what is available by searching using synaptic or by using "apt-cache search" from the command line.

Ok, so I followed your suggestion. It seems to have not worked (I'm probably missing something here).

What I did, was
Code:

sudo apt-get install kernel-image-2.6.15-25-686
which worked fine. So I then I booted into it and did the
Code:

sudo apt-get install linux-restricted-modules-2.6.15-25-686
strangely, that just dumped me back to a prompt - not sure why as normally the system will tell me if it can't find something.

So, I then tried your trick of using apt-cache search
Code:

sudo apt-cache search nvidia
and
Code:

sudo apt-cache search linux-restricted-modules
and for good measure, I also did
Code:

sudo apt-cache search linux-image
apt-cache search for linux-restricted-modules gives me this
Code:

sudo apt-cache search linux-restricted-modules
Password:
linux-restricted-modules-2.6.15-23-386 - Non-free Linux 2.6.15 modules on 386
linux-restricted-modules-2.6.15-23-686 - Non-free Linux 2.6.15 modules on PPro/Celeron/PII/PIII/PIV
linux-restricted-modules-2.6.15-23-k7 - Non-free Linux 2.6.15 modules on AMD K7
linux-restricted-modules-386 - Restricted Linux modules on 386.
linux-restricted-modules-686 - Restricted Linux modules on PPro/Celeron/PII/PIII/PIV.
linux-restricted-modules-common - Non-free Linux 2.6.15 modules helper script
linux-restricted-modules-k7 - Restricted Linux modules on AMD K7.
avm-fritz-kernel-source - AVM Fritz! binary kernel module source
fglrx-kernel-source - ATI binary kernel module source
nvidia-kernel-source - NVIDIA binary kernel module source
nvidia-legacy-kernel-source - NVIDIA binary 'legacy' kernel module source

I've tried various combinations (sorry, can't explain any better as I'm thoroughly confused over this) but the only one that seems to work is -23-386. Also, I now have 4 different kernels installed i.e. -23-386, -25-386, -23-686 and -25-686 which is making my confusion worse as I have made sure that I can see the grub menu but as I've commented out the "hiddenmenu" option in the menu.lst the highlight bar seems to have disappeared and I have to count the number of "presses" of the arrow to work out what kernel I'm booting into (and check with uname -r post boot process, once I'm into the CLI).

Now I know that this must sound like I'm babbling like some complete idiot, but it's come to mind that if you, and others say that you can find the linux-restricted-modules-2.6.15-25-686 but my system is failing to disclose this package could only be (as I understand it) that I haven't got the correct entry in my sources.list - my sources.list currently looks like this

Code:

deb cdrom:[Kubuntu 6.06 _Dapper Drake_ - Release i386 (20060531)]/ dapper main restricted
deb http://packages.freecontrib.org/ubuntu/plf/ dapper free non-free
deb-src http://packages.freecontrib.org/ubuntu/plf/ dapper free non-free

deb http://gb.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb-src http://gb.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse

deb http://gb.archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
deb-src http://gb.archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse

deb http://gb.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://gb.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ dapper-security main
deb-src http://security.ubuntu.com/ubuntu/ dapper-security main
deb http://security.ubuntu.com/ubuntu/ dapper-security universe
deb-src http://security.ubuntu.com/ubuntu/ dapper-security universe

deb http://kubuntu.org/packages/kde-latest/ dapper main
deb-src http://kubuntu.org/packages/kde-latest/ dapper main

So have I got something wrong there ??? i.e. is there a source that I've missed so that it won't show some of these more elusive packages ?

regards

A very confused John

bigjohn 06-18-2006 05:38 PM

Are the instructions that I used to get this sorted out.

regards

John

fragos 06-18-2006 07:18 PM

I have things working again. Your steps may vary depending on your processor but the concept of what I'm doing will work with all.

1. http://www.nvidia.com/object/linux_d..._1.0-8762.html and download NVIDIA-Linux-x86_64-1.0-8762-pkg2.run

2. Logout and then Ctrl+Alt+F1 exit X and go to level 3

3. Login at the terminal command line

4. cd {dir of where you put the download}

5. sudo sh NVIDIA-Linux-x86_64-1.0-8762-pkg2.run

6. The Nvidia installer will prompt you. If in doubt select defaults. The installer will even offer to edit your xorg.conf which you should let it do.

7. sudo reboot

m_yates 06-18-2006 08:28 PM

It seems restricted modules are now also available for the 386 kernel. Here is the current output of "apt-cache search linux-restricted-modules-2.6.15-25":
Quote:

linux-restricted-modules-2.6.15-25-386 - Non-free Linux 2.6.15 modules on 386
linux-restricted-modules-2.6.15-25-686 - Non-free Linux 2.6.15 modules on PPro/Celeron/PII/PIII/PIV
linux-restricted-modules-2.6.15-25-k7 - Non-free Linux 2.6.15 modules on AMD K7
I just upgraded a second system with the Nvidia driver and used the 386 kernel. I guess your problem was not all repositories were activated (maybe security missing?). Here is my sources.list:
Code:

deb http://archive.ubuntu.com/ubuntu dapper main restricted
deb-src http://archive.ubuntu.com/ubuntu dapper main restricted

deb http://archive.ubuntu.com/ubuntu dapper-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu dapper-updates main restricted

deb http://archive.ubuntu.com/ubuntu dapper universe
deb-src http://archive.ubuntu.com/ubuntu dapper universe

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted

deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe


bigjohn 06-19-2006 02:11 PM

Quote:

Originally Posted by m_yates
It seems restricted modules are now also available for the 386 kernel. Here is the current output of "apt-cache search linux-restricted-modules-2.6.15-25":I just upgraded a second system with the Nvidia driver and used the 386 kernel. I guess your problem was not all repositories were activated (maybe security missing?). Here is my sources.list:
Code:

deb http://archive.ubuntu.com/ubuntu dapper main restricted
deb-src http://archive.ubuntu.com/ubuntu dapper main restricted

deb http://archive.ubuntu.com/ubuntu dapper-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu dapper-updates main restricted

deb http://archive.ubuntu.com/ubuntu dapper universe
deb-src http://archive.ubuntu.com/ubuntu dapper universe

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted

deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe


Yes, I suspect that you are exactly right. I does strike me as a little unusual for the upgraded package to be released in such a way. I'm familiar with having to wait for something, but it's always been that when it's available on one repository, it's also hit all the mirrors.

I have to say, that with respect to the above, gentoo seemed to have the right idea, because I found when I ran that, that when I was "emerging" something, if it wasn't available at one location or that location was busy/didn't reply, then it would go to the next location until it found what it was looking for. Spooky!

anyway, thankyou very much for your assistance. It is, very much appreciated.

regards

John


All times are GMT -5. The time now is 07:47 AM.