LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Installing from source, installing from CVS and the E-17 window manager... (http://www.linuxquestions.org/questions/ubuntu-63/installing-from-source-installing-from-cvs-and-the-e-17-window-manager-409358/)

Buffbannana049 01-29-2006 01:27 PM

Installing from source, installing from CVS and the E-17 window manager...
 
Hi,
First off I want to warn I have been messing around on my own with Ubuntu, however I am still extreamly new to all of this.


I use package managers to install software, and I am yet to install something from source (if someone wants to help with that also I would appreciate it :)). I however like the e17 window manager and I hear it's preatty good stuff... Should some as new as I am be dealing with something like this? And if it would be no big deal could I have some assistance with install it?

Note: I have installed something from CVS either...

Thanks you for anything...

imagreg 01-31-2006 08:28 PM

i just installed e17 today from cvs. this is a great link that tells you how to:

https://vogelweith.homeftp.net/Linux/e17_en.php

follow it exactly and you'll be running e17 in no time

Buffbannana049 02-06-2006 11:03 PM

Hey, thanks for the responce and sorry it took me so long to answer, I've been preatty busy.

I got he guide and it's great... It was working prefectly untill I was building emotion and it says I need Xine or Gstreamer installed for it to work. I have both installed but it would appear I'm using a version that is to old... I have tried a few things but I can't find one thats new enough... Anyone know where I can get a verion of Xine newer then 1.1.1? I know I got far enough into this that if I restart it wont come back on :). Anyone please want to direct me to a repository where I can get what I need? Thank you VERY much...

imagreg 02-07-2006 10:15 AM

I had the same issue with emotion. Go here and download http://prdownloads.sourceforge.net/x...b-1.1.1.tar.gz

Do a sudo apt-get install checkinstall (checkinstall is used instead of make install-it will build a deb package)

Untar xine-lib-1.1.1 cd into the untarred directory ./configure make sudo checkinstall

This will make a deb package for u and install it. For some reason it didn't work with the version from Ubuntu. After installing this emotion built just fine.

Buffbannana049 02-07-2006 10:30 PM

Thanks again for the help... It worked great and I got pased it. I was hoping to have the next post be WHOOOO, I DID IT... However, :), I am ./auotgen.sh(ing) exlair and it's saying...

--------------
checking for taglib-config... no
taglib-config is not in your $PATH. Please ensure it is.
Read the manual page for you shell as to how to extend your path.
configure: error: Cannot find taglib-config
--------------

And then when I run make it says...

--------------
make: *** No targets specified and no makefile found. Stop.
--------------

Can you help me with this? I relize it's saying it can't find taglib-config, however I looked all over the place and I can't find it either... Thanks again :).

P.S. As always, thanks for the fast responce, I fell asleep early yesterday and I just got home a hour or two ago today...

imagreg 02-12-2006 11:49 PM

have u previously tried to install enlightenment. if so...there may be an outdated package causing this error. check in /usr/bin and see if there are any outdated enlightenment packages. if there are delete them and then try compiling eclair again. let me know if that's the case.

imagreg 02-12-2006 11:52 PM

by the way...did u also see that in order to compile eclair u need these packages...

apt-get install libtag1-dev libtagc0-dev libxml2-dev libglade2-dev libsqlite3-dev

Buffbannana049 02-13-2006 07:57 PM

Hey, thanks again for the help and sorry sunday was crazy...

I looked and there were no enlightenment packages... Could that be the problem? I however ran the command you gave in your second post and then tried and it worked...

However when I got to evidence the folder they said to cd to was not there... I searched around a little and then I did a search through palces, search for files, and the only place it found anything from evidance was in the /cvs/e17/libs/ewl(s?) folder so I built and installed that. However when I tried to actually start E it poped up for a second and I can tell there is text and there is a box so I can tell it's not just a error message, however it crashes and the terminal closes before I can read it. I think it might have something to do with evidance being missing?

Thanks again, for all the help and sticking with me, if nothing else I learned a lot :).

P.S. I don't know if it has anything to do with anything but I installed mythtv but never got it working, but now and then when I was working on this I would think I say something starting with error and I saw the word mythtv on the same line... Could this be it? Even if it's not do you know how to get rid of it? It's annoying :)...

imagreg 02-14-2006 04:37 PM

u need to edit your xsessions to get E to launch. u have everything compiled u need to get running. open up an editor and put this:

[Desktop Entry]
Encoding=UTF-8
Name=Enlightenment
Comment=Highly configurable and low resource X11 Window manager
Exec=/usr/local/bin/enlightenment
Terminal=False
TryExec=/usr/local/bin/enlightenment
Type=Application

[Window Manager]
SessionManaged=true

save it as Enlightenment.desktop

open up a terminal and sudo mv (drag the doc u created leave a space) /usr/share/xseesions

this will place Enlightnment.desktop in your /usr/share/xsessions folder

now u can do a ctrl/alt/backspace

Enlightenment will now show up along with Gnome as one of your login choices

u need to check out evidence seperately if u want it...u don't need it

sudo apt-get install rox-filer (my fav. filer app) launch it in terminal by rox...i use this instead

Buffbannana049 02-14-2006 07:43 PM

Ok, thanks, I made the file and I put it in the folder however E's still not a option on log in... Also when I look at the xsessions folder with rox it shows gnome.desktop and xsessions. However nautalis shows Enlightenment and GNOME... Any idea why?


As always, thanks...

imagreg 02-14-2006 11:27 PM

let's try again...

do a sudo gedit

then paste this:

[Desktop Entry]
Encoding=UTF-8
Name=Enlightenment
Comment=Highly configurable and low resource X11 Window manager
Exec=/usr/local/bin/enlightenment
Terminal=False
TryExec=/usr/local/bin/enlightenment
Type=Application

[Window Manager]
SessionManaged=true



Name it Enlightenment.desktop

Go to File / Save as / Browse for other folders / /usr/share/xsessions / save

Then control alt back and see if it shows up in your options


All times are GMT -5. The time now is 10:44 PM.