LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2012, 02:01 AM   #1
bencla
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Rep: Reputation: Disabled
install .deb with lower version of python


Alright you guys, I'm totally new to the whole linux things so bear with me.

I have a computer without internet where I'm trying to install meets 1.0 on. I have installed all the dependencies manually but when I run it, sudo dpkg -i keryx.deb, it gives me this error:

Dpkg: dependency problems prevent configuration of keryx:
Keryx depends on python (<<2.7); however:
Version of python on system is 2.7.3-0ubuntu2.

However, I tried to install python 2.5 and actually when I type python in the terminal I get 2.5.6
So what am I doing wrong?



Thanks!
 
Old 04-27-2012, 04:19 AM   #2
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,607

Rep: Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242
maybe you need to uninstall 2.7.3. or you can try to force install (dpkg --force-depends -i filename.deb)
 
Old 04-27-2012, 11:21 AM   #3
bencla
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
So I force installed because I didn't want to mess up my ubuntu uninstalling python2.7 and it installe. However, when I rupture keryx into the terminal, it gives me an error:

File"/usr/bin/keryx", line 60, in <module>
From Keryx import aboutkeryxdialog, keryxconfig
Importerror: no module named Keryz.


No idea what it means but did it just install incorrectly?
 
Old 04-28-2012, 11:43 AM   #4
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,607

Rep: Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242
It looks like keryx installed a module into 2.7.3. Just try to find it and copy to the other python environment.
 
Old 05-01-2012, 01:13 PM   #5
bencla
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Will give that a shot tonight, thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] trying to install lower version of ktorrent Adol Suse/Novell 1 06-30-2011 12:12 AM
[SOLVED] emerge lower version of program Adol Gentoo 4 04-14-2011 09:36 PM
Replacing GCC to lower version sjcoder Linux - Software 3 08-16-2007 02:49 PM
Can I drop to a lower kernel version Ratclaws Fedora 1 08-19-2005 12:37 PM
Compling on a higher version and executing on a lower version aditya_shah Programming 0 09-30-2003 11:48 PM


All times are GMT -5. The time now is 02:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration