LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   install .deb with lower version of python (http://www.linuxquestions.org/questions/ubuntu-63/install-deb-with-lower-version-of-python-942021/)

bencla 04-27-2012 02:01 AM

install .deb with lower version of python
 
Alright you guys, I'm totally new to the whole linux things so bear with me.

I have a computer without internet where I'm trying to install meets 1.0 on. I have installed all the dependencies manually but when I run it, sudo dpkg -i keryx.deb, it gives me this error:

Dpkg: dependency problems prevent configuration of keryx:
Keryx depends on python (<<2.7); however:
Version of python on system is 2.7.3-0ubuntu2.

However, I tried to install python 2.5 and actually when I type python in the terminal I get 2.5.6
So what am I doing wrong?



Thanks!

pan64 04-27-2012 04:19 AM

maybe you need to uninstall 2.7.3. or you can try to force install (dpkg --force-depends -i filename.deb)

bencla 04-27-2012 11:21 AM

So I force installed because I didn't want to mess up my ubuntu uninstalling python2.7 and it installe. However, when I rupture keryx into the terminal, it gives me an error:

File"/usr/bin/keryx", line 60, in <module>
From Keryx import aboutkeryxdialog, keryxconfig
Importerror: no module named Keryz.


No idea what it means but did it just install incorrectly?

pan64 04-28-2012 11:43 AM

It looks like keryx installed a module into 2.7.3. Just try to find it and copy to the other python environment.

bencla 05-01-2012 01:13 PM

Will give that a shot tonight, thanks!


All times are GMT -5. The time now is 12:27 AM.