LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   I messed up my usb external disk auto-mounting (http://www.linuxquestions.org/questions/ubuntu-63/i-messed-up-my-usb-external-disk-auto-mounting-557059/)

alek66 05-27-2007 04:04 PM

I messed up my usb external disk auto-mounting
 
I have an external usb disk. I messed up i touch the mounting properties, and changed the mount point. I did a leftclick on the desktop icon of my disk and changed it there... (this image is to point out where I changed it, this image is from my sdcard)
http://img294.imageshack.us/img294/4...rtiega1.th.png
Now it doesnt work anymore and everytime I plug the usb disk i get this:
http://img294.imageshack.us/img294/7...ountzj9.th.png

I dont know where to go and fix this. I looked at fstab...but nothing there.
HELP!

Sjonnie48 05-28-2007 06:26 AM

Hi,

You are looking on the wrong place. Look in /etc/mtab. I have a USB-hdd and in the mtab it looks like this:

/dev/sde1 /media/sde1 reiserfs rw,noexec,nosuid,nodev 0 0

Anyway, why should you mess up the automount options. If it works fine leave it that way. To unmount I only swith the disk itself to off.

Kind regards

alek66 05-28-2007 06:54 AM

Quote:

Originally Posted by Sjonnie48
Hi,

You are looking on the wrong place. Look in /etc/mtab. I have a USB-hdd and in the mtab it looks like this:

/dev/sde1 /media/sde1 reiserfs rw,noexec,nosuid,nodev 0 0

Anyway, why should you mess up the automount options. If it works fine leave it that way. To unmount I only swith the disk itself to off.

Kind regards

Beacause its a external usb case for an internal disk. The disk is in ntfs filesystem, and although I installed the compatibility package to write into ntfs, it doesnt work. I though this would fix it.

There was no line refered to it, so I added a line, using my info... and but didnt work.
I added /dev/sda1 /media/ALEUSB ntfs rw,noexec,nosuid,nodev 0 0
and this was all that was on mtab
Quote:

/dev/hda1 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.20-15-generic/volatile tmpfs rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sdc1 /media/MEMORYSTICK vfat

rw,nosuid,nodev,shortname=mixed,uid=1000,utf8,umask=077 0 0
this is the syslog
Quote:

May 28 09:00:09 DeathStar kernel: [ 523.429316] usb 4-1.3: new high speed USB device using ehci_hcd and address 10
May 28 09:00:10 DeathStar kernel: [ 523.471187] usb 4-1.3: configuration #1 chosen from 1 choice
May 28 09:00:10 DeathStar kernel: [ 523.471344] scsi3 : SCSI emulation for USB Mass Storage devices
May 28 09:00:15 DeathStar kernel: [ 526.703147] scsi 3:0:0:0: Direct-Access ST380011 A 0000 PQ: 0 ANSI: 0
May 28 09:00:15 DeathStar kernel: [ 526.704998] SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
May 28 09:00:15 DeathStar kernel: [ 526.705930] sda: Write Protect is off
May 28 09:00:15 DeathStar kernel: [ 526.706869] SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
May 28 09:00:15 DeathStar kernel: [ 526.707742] sda: Write Protect is off
May 28 09:00:15 DeathStar kernel: [ 526.707750] sda: sda1
May 28 09:00:15 DeathStar kernel: [ 526.727301] sd 3:0:0:0: Attached scsi disk sda
May 28 09:00:15 DeathStar kernel: [ 526.727350] sd 3:0:0:0: Attached scsi generic sg0 type 0
May 28 09:00:23 DeathStar gconfd (root-6670): GConf server is not in use, shutting down.
May 28 09:00:23 DeathStar gconfd (root-6670): Exiting

Sjonnie48 05-28-2007 07:50 AM

Give this procedure a try.

First of all I listed /etc/mtab with the following result:

/dev/sde1 /media/sde1 reiserfs rw,noexec,nosuid,nodev 0 0

Then I disconnected my usb harddisk.
Then I listed /etc/mtab with the following result:




Then I reconnected my usb harddisk.
Then I listed /etc/mtab with the following result:

/dev/sde1 /media/sde1 reiserfs rw,noexec,nosuid,nodev 0 0

Whenever I connect my usb harddisk the system asks me what to do. The options are:

Do nothing or Open in a new window

I usually select opening in a new window, then it opens in Konqueror, and in less than 10 seconds I can browse my usb harddrive. My drive is also an internal harddisk built in a usb-hub.

And do not touch that icon on your desktop :-)

alek66 05-28-2007 08:05 AM

I disconnected the disk, this appears:
Code:

/dev/hda1 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.20-15-generic/volatile tmpfs rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sdc1 /media/MEMORYSTICK vfat rw,nosuid,nodev,shortname=mixed,uid=1000,utf8,umask=077 0 0

I connected the disk, (the error window appeared "Cannot mount volumen" is the image I posted first), this is the mtab.
Code:

/dev/hda1 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.20-15-generic/volatile tmpfs rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sdc1 /media/MEMORYSTICK vfat rw,nosuid,nodev,shortname=mixed,uid=1000,utf8,umask=077 0 0

Any thoughts?

Sjonnie48 05-28-2007 08:26 AM

There must be something wrong.
Your system tells you that you have connected a memorystick, not a harddisk.
I cannot tell you why your system sees a memorystick while my system recognizes it as a harddisk.
Maybe you still have a Windows system somewhere. You could connect the usb hdd to it, make it a share for your Ubuntu computer and then copy the contents to an internal harddisk.
The other option is to install the "memorystick" into your Ubuntu system, making it an internal harddisk.

Good luck!

alek66 05-28-2007 08:28 AM

Quote:

Originally Posted by Sjonnie48
There must be something wrong.
Your system tells you that you have connected a memorystick, not a harddisk.
I cannot tell you why your system sees a memorystick while my system recognizes it as a harddisk.
Maybe you still have a Windows system somewhere. You could connect the usb hdd to it, make it a share for your Ubuntu computer and then copy the contents to an internal harddisk.
The other option is to install the "memorystick" into your Ubuntu system, making it an internal harddisk.

Good luck!

The memorystick is an actual memorystick, besides de usb disk I have a cardreader. that works...
is there a way to wipe everything, so that it detects everything again, from scratch?

Sjonnie48 05-28-2007 08:34 AM

Maybe the confusion is caused by an inserted usb memorystick.
Remove the inserted memory-sticks and -cards before connecting the thing to your computer.

alek66 05-28-2007 08:36 AM

Quote:

Originally Posted by Sjonnie48
Maybe the confusion is caused by an inserted usb memorystick.
Remove the inserted memory-sticks and -cards before connecting the thing to your computer.

the hole thing started cause i added a mounting point where it should go, and now I can access the same place to change it back.

Sjonnie48 05-28-2007 08:49 AM

Quote:

Originally Posted by alek66
the hole thing started cause i added a mounting point where it should go, and now I can access the same place to change it back.


The /etc/fstab and /etc/mtab files have different functions:

mtab handles the mounted devices and is automatically updated by the mount command.

fstab is a description of the various file systems.

alek66 05-28-2007 08:54 AM

Quote:

Originally Posted by Sjonnie48
The /etc/fstab and /etc/mtab files have different functions:

mtab handles the mounted devices and is automatically updated by the mount command.

fstab is a description of the various file systems.

I get it, thats why I messed up.
Is there a way to clear everything, so as when I reboot, the system discovers everything again.

Sjonnie48 05-28-2007 09:03 AM

A reboot should clean up everything. Maybe you should disconnect the usb harddisk before rebooting. After rebooting you can reconnect it.
If you want to change mountpoints you'd better use the System Administration panel in the System Settings gui.

alek66 05-28-2007 09:38 AM

Already done reboot and nothing.
Thanks anyway

Sjonnie48 05-28-2007 09:52 AM

Don't you have a hardware problem?
Did you remove the lines that you added in /etc/fstab?

alek66 05-28-2007 11:11 AM

I tried to manually mount the disk and this came up
Quote:

alek@DeathStar:~$ sudo mount /dev/sda1 /media/ALEX
mount: mount point /media/ALEX does not exist
alek@DeathStar:~$ sudo mkdir /media/ALEX
alek@DeathStar:~$ sudo mount /dev/sda1 /media/ALEX
Cannot create link /etc/mtab~
Perhaps there is a stale lock file?

alek@DeathStar:~$ sudo umount /media/ALEX/
Cannot create link /etc/mtab~
Perhaps there is a stale lock file?

What is the stale lock file?


All times are GMT -5. The time now is 08:51 AM.