LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 03-19-2012, 08:13 AM   #16
redguy
LQ Newbie
 
Registered: Mar 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled

yancek, Are you telling me that I need to insert the line of code that you provided into the cfg file? I so where in the cfg file do I put it?
 
Old 03-19-2012, 11:26 AM   #17
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,122

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
Quote:
Are you telling me that I need to insert the line of code that you provided into the cfg file?
No. From my last post, open a Terminal and enter the line below:

Quote:
sudo gedit /etc/default/grub
Near the bottom of the file You will see this line:
Quote:
#GRUB_GFXMODE=640x480
Delete the hash mark (#) so it looks like this:
Quote:
GRUB_GFXMODE=640x480
As I said in my last post, this worked for me on the "input not supported" message which basically showed a black screen. Might work in your case? If not, you can always boot again and change it back.

Last edited by yancek; 03-19-2012 at 11:31 AM.
 
1 members found this post helpful.
Old 03-19-2012, 05:21 PM   #18
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 288Reputation: 288Reputation: 288
If removing the # from the #GRUB_GFXMODE=640x480 helps you to see the grub menu, then the 640x480 resolution can be changed to whatever resolution that you want as long as your graphics card supports that resolution.
Then just be sure to run sudo update-grub for the changes to take effect.

Last edited by tommcd; 03-19-2012 at 05:22 PM.
 
Old 03-19-2012, 05:31 PM   #19
redguy
LQ Newbie
 
Registered: Mar 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
how to modify my cfg file

Quote:
Originally Posted by yancek View Post
If you were able to boot into windows using that method, it means your Grub file is correct. You had an entry for windows in your /boot/grub/grub.cfg file so that was to be expected.

I'm not sure if this will work. I installed Ubuntu 11.10 as well as Mint12 several months ago and had a similar error. When I booted either, I would see an input not supported box floating on the monitor which is apparently not the same thing you see. After some googling, I found a site which suggested removing the hash mark (#) from before the following line in the /etc/default/grub file and then running sudo update-grub.
You will need to open gedit as root: sudo gedit /etc/default/grub.




I just did this on the Mint12 install and it got rid of the input not supported box and showed the Grub2 boot menu. Since your are getting a different message "signal out of range" I'm not sure if this will work.
Are you suggesting that I install that line of code in my cfg file? If so where would I install it?

Sorry but I couldn't find my post from this morning and your responses because I didn't realize it was on page 2. Again, I am new to this.

Last edited by redguy; 03-19-2012 at 05:38 PM. Reason: I apologize for double posting
 
Old 03-19-2012, 06:03 PM   #20
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 288Reputation: 288Reputation: 288
Quote:
Originally Posted by redguy View Post
Are you suggesting that I install that line of code in my cfg file? If so where would I install it?
The #GRUB_GFXMODE=640x480 line is in the file: /etc/default/grub file. The grub.cfg file that is in the /boot/grub/ directory is not supposed to be edited. Editing that file will not hurt anything though. However, any edits to /boot/grub/grub.cfg will be overwritten with each kernel update for Ubuntu; and kernel updates for Ubuntu happen fairly often.

So ...
Just remove the # mark in front of the #GRUB_GFXMODE=640x480 line in the /etc/default/grub file using sudo gedit /etc/default/grub or any text editor launched with sudo to give you admin privileges.
Then run sudo update-grub for the changes to take effect.
Then reboot and see if you get the grub menu when you boot the PC.

Last edited by tommcd; 03-19-2012 at 06:09 PM.
 
1 members found this post helpful.
Old 03-20-2012, 06:51 AM   #21
redguy
LQ Newbie
 
Registered: Mar 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
deleted

Last edited by redguy; 03-20-2012 at 09:31 AM. Reason: post deleted
 
Old 03-20-2012, 09:28 AM   #22
redguy
LQ Newbie
 
Registered: Mar 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
It Works!

Thanks gentlemen, the boot up menu works.
Is there a way to eliminate the other options on the menu (there are 6) The heading of the grub.cfg file states: DO NOT EDIT THIS FILE. I would like the menu to show only ubuntu and windows. thanks again for the help!
 
Old 03-20-2012, 11:00 AM   #23
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,122

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
Here's a link to the ubuntu forums which explains several methods. Read through the options first so you understand and also make sure you get the right kernel.


http://ubuntuforums.org/showthread.php?t=1587462
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No 'Alongside' option when trying to install Ubuntu 11.04 to dual boot with Windows 7 UnfairBear Linux - Newbie 16 09-16-2012 06:34 PM
[SOLVED] Installing ubuntu 11.10 alongside windows prob seeing partitions Stev8 Ubuntu 17 03-07-2012 08:14 PM
I want to remove ubuntu boot loader and use windows boot loader RUshabh55 Linux - Newbie 9 11-29-2009 08:01 PM
Installing Ubuntu boot loader ahmed_as8 Linux - Newbie 9 03-29-2009 08:37 AM
Boot Loader is Gone after installing Windows 98 hazarcon Linux - General 4 09-14-2004 02:48 PM


All times are GMT -5. The time now is 08:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration