LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   I Disabled gnome-screensaver, and I Need to Enable It Again (http://www.linuxquestions.org/questions/ubuntu-63/i-disabled-gnome-screensaver-and-i-need-to-enable-it-again-699813/)

Teasdale 01-25-2009 02:45 PM

I Disabled gnome-screensaver, and I Need to Enable It Again
 
I wanted to try xscreensaver, and when I opened it, it wanted me to disable gnome-screensaver, so I checked the option to let xscreensaver work.

I don't like xscreensaver because it doesn't automatically lock my screen after so many minutes; it only locks the screen if I manually lock it. So I want gnome-screensaver back. But I don't know how to get it back.

I've tried uninstalling xscreensaver from synaptic package manager. I've tried reinstalling gnome-screensaver from synaptic package manager. I tried uninstalling gnome-screensaver from synaptic package manager and restarting my computer, then reinstalling gnome-screensaver from synaptic package manager again. I even reinstalled xscreensaver to see if the option to enable gnome-screensaver was in there somewhere. But I can't figure out how to get gnome-screensaver working again.

I even googled and found this:

gconftool-2 --set -t boolean /apps/gnome-screensaver/idle_activation_enabled true

But Ubuntu doesn't recognize that command; I think that's a command for another Linux distro.

Do I have to wipe my hard drive and do a clean install of Ubuntu to get my default screensaver back? Surely that can't be the only option.

wernerz 01-25-2009 03:17 PM

Click System > preferences > screensaver. Click on activate screensaver and choose the time and type of screensaver.

Teasdale 01-25-2009 04:12 PM

When I click system > preferences, I now have TWO screensavers; each one is listed separately in my preferences list (one for gnome-screensaver, one for xscreensaver). When I right-click, I get options to "add launcher to panel," "add launcher to desktop," 'add this as drawer to panel," and "add this as menu to panel." The options are the same for both.

When I left-click, it opens the screensaver program, but I don't see any options to activate; all I see are options to choose a screensaver from the list, and set a time for it to activate when the computer is idle (which it's ignoring, because the whole program has been disabled.)

I'm running Ubuntu 8.04.

rizwanrafique 01-25-2009 04:32 PM

This post lists all steps to switch from gnome-screensaver to xscreensaver. I think just do the reverse to what the poster suggested and you should be good to go.

About two links in menu: I played around with xscreensaver recently. I modified my menu to have different label for both links. You do that by right clicking on menu button and then Edit Menu and then changing labels for your required menu links.

Teasdale 01-25-2009 04:40 PM

Quote:

Originally Posted by rizwanrafique (Post 3421007)
I modified my menu to have different label for both links. You do that by right clicking on menu button and then Edit Menu and then changing labels for your required menu links.

I did that last night - thanks for that, though. And I'll check the link you posted - I don't know I didn't think to go backwards to begin with. Thanks for your help!

Teasdale 01-25-2009 04:42 PM

Quote:

Originally Posted by rizwanrafique (Post 3421007)
This post lists all steps to switch from gnome-screensaver to xscreensaver.

The link isn't taking me to a post; it wants me to download a Wordpress statcounter plugin.

rizwanrafique 01-26-2009 08:17 AM

Quote:

Originally Posted by Teasdale (Post 3421015)
The link isn't taking me to a post; it wants me to download a Wordpress statcounter plugin.


Sorry, that's my mistake. wrong item on top of clipboard stack.

Here is right one.

http://ubuntuforums.org/showthread.php?t=195557

Teasdale 01-26-2009 03:13 PM

OK- I saw that; it's for a different version of Ubuntu than mine (I have Ubuntu 8.04), and the very first step is different - it says that I should have check-box options when I click on screensaver from the system/menu, but those options aren't available in 8.04.

Still, I suspect something in those instructions should have something I can use. But I'm not familiar enough with terminal commands to try and re-write what's there for 8.04, or to just forge ahead and try using the commands as given. I'm not sure if they could cause some damage. My stupidity in thinking it would be easy enough to switch back to gnome-screensaver is what got me into this mess, I don't dare start testing Dapper commands in the terminal without knowing what I'm doing.


All times are GMT -5. The time now is 08:49 PM.