LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   I can't make screen size changes "stick" -- they're always set back after a reboot (http://www.linuxquestions.org/questions/ubuntu-63/i-cant-make-screen-size-changes-stick-theyre-always-set-back-after-a-reboot-623735/)

PTrenholme 02-25-2008 11:43 AM

I can't make screen size changes "stick" -- they're always set back after a reboot
 
Every time I reboot I have to go to "System Settings -> Display" and reset my screen size to 1680x1050 because it's seems to be reset to 1152x864 by the reboot.

I tried changing the /etc/usplash.conf file to
Code:

$ cat /Ubuntu/etc/usplash.conf
# Usplash configuration file
xres=1680
yres=1050

but that made no difference.

I've also looked at /etc/kde3/ et ales and been unable to find any place where the screen size is forced.

Oh, I also ran dkpg to reset xorg.conf, but that, too, made no difference.

Note, please, that the display works fine at 1680x1050 and the display configuration tool has no problem setting that resolution, so xorg.conf must be reasonably correct.

So, friends, any suggestions?

shadowsnipes 02-25-2008 12:12 PM

What does the "Screen" section of your xorg.conf say?

PTrenholme 02-25-2008 03:13 PM

Code:

Section "Screen"
        Identifier      "Default Screen"
        Device          "Intel 845G/GM"
        Monitor        "Sceptre"
        Defaultdepth    24
        SubSection "Display"
                Depth  24
                Virtual 1920    1440
                Modes          "1600x1200@60" "1400x1050@60"  "1792x1344@60"  "1400x1050@60" "1856x1392@60"  "1280x960@60"  "1920x1440@60"  "1280x1024@60"  "1280x960@60"  "1280x1024@60"  "1152x864@60"  "1024x768@60"  "832x624@60"    "800x600@60"    "640x480@60"
        EndSubSection
EndSection

As I said, the setting the screen size "by hand" works with no problem. It just doesn't "stick."

jolphil 02-26-2008 07:22 AM

Hello,
I do not wish to jump this thread but I though the more information the better..
I have the exact same problem,,
jolphil

edit: BTW I use Kubuntu 7.10 rel

pbhj 02-26-2008 09:45 AM

I've found recently when trying to configure for twinview that there's some autoconfigure going on at reboot.

A working xorg.conf got reset back to a non-working one.

I've just done (in a konsole):

Code:

sudo su
chmod a-w /etc/X11/xorg.conf

.. to disable writing of the xorg.conf file ... so that's an idea but not a proper fix.

shadowsnipes 02-26-2008 11:39 AM

Quote:

Originally Posted by PTrenholme (Post 3069474)
Code:

Section "Screen"
        Identifier      "Default Screen"
        Device          "Intel 845G/GM"
        Monitor        "Sceptre"
        Defaultdepth    24
        SubSection "Display"
                Depth  24
                Virtual 1920    1440
                Modes          "1600x1200@60" "1400x1050@60"  "1792x1344@60"  "1400x1050@60" "1856x1392@60"  "1280x960@60"  "1920x1440@60"  "1280x1024@60"  "1280x960@60"  "1280x1024@60"  "1152x864@60"  "1024x768@60"  "832x624@60"    "800x600@60"    "640x480@60"
        EndSubSection
EndSection

As I said, the setting the screen size "by hand" works with no problem. It just doesn't "stick."

So if you add 1680x1050@60 to that section you can then choose that resolution, but upon reboot it is gone? Please confirm this because I want to make sure I am understanding you correctly.

It would seem that one of the startup scripts is modifying this. Taking away the write perms on the file (as mentioned above) is a workaround, but definitely not an ideal one. If you were going to do something similar I suggest that you make a backup of the config you like and then add a line at the end of your startup scripts that simply backs up the xorg.conf file (somewhere different that your previous backup) and copies your chosen backup to xorg.conf. That way no information is lost and your file will be how you want it at every boot.

However, it would be better to understand why this is happening instead of just working around it. I suggest you look through the startup scripts to try and determine what is modifying it.

It could be that even though the settings you are putting in xorg.conf appear to be safe, they might be out of spec with what your monitor/graphics card can safely produce for extended periods of time. I suggest you check the documentation for both and double check that the resolutions, color depths, horizontal and vertical syncs are all within the specs.

It could also be that the EDID that your computer is acquiring for your monitor (at every bootup) doesn't include the resolution you are trying to display. As a result, some auto sane check on your xorg.conf file decides to "fix" this for you.

I find it strange that your Screen section only shows one sync rate. What does your Monitor section say? Do you really only have one sync rate?

My Monitor and Screen Sections look like (comments removed)
Code:

Section "Monitor"
    Identifier    "My Monitor"
    HorizSync      31.5 - 60.0
    VertRefresh    60.0 - 75.0
EndSection

Section "Screen"
    Identifier    "Screen 1"
    Device        "VESA Framebuffer"
    Monitor        "My Monitor"
    DefaultDepth    24
    SubSection    "Display"
        Depth      8
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      16
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      24
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      32
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
EndSection


PTrenholme 02-26-2008 02:22 PM

I believe that the problem is that, someplace in the boot-up scripts, the resolution is being set to the value I was using before I bought the Sceptre monitor. (The 1152x864 was the resolution I set when I installed Gutsy on my older system.) But I can't find any script where those values are used.

I went back and regenerated the xorg.conf file using the dkpg tool, and I still have the same problem, although the section in question now looks like this:
Code:

Section "Monitor"
        Identifier      "Sceptre"
        Vendorname      "Plug 'n' Play"
        Modelname      "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
  modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@75" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
  modeline  "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
  modeline  "1920x1440@60" 234.0 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync
        Gamma  0.65
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Intel"
        Monitor        "Sceptre"
        Defaultdepth    24
        SubSection "Display"
                Depth  24
                Virtual 1920    1440
                Modes          "1600x1200@60"  "1600x1200@75"  "1600x1200@65"  "1600x1200@70" "1400x1050@75"  "1792x1344@60"  "1400x1050@60"  "1856x1392@60"  "1280x960@75"  "1920x1440@60" "1280x1024@60"  "1280x960@60"  "1280x1024@75"  "1152x864@75"  "1024x768@60"  "1024x768@70"  "1024x768@75"    "832x624@75"    "800x600@60"    "800x600@75"    "800x600@72"    "800x600@56"  "640x480@75"    "640x480@72"    "640x480@60"
        EndSubSection
EndSection

Oh, notice the "gamma 0.65" in the "Monitor" section. I set that in the System Settings screen, and it took.

Anyhow, I'd be really surprised if the problem was in the xorg.conf file.

But, just for the sake of completeness, I'm going to "import" the screen and monitor sections of the xorg.conf file I use on my Fedora system too see if that makes any difference. Look for my next post for an update.

PTrenholme 02-26-2008 03:26 PM

Well, back on Kubuntu with the Fedora xorg.conf, and no change to the need to reset the resolution after reboot. :(

I do notice, though, that the login screen size (from kdm, I presume) is also incorrectly set. But that size is not specified anywhere that I can find. Any clues, anyone? :scratch:

For completeness, here's the current xorg.conf from /etc/X11 on my Kubuntu system:
Code:

# xorg.conf (xorg X Window System server configuration file)

Section "InputDevice"
        Identifier      "Micro Inovations"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"    "us"
EndSection

Section "InputDevice"
        Identifier      "Logitech Thumbwheel Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"        "/dev/input/mice"
        Option          "Protocol"      "ImPS/2"
        Option          "ZAxisMapping"  "4 5"
        Option          "Emulate3Buttons"      "true"
EndSection

Section "Device"
        Identifier      "945G"
        Boardname      "intel"
        Busid          "PCI:0:2:0"
        Driver          "intel"
        Screen  0
EndSection

Section "Monitor"
        Identifier      "Sceptre"
        Vendorname      "Plug 'n' Play"
        Modelname      "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
  modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@75" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
  modeline  "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
  modeline  "1920x1440@60" 234.0 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync
        Gamma  0.65
EndSection

Section "Screen"
        Identifier      "LCD"
        Device          "945G"
        Monitor        "Sceptre"
        Defaultdepth    24
        SubSection "Display"
                Depth  24
                Virtual 1920    1440
                Modes          "1600x1200@60"  "1600x1200@75"  "1600x1200@65"  "1600x1200@70"  "1400x1050@75"  "1792x1344@60"  "1400x1050@60" "1856x1392@60"  "1280x960@75"  "1920x1440@60"  "1280x1024@60"  "1280x960@60"  "1280x1024@75"  "1152x864@75"  "1024x768@60"  "1024x768@70"  "1024x768@75"    "832x624@75"    "800x600@60"    "800x600@75"    "800x600@72"    "800x600@56"    "640x480@75"    "640x480@72"    "640x480@60"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
  screen 0 "LCD" 0 0
        Inputdevice    "Micro Inovations"
        Inputdevice    "Logitech Thumbwheel Mouse"
EndSection

Section "Module"
        Load            "glx"
        Load            "GLcore"
        Load            "v4l"
EndSection
Section "ServerFlags"
EndSection

<edit>
Wait a second: I just looked at the xorg.conf I posted, and it doesn't look like the one I copied from my Fedora system. The "modline" and "modes" are different. :scratch: (I didn't review them before posting, just cut them from a terminal window and pasted.)

Here, for example, is what the "Screen" section should have been:
Code:

Section "Screen"
        Identifier "Screen0"
        Device    "845G"
        Monitor    "Sceptre"
        DefaultDepth    24
        SubSection "Display"
                Depth    24
                Virtual 1920    1200
                Modes          "1680x1050"    "1600x1024"    "1920x12000"    "1440x900"      "1920x1200"    "1440x900"      "1280x800"    "1280x720"      "1280x768"      "1280x800"      "1280x720"      "1280x768"      "1280x854"      "1152x768"      "800x600"
        EndSubSection
EndSection

So it seems that Kubuntu is automatically reseting the modes and modline entries during the boot, over-riding my "by hand" changes.

(The values being set are a subset of the correct values that should have been returned by the "plug and play" settings.)

The monitor claims to be a "Plug and Play" device, and I'm now suspecting that Kubuntu's handling of P&P monitors is, um, less than ideal.
</edit>

pbhj 02-26-2008 08:28 PM

So whilst it doesn't solve the mystery of where the resolution is being set from (an overzealous failsafe mechanism I think) ... did you try setting a working xorg.conf to not be writable?

You might also look at xrandr which I think can be used to force your desired screen resolution at startup.

PTrenholme 02-26-2008 09:03 PM

I'll try setting the sticky bit on xorg.conf. I don't think that making it unwritable would work, since the boot process is running as root.

I just thought to look at all of the /etc/X11/xorg.conf files, and it looks like every time I set xorg.conf by hand, the boot "bumped" it to a backup. Here's what I found: (I'm on my Fedora system right now.)
Code:

$ ls -l /Ubuntu/etc/X11/xorg*
-rw-r--r-- 1 root root 3579 2008-02-26 14:13 /Ubuntu/etc/X11/xorg.conf
-rw-r--r-- 1 root root 2854 2008-02-26 14:01 /Ubuntu/etc/X11/xorg.conf~
-rw-r--r-- 1 root root 1810 2008-02-12 10:41 /Ubuntu/etc/X11/xorg.conf.1
-rw-r--r-- 1 root root 2443 2008-02-25 06:35 /Ubuntu/etc/X11/xorg.conf.10
-rw-r--r-- 1 root root 4851 2008-02-25 08:05 /Ubuntu/etc/X11/xorg.conf.11
-rw-r--r-- 1 root root 4885 2008-02-25 08:30 /Ubuntu/etc/X11/xorg.conf.12
-rw-r--r-- 1 root root 4885 2008-02-25 14:12 /Ubuntu/etc/X11/xorg.conf.13
-rw-r--r-- 1 root root 2126 2008-02-26 14:13 /Ubuntu/etc/X11/xorg.conf.14
-rw-r--r-- 1 root root 4281 2008-02-12 10:42 /Ubuntu/etc/X11/xorg.conf.2
-rw-r--r-- 1 root root 4281 2008-02-21 12:58 /Ubuntu/etc/X11/xorg.conf.20080221125844
-rw-r--r-- 1 root root 4405 2008-02-25 06:32 /Ubuntu/etc/X11/xorg.conf.20080225063208
-rw-r--r-- 1 root root 2515 2008-02-21 14:06 /Ubuntu/etc/X11/xorg.conf.3
-rw-r--r-- 1 root root 4990 2008-02-21 15:07 /Ubuntu/etc/X11/xorg.conf.4
-rw-r--r-- 1 root root 4990 2008-02-21 15:09 /Ubuntu/etc/X11/xorg.conf.5
-rw-r--r-- 1 root root 4405 2008-02-21 15:10 /Ubuntu/etc/X11/xorg.conf.6
-rw-r--r-- 1 root root 4405 2008-02-21 16:23 /Ubuntu/etc/X11/xorg.conf.7
-rw-r--r-- 1 root root 4405 2008-02-23 13:23 /Ubuntu/etc/X11/xorg.conf.8
-rw-r--r-- 1 root root 4405 2008-02-25 05:34 /Ubuntu/etc/X11/xorg.conf.9

$ diff /Ubuntu/etc/X11/xorg.conf /Ubuntu/etc/X11/xorg.conf.14
23,27c23,26
<      Identifier      "945G"
<      Boardname      "intel"
<      Busid          "PCI:0:2:0"
<      Driver          "intel"
<      Screen  0
---
>      Identifier  "945G"
>      Driver      "intel"
>      VendorName  "Intel"
>      BoardName  "Intel Corporation 82945G/GZ Integrated Graphics Controller"
31,59c30,42
<      Identifier      "Sceptre"
<      Vendorname      "Plug 'n' Play"
<      Modelname      "Plug 'n' Play"
<  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
<  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
<  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
<  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
<  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
<  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
<  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
<  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
<  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
<  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
<  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
<  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
<  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
<  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
<  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
<  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
<  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
<  modeline  "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
<  modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
<  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
<  modeline  "1600x1200@75" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
<  modeline  "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
<  modeline  "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
<  modeline  "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
<  modeline  "1920x1440@60" 234.0 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync
<      Gamma  0.65
---
>      Identifier  "Sceptre"
>      VendorName  "Sceptre"
>      ModelName    "SceptreX22WG-1080P"
>      modeline "640x480x0.0"    31.50  640  656  720  840  480  481  484  500 -hsync -vsync
>      modeline "720x400x0.0"    28.32  720  738  846  900  400  412  414  449 -hsync +vsync
>      modeline "800x600x0.0"    40.00  800  840  968 1056  600  601  605  628 +hsync +vsync
>      modeline "832x624x0.0"    57.28  832  864  928 1152  624  625  628  667 -hsync -vsync
>      modeline "1024x768x0.0"    78.80  1024 1040 1136 1312  768  769  772  800 +hsync +vsync
>      modeline "1152x864x0.0"  108.00  1152 1216 1344 1600  864  865  868  900 +hsync +vsync
>      modeline "1280x1024x0.0"  135.00  1280 1296 1440 1688 1024  1025 1028  1066 +hsync +vsync
>      modeline "1920x1080x0.0"  148.50  1920 2008 2096 2180 1080  1083 1089  1115 -hsync +vsync
>      Gamma        0.65
>      Option      "dpms"
63,66c46,49
<      Identifier      "LCD"
<      Device          "945G"
<      Monitor        "Sceptre"
<      Defaultdepth    24
---
>      Identifier "LCD"
>      Device    "945G"
>      Monitor    "Sceptre"
>      DefaultDepth    24
68,70c51,53
<              Depth  24
<              Virtual 1920    1440
<              Modes          "1600x1200@60"  "1600x1200@75"  "1600x1200@65"  "1600x1200@70" "1400x1050@75"  "1792x1344@60"  "1400x1050@60"  "1856x1392@60"  "1280x960@75"  "1920x1440@60" "1280x1024@60"  "1280x960@60"  "1280x1024@75"  "1152x864@75"  "1024x768@60"  "1024x768@70"  "1024x768@75"    "832x624@75"    "800x600@60"    "800x600@75"    "800x600@72"    "800x600@56"  "640x480@75"    "640x480@72"    "640x480@60"
---
>              Depth    24
>              Virtual 1920    1200
>              Modes  "1680x1050" "1600x1024" "1920x12000" "1440x900" "1920x1200" "1440x900" "1280x800" "1280x720" "1280x768" "1280x800" "1280x720" "1280x768" "1280x854" "1152x768" "800x600"
76c59
<  screen 0 "LCD" 0 0
---
>      Screen      0  "LCD" 0 0
86,87d68
< Section "ServerFlags"
< EndSection


PTrenholme 02-27-2008 08:22 AM

An addendum: Before trying the "no write" option, I thought I'd try pbhj's suggestion re xrandr. (Thank you pbhj!)

xrandr (and grandr) did work to quickly change the screen resolution, but newly created windows on the screen seem to "think" that they're being rendered in the smaller window. After they're created, they can be resized to the larger screen. That's a pain, but the real pain is that the task bar (which I keep at the bottom of the screen) ends up in the lower left quadrant, and is not movable. It's also some shorter than the whole screen width. (I did move it to the top screen position for now, but that, too, is a pain since I ware bifocals, and need to tilt my head way back to read the task bar in that position.)

pbhj 02-27-2008 07:05 PM

re: sticky bits and unwritable files
 
Quote:

Originally Posted by PTrenholme (Post 3070982)
I'll try setting the sticky bit on xorg.conf. I don't think that making it unwritable would work, since the boot process is running as root.

Just to clarify: the sticky bit is set on a directory to protect it's files from deletion by unauthorised users (that's the short version).

Unless root (or a script run as root) does a "chmod u+w" on a file it remains unwritable. As ever root has ultimate power but is still confined by the settings it puts in place itself.

FWIW.

PTrenholme 02-28-2008 06:37 AM

Quote:

Originally Posted by pbhj (Post 3072036)
Just to clarify: the sticky bit is set on a directory to protect it's files from deletion by unauthorised users (that's the short version).

Unless root (or a script run as root) does a "chmod u+w" on a file it remains unwritable. As ever root has ultimate power but is still confined by the settings it puts in place itself.

FWIW.

Sometimes (usually in older distributions) the sticky bit can also be placed on a file to prevent any changes in the file unless you are the file owner or a privileged user. Kubuntu, unfortunately for my idea, does not honor the sticky bit on files and, in any case, root is a privileged user.

So when I tried it, changing the owner and group of xorg.conf me, making it read only, and setting the sticky bit, the boot process blithely ignored all that, created the backup file as owned by root, and added its own (improperly generated) xorg.conf file.

Now I'm looking at the Python programs in /usr/share/python-support/guidance-backends/ and thinking about adding a new option that /etc/X11/Xsession.options can read that will tell the X startup to keep its grubby hands off my hand-crafted and tested xorg.conf file.

When I get time to do so . . .

pbhj 02-28-2008 07:31 PM

That's weird cos it worked for me! Setting the file read only I mean. It seems a bit of a stretch that the distro designers would not only enforce a failsafe rewrite but also enabling writing of the file that could only have been disabled by root level user ... that's sick!

PTrenholme 02-28-2008 08:00 PM

Quote:

Originally Posted by pbhj (Post 3073338)
That's weird cos it worked for me! Setting the file read only I mean. It seems a bit of a stretch that the distro designers would not only enforce a failsafe rewrite but also enabling writing of the file that could only have been disabled by root level user ... that's sick!

O.K., I'll give it another shot: when I made the changes in the file permissions for the test I was logged in to my Fedora system, and my numeric user id in that system is 1000, not 500, since Fedora starts the user list at 1000, so I may have confused Kubuntu with an unassigned user and group number. (I did specify 500, but I'm not sure if that "took.")

More later -- I have a process running on my Fedora system right now that will take a few more hours to complete, and then I'll probably need to go see if my wife remembers what I look like, so check here tomorrow (afternoon in GB time) to see what happened. (With the problem -- I'll try to deal with the wife on my own, thank you.)


All times are GMT -5. The time now is 03:20 PM.