LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-26-2010, 08:25 PM   #1
ibkhalil
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Rep: Reputation: 0
Question How to solve black screen on ubuntu ue 2.6


Hi everyone,
I've tried installing ubuntu 2.6 on my 32-bit samsung R60 notebook. when the computer tries to boot from the CD, it goes in to black screen and won't boot again. I tried hitting F6 and selected one of the options (nomodset). It worked at first and i installed it successfully. But when i tried to boot from the hard disk, the same thing happened again, it went black screen and never boot up again.
Can anyone help me out, please!?

I. B. Khalil
 
Old 08-27-2010, 02:38 PM   #2
arochester
Member
 
Registered: May 2006
Location: Scotland
Distribution: Debian Squeeze Xfce
Posts: 567

Rep: Reputation: 79
Look at this: "HOW TO - Samsung R60 plus - ubuntu Hardy Heron 8.04 installation" - http://ubuntuforums.org/showthread.php?t=839000

It's 2 years old. Scroll down to "Installation". The key is probably: noapic
 
Old 09-04-2010, 05:38 PM   #3
ibkhalil
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Red face

I tried it, but after pressing F6,i tried the noapic but did not work. so i selected nomodset and it worked,i installed it successfully. after the installation was done, i rebooted and selected 'ubuntu generic' at the GRUB bootloader. instead of seeing some code and screen flashes, all i could see was a black screen. as a newbie, i tried all my best, even the alt and F2 didn't work. what else can i do? i love Ubuntu and that's why i'm writing this , more help please!

I. B. Khalil
 
Old 09-04-2010, 05:41 PM   #4
ibkhalil
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Red face Frustrated : it didn't work !

I tried it, but after pressing F6,i tried the noapic but did not work. so i selected nomodset and it worked,i installed it successfully. after the installation was done, i rebooted and selected 'ubuntu generic' at the GRUB bootloader. instead of seeing some code and screen flashes, all i could see was a black screen. as a newbie, i tried all my best, even the alt and F2 didn't work. what else can i do? i love Ubuntu and that's why i'm writing this , more help please!

I. B. Khalil
 
Old 09-04-2010, 09:53 PM   #5
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
If you need more help, why did you mark this thread Solved?

Please take the "Solved" prefix off of this thread if you need more help.
 
Old 09-04-2010, 10:07 PM   #6
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
At the grub prompt highlight the generic entry hit the e key to edit, add nomodset to the end of the linux/kernel line and then boot
 
Old 09-06-2010, 08:57 AM   #7
ibkhalil
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Original Poster
Rep: Reputation: 0
It worked

Yes! I added nomodeset to the GRUB and it worked, my ubuntu is working very well now, thanks alot. but how do i make it a permanent fix? Or do i always have to add the nomodeset on boot?

I. B. Khalil
 
Old 09-06-2010, 10:26 AM   #8
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
assuming you are using grub2 Open up a terminal by clicking on applications/accessories/terminal type the following:
Quote:
sudo gedit /etc/default/grub
add nomodest to the following line
Quote:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to look like this
Quote:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
exit and save. Then in the terminal run
Quote:
sudo update-grub
Here is a link to configuring grub2 https://help.ubuntu.com/community/Gr...c/default/grub

If your using grub legacy then edit the ubuntu entry in /boot/grub/menu.lst
 
Old 09-06-2010, 05:14 PM   #9
ibkhalil
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Appreciation

jst wanna say thanks to u,i followed the steps and now my ubuntu is working perfectly, thanks so much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 10.04 - black screen on boot giammy Ubuntu 8 05-06-2010 07:09 AM
screen is black on ubuntu 9.04 harvey746 Linux - Newbie 2 05-11-2009 05:41 PM
ubuntu : black screen on startup kvs Linux - Newbie 5 05-10-2009 02:49 AM
Installing Ubuntu (black screen) Starius Linux - Newbie 4 01-17-2008 12:46 PM
Ubuntu 7.04 won't start - black screen... jamiepane Ubuntu 2 09-08-2007 01:41 AM


All times are GMT -5. The time now is 01:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration