LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   How to record the sound output (wave out) instead of input (mic/line-in) (http://www.linuxquestions.org/questions/ubuntu-63/how-to-record-the-sound-output-wave-out-instead-of-input-mic-line-in-571414/)

Thirteenth Zodiac 07-22-2007 03:17 PM

How to record the sound output (wave out) instead of input (mic/line-in)
 
Hello all,

I just installed Ubuntu 7.04 - Feisty Fawn and have pretty much set things up to a satisfying degree. I compiled the most recent ALSA drivers and installed JACK, adjusted my volume controls to unmute everything in playback and recordnig, etc. Everything works fine: I can hear system sound effects, music from cds or files, and I can plug my mic or guitar through the mic input and hear what I'm saying/playing through my speakers. I can record said input as well using Audacity (or whatever else, probably), and play it back without problem. The only thing I don't know how to do is how to record what's playing through my speakers (for instance a CD, a MIDI file, etc.). I am not asking for tools to rip cd's, I really need the ability to record the "wave out" for my music production needs. Is it a matter of setting up JACK appropriately, or is it about selecting something else in my Volume control?

My system is a 1.8ghz Sempron 3200 with onboard Intel HD sound card. (I also have an M-Audio Audiophile USB sound card, but I'd like to master the basic setup before adding extra layers of complexity ;)). All recording volumes ("Capture" and "Capture 1") are unmuted and set to max, in Switches "Headphones" is checked and there is an extra "IEC958", which I have no idea what it is, that is unchecked, and in Options, I have two Input Sources which I can set to Front Mic, Mic, Line, or Aux. Both are set to Front Mic (there are two mic inputs on my case, one in front, one in back...I am using the front, naturally). My first guess was to change the input source to "Wave out" or "What you hear" or some sort, but it's not listed. :/ Any help would be greatly appreciated!

Thirteenth Zodiac 07-22-2007 09:16 PM

Well, I found a sort of workaround, if anyone's interested. I plugged a regular audio cable, male 1/8'' on both ends, from the Line Out to the Line In. Not optimal, but I can manage that. :(

shaunw 08-11-2007 11:34 PM

Recording the mix
 
On the record source screen you should be able to select a
record source e.g. line in, cd, microphone etc. One of the items
on this screen should be mix which records whatever is playing
through the sound chip.
Open the Alsa mixer (double click on the speaker icon) go to
the Edit->Preferences menu and add all the recording sources you
need.

Thirteenth Zodiac 08-13-2007 04:13 PM

Thanks for the reply.

I have no "mix" entry in the input source selection. I only have Front Mic, Mic, Line-in, and Aux. (which are all correctly mapped to the various physical inputs on my box). Could this be an issue with my hardware/driver? I'm using the onboard sound (Realtek something).


All times are GMT -5. The time now is 03:05 AM.