LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   How to name workspaces in Ubuntu 11.04 (Natty) running Gnome without Unity (http://www.linuxquestions.org/questions/ubuntu-63/how-to-name-workspaces-in-ubuntu-11-04-natty-running-gnome-without-unity-878532/)

adrian_higgs 05-03-2011 06:30 AM

How to name workspaces in Ubuntu 11.04 (Natty) running Gnome without Unity
 
Hi

I've done a bit of searching and failed to find an answer to this, so please, if I've missed something, do point me to it.

I've just installed Ubuntu 11.04 on my netbook. Having had a bit of a play with Unity I found it not to my taste, so I've switched to "Ubuntu Classic" - Gnome without Unity - on the login screen.

For a while now I've organised my work using the Workspace Switcher Gnome applet. I use five workspaces, each named to identify the type of stuff that goes on in it.

11.04 comes with Workspace Switcher version 2.32.1 - right clicking it and clicking on Preferences gives a stripped down preferences dialogue, no longer including fields allowing the user to define workspace names. Ubuntu 10.04, for example, uses Workspace Switcher 2.30.2 which did allow for workspace names to be defined via the Workspace Switcher Preferences dialogue.

I'd really like to be able to define workspace names and have them show in the Workspace Switcher in the panel. Can anyone suggest any solutions?

Many thanks,

Adrian

timj 05-03-2011 10:42 AM

How to name workspace in classic desktop Unbuntu 11.04
 
I use 12 workspaces and being able to name them is very important. About half of the names do not change, but others do depending on the tasks I am currently working on.

In previous versions of Ubuntu I have had to disable any 'Visual Effects' to get this functionality to work. When 'Visual Effects' were enabled, the 'Workspace Properties' menu did not include the ability to set the workspace names. In 11.04, "Visual Effects" are not available in 'System->Preferences->Appearance' menu.

I noticed that information about the workspaces is in the following XML: .gconf/apps/panel/applets/applet_2/prefs/%gconf.xml. There is a entry 'name="display_workspace_names"' (with no 'value') which leads me to believe that some thought was put into supporting workspace names. This file appears to be over-written with the latest info when you log out, so editing this file is not really an option.

adrian_higgs 05-03-2011 11:29 AM

Ah yes. I recall having to turn off visual effects now. And your comment has helped me find the fix, TimJ.

At the login screen, once you've clicked on the user name you wish to log in as, you'd get the session menu at the bottom of the screen (third menu from the left in the bottom bar). Select "Ubuntu Classic (No effects)" and log in.

You should now be able to define workspace names as in earlier Ubuntu releases.

Thanks Tim!

Adrian

adrian_higgs 05-03-2011 11:32 AM

And... *twelve* workspaces. Woah! :-)

timj 05-03-2011 05:19 PM

The problem is that the name of the workspace is no longer displayed in the 'Workspace Switcher' applet. If you hold your mouse over the applet it displays the name of the workspace: 'Click to switch to "Mail"'. It also shows the current workspace name when you use the ctl-alt-arrows keys to select a workspace.

I want to be able to see the name in the 'Workspace Switcher' applet, then a change of workspace is just single mouse click away.

Part of the reason I need the names to be displayed is that about 1/3 of them change on a regular basis. In the early days of using a window manager that supported workspaces, I was limited by physical memory on the host, that is no longer a restriction. 12 is the number that work 'for me'.

adrian_higgs 05-04-2011 05:16 AM

That's odd. Now I'm logging into Gnome without effects, mine is displaying the workspace names in the applet just as on my previous version of Ubuntu.

I take it you've ticked the "Show workspace names in switcher" option in the Workspace Switcher Preferences?


All times are GMT -5. The time now is 12:07 AM.