LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   how to hide gnome menu bar icons (http://www.linuxquestions.org/questions/ubuntu-63/how-to-hide-gnome-menu-bar-icons-818671/)

Krajisnik 07-08-2010 06:45 AM

how to hide gnome menu bar icons
 
Hi,

I'm looking for a way to hide the icons in the Gnome menu bar.
Searching on the net didn't help me ...

The only thing i've found is the gconf-editor and unchecking /desktop/gnome/interface/menus_have_icons, but that only affects the System menu and not Applications and Places...

Example:
http://i261.photobucket.com/albums/i...plications.jpg
Must be like:
http://i261.photobucket.com/albums/i...enu_system.jpg

Anyone knows how to disable them ?

I'm running Ubuntu 10.04LTS with Gnome 2.30

Thanks in advance.

zornslemma 07-08-2010 11:15 PM

Re: how to hide gnome menu bar icons
 
I just had a play around on my Ubuntu 10.04 system and it seems you can remove the menu completely by right clicking on it and choosing "Remove from panel". It isn't obviously possible to remove individual menus, though I might guess if you remove all the items from a menu in the menu editor (right click the menu title and choose "Edit menus") it will disappear. I didn't like to try it myself... :-)

Failing that, the Help button in the edit menus dialog brings up "Customising the Panel Menubar" which includes a link to a System Administration Guide which has lots of information. I suspect you need to hand-edit some *.menu files.

I hope this is some help at least.

Steve

floorripper 11-20-2012 05:09 AM

disable icons gnome menu| right click menu | ubuntu 10.04 |
 
1 Attachment(s)
Hallo,

I have been facing this issue after I have installed multiboot utility for usb keys. Multi-system.
http://www.pendrivelinux.com/multibo...sb-from-linux/
It has asked me something like " do you want to enable gnome icons" ? And I have been thinking that it is for the bootable usb stick. So I didm yes! But no, it has twisted my ubuntu desktop settings.

Because the normal way from CLI,did not work, sudo gconf-editor, tick, and un-tick some fields in /desktop/gnome/interface/menus_have_icons

I have installed UBUNTU-TWEAK
http://www.ubuntugeek.com/how-to-ins...ucid-lynx.html
Code:

    sudo add-apt-repository ppa:tualatrix/ppa
    sudo apt-get update
    sudo apt-get install ubuntu-tweak

and I have "un-selected" one field with icons in menu. Please see attached picture. And it has worked so far fine, the stupid icons from ubuntu right-click are gone!!!


All times are GMT -5. The time now is 12:05 AM.