LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   How to edit Firefox global settings on Edubuntu LTSP server (http://www.linuxquestions.org/questions/ubuntu-63/how-to-edit-firefox-global-settings-on-edubuntu-ltsp-server-892778/)

jeffmd55 07-20-2011 01:54 PM

How to edit Firefox global settings on Edubuntu LTSP server
 
I recently did a clean install of Edubuntu 11.04 (Natty Narwhal) with LTSP. After installing, I found that Firefox was on version 5. I've done customizations to Firefox in 3.6.x (proxy settings, etc) on other LTSP servers (Ubuntu 9.10) and have always used the firefox.js file located in /usr/lib/firefox-3.6.x/defaults/pref. When I looked, it doesn't exist in this directory. There is a syspref.js and I've added lines to that, but it doesn't seem to pull from that file. Is there a js file somewhere that I can use to set global changes to Firefox for all users on LTSP? I'm looking to set things like proxy settings, cache directories and sizes, etc....Any help is appreciated!

markush 07-29-2011 02:58 PM

Hello,

maybe you're looking for this http://kb.mozillazine.org/Profile_folder_-_Firefox information.

Markus

jeffmd55 02-01-2012 10:16 AM

Found a fix...
 
I know this is a long time coming, but a little while after posting this I decided to go back to the LTS version of Ubuntu (Karmic 10.04). I still struggled with the disk caching issue, but finally found a resolution that seems to be working the way I'd expect it to AND it applies to Firefox 3.6 and up...(have tested 8.0 and works). So the trick is to create your locked preferences file and name it syspref.js and copy it into /etc/firefox/pref, but you need to be careful that the preferences you are trying to set are defaults in about:config, otherwise once FF references the syspref.js and stumbles upon a preference not in about:config, it stops there and doesn't load the remaining locked preferences. I found this out when trying to set a local cache directory as /tmp, there was no browser.cache.disk.parent_directory by default in about:config, so it would stop applying the locked preferences when it hit this. So instead, I decided to just disable caching altogether and by removing the preferences not in about:config, it then set correctly all of the preferences in syspref.js. Sure it may drive up network usage, but at least now my file servers aren't getting hit so hard with the caching of pages.


All times are GMT -5. The time now is 10:01 PM.